Title: A Short Course in Project Management

advertisement
A Short Course in Project Management
Understanding What Defines a Project
In order to succeed as a project manager it requires that you complete your projects on
time, finish within budget, and make sure your customers are happy with what you
deliver. The four main factors to consider in any project are therefore: Time, Cost, Scope
and Quality.
With the use of MS Project, the purpose of this presentation will assist you in becoming
familiar with the following elements of the software program:
 Getting Started with Project
 Introducing the Project Calendar
 Entering the Project Properties
 Creating a Task List
 Setting up People Resources
Getting Started with Project
In this exercise, you will create a New Project Plan using the Project Guide.
1. On the file menu, click the New command
The New Project task pane appears.
2. Under New, click on the Blank Project link.
Ms Project opens a new window with the New Project task pane being replaced by the
Tasks pane of the Project Guide:
Figure 1. MS Blank Project Window
It is important to familiarize yourself with the Tasks pane (Found in the left column of
the main window). This pane is very useful for directing the user to various activities
such as defining general work times, listing the project tasks, organizing the tasks into
phases and/or setting deadlines for tasks.
3. Using the Tasks pane, click the Define the project link.
A window will appear on screen.
4. In the next pane that appears, in the Date box click the down arrow.
This will open a small monthly calendar.
The default setting uses the current date as the project start date.
5. Click Save and go to Step 2, located at the bottom of the pane.
6. This step has to do with the Project Server (expand if necessary).
Click No in the Step 2 pane and go to Step 3.
7. Click Save and Finish in the Step 3 pane.
The task activity list will reappear on screen, in the Project Guide pane.
This completes the ‘Define the Project activity’.
8. To save, Click on the Save button, found above along the toolbar.
This will automatically open the Save As dialog box.
The default location for the Project 2003 Step by Step folder is…
9. In the File Name box, type TEAM 2006/07 Project Name.
10. Click the Save button to close the Save As dialog box.
11. To automatically save the active project plan at defined time intervals, click
on the Tools menu and select Options.
In the Options dialog box, click the Save tab. Choose the time interval you
prefer and select the Save Every check box.
Introducing the Project Calendar
The purpose of the project calendar is to define the general working and nonworking time
for tasks.
1. In the Tasks pane, click the Define general working times link.
This will open the Project Working Times pane, with a preview of a weekly
schedule – Sunday through Saturday, starting at 8am.
The Preview Working Time is designated by Working time (blue) and
Nonworking time (yellow), where Project can schedule tasks within the blue
region based on the settings in the project calendar.
Figure 2. Preview Working Time Window.
The Hint icon can prove to be very useful when using the Project Working Times
pane.
2. In the project Working Times pane, click on the down arrow of the Select a
calendar box.
The following is a list that will appear which includes the three base
calendars provided by Project.
 Standard: Monday – Friday, 8 A.M. to 5 P.M., 1 hour lunch break.
 24 hours: Does not include ‘Nonworking’ time.
 Night Shift: Same as Standard PLUS Monday – Friday 11 P.M to 8
A.M., including Saturday 12 A.M to 8 A.M.
Type About Calendars in the box labeled ‘Type a question for help’ to learn
more about the features and options offered.
3. At the bottom of the pane, click the Save and go to Step 2 link.
This opens a second pane which allows the users to change the project’s
calendar working time for a specific day of every week.
This allows the group members to create a project calendar surrounding the
various TEAM members’ schedules.
4. At the bottom of the pane, click the Save and go to Step 3 link.
A third pane will appear which allows the users to enter the nonworking days
for the project calendar.
5. Click on the Change working time link in the pane.
The Project Guide displays the Change Working Time dialog box. This is
the same dialog box you would see if you clicked the Change Working Time
command on the Tools menu.
6. Using the calendar below the Select Date(s) label, scroll up or down to the
current month. (September 2006).
To schedule a particular day off work, well in advance, select the known date,
such as September 16 for Queen’s Homecoming.
7. Under the Set selected date(s), click Nonworking time:
This date is now scheduled to be a nonworking time for the project.
In the dialog box, the data appears underlined and will be formatted to gray
color, indicating the nonworking time.
Figure 3. Project Working Time Selection.
8. Click OK to close the Change Working Time dialog box.
9. At the bottom of the pane, click the Save and go to Step 4 link.
Be sure to take a moment and read the text in the Define Time Units pane.
As a result of not changing the default working times for the project calendar,
you should not change these units.
10. At the bottom of the pane, click the Save and go to Step 5 link.
The final pane of the Project Working Times activity will appear on screen.
11. Click the Save and Finish link.
The Tasks activity list will reappear in the Project Guide pane.
Entering the Project Properties
It is important to keep track of several file properties. Some of the information that can be
entered includes:
 Statistics (Opening and Closing file for revision)
 Project Title
 Author(s)
 Keyword to support a file search
1.
2.
3.
4.
5.
6.
Going to the File menu, select Properties from the list.
In the Properties dialog box click on the Summary tab.
In the Subject box, type ___TEAM PROJECT________.
In the Author box, type _____TEAM NAME/NUMBER_______.
In the Manager box, type the Project Manager’s name or leave blank for now.
Select the Save preview picture check box.
The next time this file appears in the Open dialog box with the Preview
option selected, a small image showing the first few tasks of the project will
be displayed.
Figure 4.
7. Click OK to close the dialog box.
Creating a Task List
Tasks are the most integral elements for building any project, representing the work to be
done to accomplish the goals of the project. The two primary types of tasks are summary
tasks and milestone tasks. Summary tasks represent the on-going tasks that must be
constantly finished in a defined period of time. Milestone tasks include the activities or
deliverables that have no duration but with important dates to be met.
How to Enter Tasks
1. From the Tasks pane, click the List the tasks in the project link.
This will open the List Task pane on screen.
Be sure to read the information provided on screen, this will prove to be
useful when creating a Milestone task in the future.
2. Click on the first cell under the Task Name column heading.
Label the first task as Problem Definition and press the Enter key.
Each task that is entered is given a task number, starting at 1 and incrementing
by one.
The default setting for any new task entered in Project has duration of 1 day.
The default starting date is the same as the project start date.
3. To enter further task commands below the Problem Definition, select the
following cell and enter a new task name, pressing Enter after each time.
The following list provides a brief overview of the Project Tasks:
 APSC 400 Start-Up Phase
 Prepare Project Scope of Work
 Establish Project Needs
 Conceptual + Preliminary Design
 Detailed Design
 Validation and Documentation
 Presentation for Clients
 Project Wrap-Up
Figure 4. Entering Project Tasks Window.
Specifying Task Durations
It is important to recognize at an early stage that a task’s duration does not necessarily
correlate to the elapsed time. However, at the level of sophistication we are attempting
for our schedule you can assume that it is. If a certain task is estimated to require 16
hours of work than a duration of 2 days should be entered to account for two working
days of 8 hours per day.
Estimating task durations is nearly always the most difficult step in creating a schedule.
You should always allow more time to complete a task than you think you need. One rule
of thumb is to estimate the time and then use the next largest unit of measure (i.e. if you
think it will take an hour to complete, then estimate 1 day).
The following is a table of abbreviations that can be used when working in Project.
Time Unit
minute
hour
day
week
month
Will Appear As
min
hr
day
wk
mon
User can enter
m
h
d
w
mo
The default setting for Project uses: 8 hours per day, 40 hours per week and 20 days per
month. To modify these settings:
1. Go the Tools menu and click on the Options command.
In the Options dialog box, click the Calendar tab.
2. The user is able to modify from the Calendar options, such as:
-Week starts on
-Fiscal year starting month
-Default start/finish times for a working day
-Number of hours per Day or Month
-Days per month
Click on any of the boxes listed above and either scroll through the menu or
type in the desired option.
To Enter the Duration for a task:
1. Click the desired cell below the Duration column heading for a specific task.
2. To enter a greater duration than the default of 1day, enter 3d and press Enter.
A value of 3 days will appear in the Duration field, removing the question
mark.
3. Enter the following durations for the remaining tasks:
Task ID
Task Name
Duration
Entering a Milestone Task
1. Identify a Task which is a significant event that must be reached within the
project (such as completing one phase of design) or that is forced upon the
project (such as a deadline).
*Milestones are tasks without a duration.
2. Click on the name of the identified task.
3. From the Insert menu, click New Task.
MS Project will insert a new row for the new task.
This task will also be given a new Task ID and placed within the subsequent
tasks.
The milestone will appear as a black diamond in the Gantt Chart View.
4. To insert multiple new tasks, select the multiple tasks first by holding the Ctrl
and selecting with the mouse. Then press the Insert key and Project will insert
the same number of new tasks.
5. Click on the Done link from the bottom of the List Tasks pane.
The Task pane will reappear.
6. To mark a previous task as a milestone, double-click on the task name to
display the Task Information dialog box.
Next, click on the Advanced tab and select the Mark task as milestone box.
Alternatively, the user can set the duration of the task to zero and it will
automatically become a milestone.
Figure 5. How to Enter a Milestone Task.
Organizing Tasks into Phases
When dealing with various elements of a project and closely related tasks, it becomes
very helpful to identify project phases. Summary tasks represent a grouping of related
tasks.
1. From the Tasks pane, click the Organize tasks into phases link.
2. Identify a group of tasks that can be grouped together.
3. From the Organize tasks pane, click on the Indent Tasks button.
An icon is also available from the formatting toolbar.
- Outdent and Indent buttons, respectively.
The identified task above the selected group of tasks now becomes a summary
task. A summary task bar will appear in the Gantt chart. The task name is now
formatted to be in bold type.
4. Repeat the same procedure to identify an additional group of tasks as a project
phase.
5. At the bottom of the Organize Tasks pane, click on the Done link.
Linking Tasks – Specifying Task Relationships
A very important aspect for the completion of a project is for tasks to be done in a
specific order. Due to the arrangement of tasks, some can only be completed after a
previous task is completed, creating dependence of one task on another.
Creating task dependencies allows you for a ‘smart’ schedule that adjusts automatically
when you change the finish date or duration of a task. It also allows you to find the
‘critical path’, which is the set of tasks that define the duration of the project.
There are four types of task relationships, as defined below:
The Task
relationship
Finish to Start
(FS)
Start to Start
(SS)
Finish to Finish
(FF)
Defined as
The date of completion for the
first task initiates the start date
for the following task.
This is the most common type
of dependency. A task can not
start until the prior task is
completed.
The starting date for the initial
task initiates the start date for
the following task.
Said another way, a task can
start as soon as the other task
starts.
The finish date of the
predecessor task determines the
finish date of the successor
task.
Illustrated in Gantt
chart as
Example
TEAM formation
i) Initial Group Meeting
ii) Client Meeting
iii) Project Outline
Review of Design Stage
i) Review Design
ii) Meet w AES to discuss
i) Progress Report Meeting
ii) Review Progress Report
Said another way, one task can
not finish until another
finishes.
Using the Gantt chart view the task relationships appear as the lines connecting tasks.
The following procedure demonstrates how to use different methods to create links
between several tasks to create Finish to Start (FS) relationships.
METHOD I
In the Gantt chart view type the predecessor task # into the predecessor column.
METHOD II
1. From the Tasks pane, click on the Schedule Tasks link.
2. Select the Task names for Task ID # and #.
3. From the Schedule Tasks pane, click on the Finish-to-Start icon.
There is also a Finish-to-Start icon located in the toolbar.
4. To unlink a group of tasks, or just one task from a list, then select the desired
task(s) and then click the Unlink Tasks icon from the Standard toolbar.
There is also an Unlink Tasks item found in the Edit menu.
Figure 6. Linking Dependent Tasks Pane.
METHOD III
5. To view the task information, highlight the name of a task and click the Task
Information icon from the Standard toolbar. The dialog box will appear on
screen.
6. To make a task the predecessor of another, click on the Predecessors tab in
the Task Information dialog box.
7. Select the empty cell below the Task Name column heading, then click on the
down arrow that will appear.
8. In the Task Name list, select “Task Name”, and press Enter.
9. Click OK to close the Task Information dialog box.
METHOD IV
10. The user is also able to create links between tasks by using the option
available from the task view pane right in the Gantt chart - by pointing to the
task of the “predecessors” task until the pointer changes to a four-pointed star.
11. Drag the mouse pointer up or down to the task bar of the successor task.
12. The pointer image will change to a chain link and connect the tasks.
Checking the Plan’s Duration
It is important to develop an overall understanding for the scope of your project. MS
project will determine the scheduled date of completion based on the individual task
durations and task relationships. The Project Information dialog box is helpful for
checking on the tentative project duration in detail.
1. From the Project menu, select Project Information.
This will open the dialog box containing the Project Information.
2. By clicking on the Statistics button a dialog box containing the project’s
statistics will appear.
We are mostly interested in the Current Finish Date and the Current Duration.
The duration refers to the number of working days available between the
project start date and the finish date.
This can also be verified visually from the Gantt chart.
3. Click the Close button to close the dialog box.
4. From the Project Guide toolbar select the Show/Hide Project Guide.
This will close the Project Guide.
To view the complete project, the time scale must be changed in the Gantt
chart view.
5. From the View menu, select Zoom. The dialog box will appear on screen.
6. A list of available options is presented within the dialog box.
Select Entire project and then click OK.
You should be able to see the project’s overall duration in the Gantt chart
view.
The Zoom In and Zoom Out icons can also be used from the Standard
toolbar menu.
Resources
Setting up People Resources
Setting up resources allows you to use the feature that task durations are ‘effort hours’,
rather than calendar hours. By using the resource feature, you can cause the duration of
the project to extend due to the fact that a single person is working on multiple tasks
simultaneously. There are problems in trying to use this feature in MS Project and
therefore it’s not recommended that you use this feature at this time (if you really need
this feature you will need a more advanced tool such as Primevera TM, which can handle
a task that has a different effort hour vs duration curve).
1. From the Project Guide toolbar, click on Resources.
2. From the Resources pane, click on the Specify people and equipment for the
project link.
The Specify Resources pane will appear.
The Project Guide will be the Simple Resource in view.
3. Select the last option in the list ‘Enter resources manually’.
4. From the Simple Resource Sheet view, click on the cell directly below the
Resource Name column heading.
5. Enter a contact name i.e. Dave Mody.
Click on the adjacent cell and enter the [email protected]
6. Press Enter. Project will go to the next cell for a new resource.
7. Click on the close button in the top right corner of the Project Guide pane to
close the Project Guide.
Formatting and Printing Your Plan
Formatting and Printing Reports
Reports are intended for print-previewing or printing only. The user is not able to enter or
edit data directly in a report. You can, however, edit some elements of reports such as the
text that appears in the header or the footer of the page.
1. From the View menu, click on Reports.
The Reports dialog box will open, showing six broad categories of reports
available in Project.
2. Select the first icon, Overview and click on the select button.
The Overview reports dialog box will open, showing the five predefined
reports in Project.
3. In the Overview Reports dialog box, click Project Summary, and then click
the Select button.
This will provide a summary of the project plan’s tasks, resources, costs, and
current status.
4. In order to see project statistics on the screen: Click on the Project
Information command on the Project menu, and select Statistics.
5. In the Print Preview window, click the upper half of the page with the mouse
pointer.
This will cause Project to zoom in to show the page at a better resolution.
6. To Zoom out, simply click on the screen again.
7. If you are ready to Print, click on the Print… button located along the toolbar
at the top of the page.
8. From the Print Preview toolbar, click the Close button.
The Reports dialog box will reappear.
Figure 7. Print Toolbar from Project Summary Window.
Making PDF Files of the Output
Download one of the many free tools for creating PDF files, such as PDF Factory
(www.pdffactory.com).
Download