small network infrastructure

advertisement
Compiled by DMBoudreau - 1st Year I.T. - NSCC Burridge Campus - 2012
SMALL NETWORK INFRASTRUCTURE
Two Switch & (Cisco) Router (on a stick) Checklist:
1. Name the switch(s)
(config)>hostname ‘whatever you need to name it’
2. Create 'Message of the Day' (MOTD) banner
(config)>banner motd # your name your number #
3. Avoid lookup (ie. Type in wrong command by mistake)
(config)>no ip domain-lookup
4. Create vlans.
(config)>vlan 10
(config-vlan)>name ‘whatever you need to name it’ (Note: Can’t use spaces)
#>sh vlan
5. Description vlans.
(config)>int vlan10
(config-if)>description ‘whatever you need to name it’
6. Assign ports to vlans
(config)>int fa0/1
(config-if)>switchport access vlan 10
(config-if)>switchport mode access
Compiled by DMBoudreau - 1st Year I.T. - NSCC Burridge Campus - 2012
7. Create switch Gigabit Ethernet trunking using both ports (LACP)
Assign gigabit ports to channel group
(config)>int range gi1/1-2
(config-if-range)>channel-group 1 mode active
(config-if-range)>switchport mode trunk
Trunk the channel group
(config)>int port-channel 1
(config-if)>description ‘LACP Trunk between switches’
(config-if)>switchport mode trunk
*Make sure to assign ip addresses to any PCs/Workstations/Laptops if no router-on-stick without DHCP
up to this point.
8. Create switch default gateway
(config)>ip default-gateway 'the ip number goes here'
(used in conjunction with router on stick for vlans to communicate on the router trunk)
9. Create ip address for switch management port(s) on switche(s)
(config)>int vlan99
(config-if)>ip address ‘the ip address + subnet mask goes here’
10. Create STP on a switch(s)
(config)>spanning-tree vlan 10,20,30,40,50,60,70,80,90,99 root primary
#>show spanning-tree
11. Create port trunk for Router
(config)>int fa0/23
(config-if)>description ‘trunk to whatever the router name is’
(config-if)>switchport mode trunk
12. Create interfaces for switches/vlans on Router
(config)>int fa0/0
(config-if)>no shutdown
(config)>int fa0/0.1
(config-if)>encapsulation dot1Q 1 native
(config-if)>no IP address
(config)>int fa0/0.10
(config-if)>description ‘name it whatever you need to name it’
(config-if)>encapsulation dot1Q 10
(config-if)>IP address 192.168.10.254 255.255.255.0
Compiled by DMBoudreau - 1st Year I.T. - NSCC Burridge Campus - 2012
13. Configure DHCP on Router
(config)>ip dhcp pool DHCP30 <Convention of ALL CAPS>
(dhcp-config)>Network 192.168.30.0 255.255.255.0 <Network Address + Mask>
(dhcp-config)>default-router 192.168.30.254 <Router Sub-Interface Address>
14. Setting telnet connection
(config)>user admin privilege 15 password secret
(config)>line vty 0 15
(config-line)>login local
Common commands:
#>config t
#>copy run start
(config)>exit <exits out of each config section one at a time>
(config)>end <exits all the way out>
Special Commands:
(config)>switchport trunk allow vlan all <defaults all vlans to trunk; especially useful if SOME vlans are
on the trunk but others are not and you want to revert the vlans>
Download