Command line commands

advertisement
Command line commands
Show version
Configuration
Enable
Configure terminal
Hostname
enable secret
R1(config)#ip route network-address subnet-mask {ip-address | exit-interface }
– netw.add.-cilová adresa packetů, maska, ip-přes koho/interface
R1(config)#ip route 192.168.2.0 255.255.255.0 fastethernet 0/1 172.16.2.2 –
configuration with both of exit interface and IP address
Router(config)#ip route 0.0.0.0 0.0.0.0 [exit-interface | ip-address ] – default
route
R4(config)#no ip domain-lookup – zakáže vyhledávání špatného příkazu na
serveru
R1(config)#router rip
R1(config-router)#Passive-interface FastEthernet 0/0 – tento interface
neposílá RIP-updatey ale jen naslouchá
R1(config-router)#default-information originate –nastaví se defaultní
routa na jednom routeru a ostatní si ji dynamicky převezmou –
využití při přístupu na internet
No router rip – vypne RIP
R1(config)#line console 0
R1(config-line)# logging synchronous -no unsolicited messages from
IOS are displayed – just after a command is taped
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#exit
R1(config)#line vty 0 4
R1(config-line)#password cisco
R1(config-line)#login
R1(config)#banner motd # Enter TEXT message. End with the character '#'.
R1(config-line)#exit
R1(config)#no cdp run – disabling CDP for th whole router
Interface
R1(config-if)#no cdp enable – disabling CDP just for one interface
Ip address [IP _ MASK]
Description – popis interfaceu
no shutdown – spuštění interfaceu
serial interface: clock rate 64000 – nastavení hodin pro seriový int.
show ip interface brief – stručná reference o nastavení sítí
show running-config
copy running-config startup-config – saving changes into NVRAM
Show startup-config
show ip route – displays the routing table
show interfaces – displays MAC addresses too; it is possible to use a parameter
Show interfaces FastEthernet 0/0 - it displays only one interface FE 0/0
route print
show cdp neighbors
show cdp neighbors detail
R1#show controllers show controllers serial 0/0/0 – displays, which connector is
connected to the device DCE/DTE
debug ip routing -enable debugging of routing
Debug ip rip (undebug)
Show ip protocols – shows protocols going on the router
R* defaultní brána získaná přes RIP
show ip rip database – shows all RIP routes learned by router using RIP, whether or
not the RIP route is installed in the routing table
more than one port at once – command over “RANGE”
STP - Cost
S1(config-if)#spanning-tree cost <1-200 000 000> - set the value of cost of an interface
S1(config-if)#no spannig-tree cost - rest to the default value
S1#show spanning-tree
-verifying the STP costs
S1#show spanning-tree detail
Controlled election of the ROOT BRIDGE
Method I
S1(config)#spanning-tree vlan <vlan-id> root primary -sets the primary RB
S2(config)#spanning-tree vlan <vlan-id> root secondary - sets the alternative RB
It assumes that other switches are in default states
Method II
S3(config)#spanning-tree vlan <vlan-id> priority <0-65536> -value is entered in increments
of 4096
S1(config-if)#spannig-tree port-priority <0-240>
-configuration of the port priority for
election of Non-/Designated or Root port, in increments of 16; by default 128
CCNA#4 Chapter#2 Peer-to-Peer Protocol (PPP) Configuration Commands
For serial interfaces (!)
R3(config-if)#encapsulation ppp
R1#debug ppp [packet | negotiation | error | authentication | compression | cbcp ]
Download