Queuing Techniques

advertisement
Lab Procedures:
Unit 7: Signaling System 7 (SS7): Lab 2
Priority Queuing
Priority queuing allows the administrator to configure four traffic priorities – high, normal, medium,
and low. The traffic is the high queue is processed first and until empty, then the packets in the next
highest queue are processed.
Use the diagram above and the configuration commands below to construct the basic VoIP network.
You may use the saved PlarWithNumExpanConfig file as a starting point or configure as
follows:
HQ1
RemoteEnd2
hostname HQ1
no ip domain lookup
interface Loopback0
ip address 10.10.11.1 255.255.255.255
interface Serial0/0
ip address 10.10.10.1 255.255.255.252
clockrate 1300000
no shutdown
router ospf 84
network 10.0.0.0 0.255.255.255 area 0
line con 0
exec-timeout 0 0
hostname RemoteEnd2
no ip domain lookup
interface Loopback0
ip address 10.10.11.2 255.255.255.255
interface Serial0/0
ip address 10.10.10.2 255.255.255.252
no shutdown
router ospf 84
network 10.0.0.0 0.255.255.255 area 0
line con 0
exec-timeout 0 0
password cisco
1
Lab Handout
IT412 Voice and Data Integration
password cisco
logging synchronous
login
line vty 0 4
password cisco
login
logging synchronous
login
line vty 0 4
password cisco
login
2
Lab Handout
IT412 Voice and Data Integration
Enter the following dial-peer commands in the respective routers or use the previously saved
CustomQueueingConfig file.
HQ1
RemoteEnd2
dial-peer voice 1 pots
destination-pattern 1111
port 1/0/0
dial-peer voice 2 pots
destination-pattern 1112
port 1/0/1
dial-peer voice 3 voip
destination-pattern 2222
session target ipv4:10.10.11.2
dial-peer voice 1 voip
destination-pattern 1111
session target ipv4:10.10.11.1
dial-peer voice 2 pots
destination-pattern 2222
port 1/0/0
dial-peer voice 3 voip
destination-pattern 1112
session target ipv4:10.10.11.1
Once the configurations have been entered, verify proper voice operations by placing telephone calls.
Enter the following commands in RemoteEnd2.
access-list 102
access-list 102
priority-list 2
priority-list 2
permit udp any any range 16384 16484
permit tcp any any eq 1720
protocol ip high list 102
default medium
Enter the show queuing command.
3
Lab Handout
IT412 Voice and Data Integration
Name:
Enter the show int s0/0 command. What is the current queuing strategy?
Enter the following commands on RemoteEnd2 to apply the queuing scheme to the interface.
interface serial 0/0
priority-group 2
Enter the show int s0/0 command. Does the output look similar to this? What is the current queuing
strategy now?
Enter the undebug all command. Enter the debug priority command and call 1111 from 2222.
Examine the output. What was the queue numbers used?
Why should the undebug all command be issued before entering any debug command?
Observe the output of the debug vtsp event command as 2222 places a call to 1111.
How many different state/events were observed?
Ensure all debugging is turned off by issuing the undebug all command.
Save this configuration as PriorityQueueConfig.
4
Lab Handout
IT412 Voice and Data Integration
Download