Using FEHT

advertisement
Using FEHT
Keith A. Woodbury
Introduction
• FEHT
– Is a simple finite element conduction heat
transfer analysis program
– Use of this program entails the same basic
steps necessary to solve heat transfer
problems with commercial software
– Is restricted to 2-D problems with less than
1000 nodes
– Can solve steady or unsteady (transient)
problems
Overview
• Numerical heat transfer analysis requires
the following steps
– Define geometry
– Define mesh for computation
– Assign properties
– Define boundary conditions (and initial
conditions, if necessary)
– Solve for the temperatures
– Perform any desired post-processing
Overview (cont)
• We’ll illustrate use of the program via an
example -
Open FEHT
Define Geometry
• First set the grid to something convenient
for drawing your 2-D geometry
Define Geometry
• Then draw the outline of your object
Define Geometry
• “Draw -> Outline…” tips
– The crosshair cursor does not snap to the grid
– Holding the “shift” key while drawing
constrains the motion to straight lines
– To make a corner you can click and continue
to the next point
Define Mesh
• When an outline is complete, the outline
blinks, and the “Draw->Element Lines…”
option is activated
Define Mesh
• “Draw->Element Lines…” tips
– Elements must be triangular
– Element lines can only connect at nodes (you
can’t join an element line to the middle of
another element line!)
Define Mesh
• Keep going…
Define Mesh
• It can be tedious with a lot of nodes
Specify Properties
• Click on one of the elements (NOT and edge or
node) – the entire outline will begin blinking
• Now go to “Specify->Material Properties” on the
menu (or right click on the object)
Specify Properties
• You can choose from a library of materials
or select “not specified” and enter your
own data
Apply Boundary Conditions
• Either
– Use the pointer to drag a box around a region
of the boundary, or
– Click on a segment of the boundary
Apply Boundary Conditions
• The selected portion(s) of the boundary
will blink
• Choose “Specify->Boundary Conditions”
or right click
Specify Boundary Conditions
• Fill in the boundary condition information
Apply Boundary Conditions
• At any time, “Run->Check” will tell the
status of your model
• After all boundaries have been assigned
conditions, “Run->Calculate”
Solve for Temperatures
Post-Processing
• “View->Temperatures” shows the
computed nodal temperatures
• “View->Temperature Contours” makes a
color map of the solution
• “View->Temperature Gradients” visualizes
the heat flow directions
• “View->Tabular Output” gives a table of the
solution that can be cut/pasted
Download
Related flashcards

Heat transfer

25 cards

Firefighting

21 cards

Refractory materials

30 cards

Refrigerants

45 cards

Create Flashcards