Module 5: Managing Cisco IOS
Software
Frank Mann CCAI-CCNA
2
Router Internal Components
Routers
have
different
types of
memory
Routers need to locate the Config file and the IOS
5.1 Router Boot Sequence and
Verification
Startup routines must do the following:
• Test the router hardware.
• Find and load the Cisco IOS software.
• Find and apply configuration statements, including
protocol functions and interface addresses.
Router Power-On/Bootup Sequence
1. Perform power-on self test (POST).
2. Load and run bootstrap code.
3. Find the Cisco IOS software.
4. Load the Cisco IOS software.
5. Find the configuration.
6. Load the configuration.
7. Run the configured Cisco IOS software.
5.1.2 How a Cisco device locates and
loads IOS
Finding the
Cisco IOS Software
Router Startup Flowchart
Loading the Configuration
• Load and execute the configuration from NVRAM.
• If no configuration is present in NVRAM, enter setup mode.
Determining the Current Configuration
Register Value
wg_ro_a#show version
Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-JS-L), Version 12.0(3), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-1999 by cisco Systems, Inc.
Compiled Mon 08-Feb-99 18:18 by phanguye
Image text-base: 0x03050C84, data-base: 0x00001000
ROM: System Bootstrap, Version 11.0(10c), SOFTWARE
BOOTFLASH: 3000 Bootstrap Software (IGS-BOOT-R), Version 11.0(10c), RELEASE SOFTWARE (fc1)
wg_ro_a uptime is 20 minutes
System restarted by reload
System image file is "flash:c2500-js-l_120-3.bin"
--More-Configuration register is 0x2102
• Configuration register value in show version
Configuration Register Values
• Configuration register bits 3, 2, 1, and 0 set boot option.
• Check the configuration register value with show version.
Configuration Register Values
show version Command
Router#show version
Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-JS-M), Version 12.0(7a), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Tue 05-Feb-02 01:48 by pwade
Image text-base: 0x80008088, data-base: 0x80B0404C
ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)
Router uptime is 1 minute
System restarted by reload
System image file is "flash:c2600-js-mz.120-7a.bin"
cisco 2610 (MPC860) processor (revision 0x300) with 53248K/12288K bytes of memory.
Processor board ID JAD06090BMD (2719249260)
M860 processor: part number 0, mask 49
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
TN3270 Emulation software.
Basic Rate ISDN software, Version 1.1.
1 Ethernet/IEEE 802.3 interface(s)
2 Serial(sync/async) network interface(s)
1 ISDN Basic Rate interface(s)
32K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read/Write)
Configuration register is 0x2102
show flash Command
wg_ro_a#show flash
System flash directory:
File Length
Name/status
1
10084696 c2500-js-l_120-3.bin
[10084760 bytes used, 6692456 available, 16777216 total]
16384K bytes of processor board System flash (Read ONLY)
show running-config and
show startup-config Commands
In RAM
In NVRAM
wg_ro_c#show running-config
Building configuration...
wg_ro_c#show startup-config
Using 1359 out of 32762 bytes
!
version 12.0
!
-- More --
Current configuration:
!
version 12.0
!
-- More --
• Displays the current and saved configuration
Loading the Cisco IOS Software
from Flash Memory
•The flash memory file
is decompressed into
RAM.
Loading the Configuration
• Load and execute the configuration from NVRAM.
• If no configuration is present in NVRAM, enter setup mode.
5.1.5 Troubleshooting IOS boot failure
In the event that the router does not boot
properly, there are several things that
could be wrong:
• Configuration file has missing or incorrect
boot system statement
• Incorrect configuration register value
• Corrupted flash image
• Hardware failure
Managing Cisco IOS Devices
© 2002, Cisco Systems, Inc. All rights reserved.
19
Cisco IOS File System and Devices
Managing Cisco IOS Images
Verifying Memory and Deciphering
Image Filenames
wg_ro_a#show flash
System flash directory:
File Length
Name/status
1
10084696 c2500-js-l_120-3.bin
[10084760 bytes used, 6692456 available, 16777216 total]
16384K bytes of processor board System flash (Read ONLY)
• Verify that flash memory has room for the
Cisco IOS image.
Verifying Memory and Deciphering
Image Filenames
5.2 Prefixes for Managing the Cisco File
System
Creating a Software Image Backup
• Back up current files prior to updating flash memory.
Upgrading the Image from the
Network
Device Configuration Files
5.2.4 Managing configuration files
using copy and paste
Cisco IOS copy Command
• NVRAM
• Terminal
• TFTP server
• Erase start
Cisco IOS copy Command from TFTP
An IOS image can be copied into flash from
a TFTP server
• A series of "e's" are displayed as the current IOS
image is erased from flash.
• A series of "!'s" are displayed as the image is
downloaded successfully to flash
• After the new flash image is downloaded, it is
verified
Cisco IOS copy
Command Example
TFTP Server saved.cfg
running-config
interface s0
ip address 10.1.1.1 255.255.255.0
interface e0
ip address 172.16.1.1 255.255.255.0
interface e0
ip address 10.2.2.2 255.255.255.0
interface e1
ip address 192.168.1.1 255.255.255.0
interface e1
no ip address
copy tftp run (merged)
interface s0
ip address 10.1.1.1 255.255.255.0
Resulting
running-config
interface e0
ip address 172.16.1.1 255.255.255.0
interface e1
ip address 192.168.1.1 255.255.255.0
copy run tftp and
copy tftp run Commands
wg_ro_a#copy running-config tftp
Address or name of remote host []? 10.1.1.1
Destination filename [running-config]? wgroa.cfg
.!!
1684 bytes copied in 13.300 secs (129 bytes/sec)
wg_ro_a#copy tftp running-config
Address or name of remote host []? 10.1.1.1
Source filename []? wgroa.cfg
Destination filename [running-config]?
Accessing tftp://10.1.1.1/wgroa.cfg...
Loading wgroa.cfg from 10.1.1.1 (via Ethernet0): !
[OK - 1684/3072 bytes]
1684 bytes copied in 17.692 secs (99 bytes/sec)
Adding New Devices to the Network
1. Determine the IP address to be used for management
purposes.
2. Configure administrative access for the console,
auxiliary, and vty interfaces.
3. Configure passwords for the privileged EXEC mode for
the device.
4. Configure the network management access to the
device.
5. Determine the IP address to assign to each interface.
6. Configure the new device with the appropriate
configuration.
Moving Devices on the Network
• Determine what to do with the obsolete equipment.
– Which devices connect to the equipment being
moved?
– Will the move and reconfiguration affect the
security policy?
– Does the device play a role that no other devices
play?
• Review the facilities for the new location.
• After the move, test network connectivity.
Changing the Hardware
Hardware changes
• Power down the equipment or use OIR.
• Make sure the appropriate modules are available.
• Read the hardware installation manual.
• Verify your organization’s policies.
Cisco IOS software changes
• Does the new version support the current and future
features you need?
• Does your platform have sufficient RAM and flash
memory to support the feature set?
show and debug Commands
show
debug
Processing characteristic
Static
Dynamic
Processing load
Low overhead
High overhead
Primary use
Gather facts
Observe processes
Considerations When Using debug
Commands
• May generate output in a variety of formats that
may not identify the problem
• Require high overhead, possibly disrupting
network device operation
• Useful for obtaining information about network
traffic and router status
Commands Related to debug
Router(config)#service timestamps debug datetime msec
Router#show processes
CPU utilization for five seconds: 0%/0%; one minute: 0%; five minutes: 0%
PID Q Ty
PC Runtime(ms)
Invoked
uSecs
Stacks TTY Process
1 C sp 602F3AF0
0
1627
0 2600/3000
0 Load Meter
2 L we 60C5BE00
4
136
29 5572/6000
0 CEF Scanner
3 L st 602D90F8
1676
837
2002 5740/6000
0 Check heaps
4 C we 602D08F8
0
1
0 5568/6000
0 Chunk Manager
5 C we 602DF0E8
0
1
0 5592/6000
0 Pool Manager
6 M st 60251E38
0
2
0 5560/6000
0 Timers
Router#no debug all
Summary
• The Cisco IOS File System feature provides a single
interface to all the file systems that a router uses.
• As your network grows, you may want to store
your Cisco IOS software and configuration files on
a central server, which would allow you to control
the number and revision level of software images
and configuration files you must maintain.
• Device configuration files contain a set of
user-configured commands that customize the
functionality of your Cisco device.
Summary (Cont.)
• You use the Cisco IOS software copy commands
to move configurations from one component or
device to another, such as RAM, NVRAM, or a file
server.
• Network equipment is often moved from one
location to another, removed from the network, or
the configuration may change. The process is
referred to as adds, moves, and changes.
• The show and debug commands are built-in tools
for troubleshooting. The show command is used
to display static information, while the debug
command is used to display dynamic data.
Module 5: Managing Cisco IOS Software
Lab:
5.1.3 Using the Boot System
Command
5.1.5 Troubleshooting Config
Register Boot Problems
e-Lab:
5.2.3 Managing Configuration
Files with TFTP
5.1.3 Preparing for Boot
System Commands
5.2.5 Managing IOS Images
with TFTP
5.1.4 Configuration Register
5.2.6a Password Recovery
Procedures
5.2.6b Managing IOS Images
with ROMmon and Xmodem
5.1.5 Troubleshooting IOS
Boot Failure