Particle System Project

advertisement
Splash - 4D Particle System
User Manual
Splash is a tool to create fantastic particle animations for use in 3D graphics. By altering
certain controls you can create a wide range of particle animations, from explosions to
water fountains.
Installation Guide
 Double click on Splashv101.zip and run Setup.exe to start the installation program.
 Once Splash is installed on your system, double click on Splash.exe.
 Type in your User ID as emailed to you when you bought the software.
 To associate the Particle Animation Format with Splash in Windows, click the
Settings menu, then Associate *.paf.
 You may wish to alter the speed at which the Global view rotates or how fast the
animation plays. To do this click the Settings menu, then User Interface and change
the settings.
 You computer is now prepared to run the Splash.
Limitations of the System
The maximum number of frames and the maximum number of particles emitted per
frame is 32767, although this may vary on different PCs due to memory constraints.
Splash will currently only import geometric data of faces, edges and points (i.e. no
perfect spheres or textures).
Normal Use Guide
Background and Theory of Particle Animations
The idea behind Splash is that a wide range of particle animations can be created by
altering data in a few controls such as the velocity of the particles. To make the system
even more versatile keyframes are used to animate this data. All controls will be
controlled for each frame of the animation using keyframe techniques. This is where you
set the values of the controls at a few specific frames. Then the program calculates the
values at all the other frames by mathematically interpolating (morphing) between these
KEY frames. For example, if at frame 1 the User sets the gravity at -10 and at frame 10
he sets it to 0 then at frame 5 the computer will calculate that the gravity should be -5.
The Emitter controls and the Environment controls are keyframed separately which
means that you can have a keyframe for the emitter controls on frame 12 but you don’t
need a keyframe for the Environment controls on frame 12 as well. In other words you
can animate the Emitter controls separately to the Environment controls.
User Manual
Page 1 of 12
02/17/16
The Viewports
Upon starting the system you will be faced with this screen:
This the four boxes containing grids are the four Viewports you can use to view the
particle animation. “Top”, “Front” and “Right” cannot be altered but “Global” can be
rotated in 3D by clicking and dragging with the mouse on the Global Viewport. In the
Top, Front and Right Viewports (the three fixed Viewports) the grey lines in the grids are
100 units of space apart. The point (0, 0, 0) is at the centre of every Viewport.. The grid
you see in the Global Viewport is the ground object which the particles can bounce off.
This ground object is 1000 by 1000 units in size. The axis objects placed in the bottom
left corner of the three fixed Viewports are a visualisation tool to understand which 3D
axes are represented in each of the Viewports.
User Manual
Page 2 of 12
02/17/16
This shows the Global Viewport with a simple particle animation in which particles are
bouncing off the floor. The Viewport has been rotated to display the animation from a
different viewpoint.
The Emitter
The coloured shapes in the three fixed Viewports represent the emitter object, from where
all the particles are emitted. Its shape and size vary depending on the Emission Type and
values you have inputted to the system so that you receive a visual representation of your
settings. You can move the emitter by clicking or dragging with your mouse in any of the
three fixed Viewports. You can only move the emitter along the two axes shown in the
particular Viewport, for example if you move the emitter in the Front Viewport you can
only move it in the Z and X axes. When you move the emitter it’s position will be
displayed in the information bar at the very bottom of the screen. As you continue to
move the emitter it’s position will be updated in the information bar allowing accurate
positioning of the emitter. As you can see below, I have moved the emitter –277 units in
the Z axis. Try to get the feel of how the three Viewports interact by moving the emitter
in one Viewport and seeing how it moves in another.
The Control Panel
Default values are provided in the system to get you using the software as quickly and
easily as possible. As you can see on the top screen shot, the control panel to the very
right of the screen, is filled with buttons and input boxes. To alter the particle animation
you change the values in the input boxes. To view the results of the settings simply click
“Update”. This tells the software that you have entered all the data you want and you
want it to calculate the particle animation from that data. Then right-click the play button
(green triangle) to watch the animation.
User Manual
Page 3 of 12
02/17/16
The Emitter Section
This tab at the top of the control panel is used to switch between the data about the
emitter and the data about the environment the particles move through.
This is the data displayed when the Emitter tab is selected:
The X, Y and Z values are the initial velocities of particles when they are emitted from
the emitter. For example a value of “10” in the X input box will mean that the particle are
initially given a velocity of 10 units per frame.
The Radius data is similar to the X, Y and Z data, in that it is used as a value for the
initial velocities of the particles. The Radius data is used for different emission shapes,
such as “Spherical”, which will be explained later in this section.
These values will be disabled if they do not apply to the current Emission Type.
The Spread data is used to add a random amount of ‘spread’ to the initial velocity values.
For example if the initial X velocity is set as 10 units / frame but you don’t want all the
particles to have that velocity you can give the values a 20 % spread. In other words the
velocities can now be anywhere between 8 and 12 units / frame. This is extremely useful
to give the particle animations a more natural look.
The Elasticity data is how ‘bouncy’ the particles are. A value between 0 and 1 is
recommended. For example with an elasticity of 0 the particles will not bounce at all
when they hit the floor, but with an elasticity of 1 they will bounce up with the same
amount of speed as they had falling down. A value greater than 1 will make the particles
bounce up with a greater velocity than they had when falling down.
The keyframe is updated when you click outside of the input box, although if you click
on the Frame bar this will not happen.
User Manual
Page 4 of 12
02/17/16
The Environment Section
This is the data displayed when the Emitter tab is selected:
The Viscosity data controls how viscous that the substance is that the particles are
travelling through. Viscosity will slow down moving particles each frame they move
through the atmosphere. For example air is not very viscous and so a Viscosity value
close to 1 is appropriate, i.e. the particles will not be slowed down at all. However, water
is much more viscous than air and so a value of 1.2 might be appropriate. This will mean
that the particle will slow down and eventually come to a stop (even in the middle of the
atmosphere).
The Gravity data controls how much gravity is present in the Environment. Scientifically,
this is the amount that each particle is accelerated towards the earth per second. This
force acts in the direction of the Z axis and so is negative for the particles to be
accelerated downwards. The gravity on earth is roughly –9.81 m/s/s but the units
involved here are units / frame / frame.
The Wind X and Y data is used to accelerate the particles in the X and Y directions by a
set amount every frame. The units involved are units / frame / frame. The effect this
produces is similar to a strong wind blowing dust particles in a set direction.
The Display Section
This data is merely for visualisation purposes. The ground plane mentioned earlier is
present in the Global Viewport and is used to show how the particles bounce off or
collect on the ground object. The ground plane is of a set size, 1000 by 1000 units, but
the number of lines or sections it is made up of can be set by altering the data above.
User Manual
Page 5 of 12
02/17/16
The Animation Section
The Animation section contains the data about the final animation and other data that
cannot be keyframed and controls playback of the animation.
The Frames data is the length of the animation in frames. The Particles data is the number
of particles you want to be emitted per frame by the emitter.
The Emission Type is the shape you want the particle animation to be. This is the shape
an infinite amount of particles would form if they were emitter in a 0 gravity, 1 viscosity
environment. However they produce interesting and varied effects in many different
environments. The Filled check box determines whether the Emission shape is filled with
particles or just the shell of the shape. In other words, if Filled is unchecked the particles
must appear on the surface of the emission shape but if Filled is checked they can appear
anywhere inside the emission shape.
The Circular Emission Type uses the Radius data from the Emitter Section to set the X
and Y initial velocities of the particles (and so they form a circular shape from above) and
the Z data from the Emitter Section to set the Z initial velocities.
The Spherical Emission Type solely uses the Radius data from the Emitter Section to set
the initial velocities of the particles.
The Cubic Emission Type uses the X, Y and Z data from the Emitter Section to set the X,
Y and Z initial velocities respectively.
The Ground Height data sets the position along the z axis that the ground is to be placed
at.
The Update button, as mentioned earlier, tells the software to compute the particle
animation, i.e. compute the position of every particle for every frame in the animation
User Manual
Page 6 of 12
02/17/16
and save that data. This must be performed before you can see the results of altering any
of the data in the Control Panel.
The yellow line-and-triangle “first” button moves the Frame bar to the first frame of the
animation.
The double blue left pointing triangles “previous” button moves the Frame bar to the
previous frame.
The red square “stop” button will stop the animation where it is and can also be used to
stop any long processes such as Update, Import or Export. This may be useful if they are
taking a long Frame to complete and you have realised that you have made a mistake or
want to alter some data.
The green triangle “play” button animates the particles in all four Viewports using the
data calculated when the Update button was pressed. To play a section of the animation
hold down the left mouse button and release it when you want to stop. To play the whole
animation once right click the play button. To play the whole animation in a continuous
loop double right click the play button.
The double blue right pointing triangles “next” button moves the Frame bar to the next
frame.
The yellow triangle-and-line “last” button moves the Frame bar to the last frame of the
animation.
The Information Bar
The information bar displays useful information about what the system is currently doing.
It is split into three panels which hold different information.
Panel 1
The first panel will simply display the word “Ready” for most of the program usage.
However when the program is computing the position of the particles, as a result of the
user clicking “Update” in the Animation section of the Control Panel, it will display a
progress bar representing the percentage of the process the program has completed.
Panel 2
The data displayed in this panel will change frequently during the use of the program. It
gives the user feedback about the current processes of the program. For example when
the program is computing the position of the particles it displays “Computing Animation”
and when it has finished it displays the amount of Frame that process took:
Panel 2 also displays the co-ordinates of the emitter when it is being moved so you can
accurately place it on all axes.
User Manual
Page 7 of 12
02/17/16
Panel 3
Panel 3 always displays the current frame of the animation as being displayed in the
Viewports, as set by the frame bar.
The Frame Bar
The frame bar is used to set the current frame of the animation being displayed in the
Viewports. To change the current frame you simply click and drag the pointer on the bar
and release it above one of the marks on the bar. When the current frame is altered the
data displayed in the control panel is also altered to the specific value being used in that
frame.
The marks above the frame bar denote the frames which contain keyframes. The Emitter
keyframes are denoted with a light green mark (as above) and the Environment
keyframes are denoted with a blue mark (as below).
The program will automatically start with Emitter and Environment keyframes at frame
1.
The Menu Bar
The File Menu
The File menu contains all the file management commands.
User Manual
Page 8 of 12
02/17/16
Open… will open a previously saved 4D Particle Animation. The extensions for these
files is “*.paf”.
Save will save the currently opened file.
Saves As… will save the current 4D Particle Animation as a *.paf file.
User Manual
Page 9 of 12
02/17/16
Import Particle will import a 3D object in the AutoCAD *.dxf format into the Splash.
This will replace every particle in the animation with the object you import although you
can only see the results of this when you export the particle animation.
When a particle is imported into the system it is displayed in the four Viewports so you
can check that it is the correct object. The import screen contains a warning that if the
object is not between –500 and +500 in the relevant axis then it will not be displayed.
User Manual
Page 10 of 12
02/17/16
Export Particle Animation exports the particle animation as a series of AutoCAD files
which can be read into 3D rendering packages to be integrated into other 3D animations.
Imagine TDDD files will be saved to one file and each frame of the animation will be
saved to a different state.
Blob Size can only be used in conjunction with Imagine Blobs export and sets the size of
each blob sphere.
AutoCAD files will be called the name you type into the file name input box followed by
the frame number and will have the *.dxf extension. For example frame 3 of a “Fountain”
animation would be called “Fountain3.dxf”.
The Keyframes Menu
To add a keyframe, move the frame bar to the appropriate frame, type the values you
desire into the control panel, then either click Add on the Keyframes menu or type Shift +
A on your keyboard. To delete a keyframe, move the frame bar to the appropriate frame
then either click Delete on the Keyframes menu or type Shift + D on your keyboard.
User Manual
Page 11 of 12
02/17/16
The Viewports Menu
Load Backdrop loads an image into the background of the selected Viewport. You can
use this to help model a particle effect, e.g. load a picture of a whirlwind when creating a
whirlwind particle animation. Alternatively you could load in screenshots of a 3D scene
from your rendering package, then use this to get the shape of your particle effect just
right.
Refresh Viewports will simply refresh all of the Viewports by redrawing all the elements
displayed within them (except imported particles).
The Settings Menu
User Interface can be used to set the Global Viewport rotate speed and the Animation
Playback speed.
Associate *.paf will associate the Particle Animation Format with Splash in Windows so
you can double click on a *.paf file and it will load up in Splash.
The Help Menu
The Help menu will simply provide you with information about Splash and Imagine.
User Manual
Page 12 of 12
02/17/16
Download
Related flashcards
Create flashcards