cis185-ROUTE-lecture4

advertisement
CIS 185 CCNP ROUTE
Ch. 4 Manipulating Routing Updates
Rick Graziani
Cabrillo College
graziani@cabrillo.edu
Last Updated: Fall 2011
Materials
 Book:
 Implementing Cisco IP Routing
(ROUTE) Foundation Learning
Guide: Foundation learning for the
ROUTE 642-902 Exam
 By Diane Teare
 Book
 ISBN-10: 1-58705-882-0
 ISBN-13: 978-1-58705-882-0
 eBook
 ISBN-10: 0-13-255033-4
 ISBN-13: 978-0-13-255033-8
2
Network
Performance
Issues
 Common network performance issues include the following:
 Excessive routing updates:
 Decrease network performance
 CPU utilization spikes
 The size of the routing update
 The frequency of the updates
 The presence of any route maps or filters:
 Incorrectly configured route maps or filters can cause too much or the
wrong data to be sent.
 The number of routing protocols running in the same AS:
 Processing the updates.
 Routes may also be redistributed between protocols, which can add to
the number of updates that a specific protocol must process.
3
Controlling routing updates involves a variety of solutions, including the:
 Design changes:
 Limiting the number of routing protocols used
 Choice of routing protocol
 Network design (areas, stub networks, etc.)
 Using passive interfaces
 Route filtering using:
 Access lists
 Route maps
 Distribute lists
 Prefix lists
4
Route Redistribution
5
 Routing protocols were not designed to interoperate with one another using
different:
 Metrics
 Reactions to topology changes
 Timers
 Processes
 Routers using different routing protocols can exchange routing information.
 Route redistribution is the capability of boundary routers connecting
different routing domains to exchange and advertise routing information
between those routing domains.
6
Route
Redistribution
 One-way route redistribution - one protocol receives the routes
from another)
 Two-way route redistribution - both protocols receive routes from
each other.
 Boundary routers:
 Routers that perform redistribution
 Borders two or more ASs or routing domains.
 Note: The term boundary router is also sometimes used to
describe a router running a classful routing protocol (like RIP)
that has interfaces in more than one classful network.
7
 Redistribution is always performed outbound
 The router doing redistribution does not change its routing table.
 Router A (boundary router) participates in both:
 OSPF
 EIGRP
 Two-way redistribution does not affect the routing table on Router A
 However:
 Router C will learn about redistributed EIGRP networks (via OSPF)
 Router B will learn about redistributed OSPF networks (via EIGRP)
 Only networks in Router A’s routing table can be redistributed.
8
Route
Redistribution
Why configure redistribution?
 Company mergers and different IGPs are used
 Company has different divisions with the network under separate
control for business or political reasons
 Company has connections between business partners
 To allow multivendor interoperability (OSPF on non-Cisco, EIGRP
on Cisco, for instance)
Configuring
Redistribution
My best path to
192.100.10.0 is
this way.
R2 and R3 are
running both
OSPF and EIGRP
192.168.10.0
R3
R1
OSPF
Routing Loop!
EIGRP
My best path to
192.100.10.0 is this way.
R2
 Incompatible routing information
 Each routing protocol uses different metrics.
 EIGRP uses slowest BW and cumulative Delay
 OSPF use cumulative BW
 Metrics cannot be translated exactly into a different protocol
 Path selection may not be optimal.
 Potential Routing loops – Depending on how redistribution is used, routers can
send routing information received from one AS back into the AS. (Route Feedback)
 Inconsistent convergence times:
 Different routing protocols converge at different rates.
 These potential trouble spots can be avoided with careful planning and implementation.
Selecting the Best Route in a Redistribution Environment
 Cisco routers use the
following two parameters to
select the best path:
 Administrative distance:
 Trustworthiness of the
routing source
 Modifying the
administrative distance to
influence the routeselection process is
discussed later
 When using route
redistribution, you might
occasionally need to modify a
protocol’s administrative
distance so that it is preferred
and to prevent routing loops.
(later)
 Routing metric:
 Best path
11
Concepts of
Redistribution
Multiple Routing Processes
 Cisco routers support up to
30 dynamic routing
processes on a single
router.
 Most routing protocols
allow an administrator
to configure multiple
processes of the same
routing algorithm
 RIP and BGP are
notable exceptions.
RTA#show running-config
router ospf 24
network 10.2.0.0 0.0.255.255 area 0
Not usually
!
recommended
router ospf 46
network 192.168.2.0 0.0.0.255 area 2
!
router eigrp 53
network 172.16.0.0
network 172.17.0.0
Not usually
!
recommended
router eigrp 141
network 10.0.0.0
network 192.168.3.0
Route Redistribution
 Route redistribution - The process of exchanging routing information
between routing protocols.
 EIGRP routing domain learns about networks in OSPF routing
domain.
 OSPF routing domain learns about networks in EIGRP routing
domain.
 Done by a boundary router which participates in both routing protocols.
Redistribution
Concepts and
Processes
I run both EIGRP and
OSPF.
Router(config-router)# redistribute from-protocol [process-id]
Note: Other parameters may be required and will be discussed.
 The redistribution command (“take routes from”)
 Configured on the boundary router.
 Participates in both routing protocols.
 Independent of any one protocol
 Various complexities depending on the routing protocols and
the options.
Redistributing from
OSPF into EIGRP
Our Topology
EIGRP 1
OSPF 1
 Boundary router R2-E-O is running:
 EIGRP for 172.30.0.0 subnets and 172.31.0.0 network
 OSPF for 172.16.0.0 subnets and 172.17.0.0 network
 192.168.1.0 or 10.0.0.0 not currently included in either routing
protocol (more on this later)
Redistribution
into EIGRP
redistribute protocol [process-id | as-number] [metric
bw delay reliability load mtu ] [match {internal |
nssa-external | external 1 | external 2}] [tag tagvalue] [route-map name]
 The syntax differs slightly depending on the routing protocol into which
routes will be redistributed.
Redistribution
into EIGRP
redistribute protocol [process-id | as-number] [metric
bw delay reliability load mtu ] [match {internal |
nssa-external | external 1 | external 2}] [tag tagvalue] [route-map name]
 protocol - The source of routing information. Includes RIP, OSPF, EIGRP, IS-IS,
BGP, connected, and static.
 process-id, as-number - If redistributing a routing protocol that uses a process-id or
ASN on the router global config command, use this parameter to refer to that process
or ASN value.
 metric - A keyword after which follows the four metric components (bandwidth, delay,
reliability, link load), plus the MTU associated with the route.
 match - If redistributing from OSPF, this keyword lets you match internal OSPF
routes, external (by type), and NSSA external routes, essentially filtering which routes
are redistributed.
 tag - Assigns a unitless integer value to the route, which can be later matched by
other routers using a route-map.
 route-map - Apply the logic in the referenced route-map to filter routes, set metrics,
and set route tags.
19
Redistribution
into EIGRP
Current configurations
R1-E
R3-O
router eigrp 1
router ospf 1
network 172.30.0.0
network 172.16.0.0 0.0.255.255 area 0
network 172.31.0.0
auto-summary
R2-E-O
R4-O
router eigrp 1
router ospf 1
network 172.30.0.0
network 172.16.0.0 0.0.255.255 area 0
auto-summary
network 172.17.0.0 0.0.255.255 area 0
router ospf 1
network 172.16.0.0 0.0.0.3 area 0
What networks
do I know about
and how did I
learn about
them?
Redistribution
into EIGRP
What do you expect to see?
Directly Connected and any EIGRP networks – NO OSPF networks
R1-E# show ip route
C
172.31.0.0/16 is
172.30.0.0/16 is
C
172.30.2.0/24
C
172.30.3.0/24
C
172.30.0.0/30
D
172.30.0.0/16
C
172.30.1.0/24
C
172.30.4.0/24
R1-E#
directly connected, Loopback31
variably subnetted, 6 subnets, 3 masks
is directly connected, FastEthernet0/1
is directly connected, Loopback0
is directly connected, Serial0/0
is a summary, 00:02:41, Null0
is directly connected, FastEthernet0/0
is directly connected, Loopback1
Redistribution
into EIGRP
What do you expect to see?
EIGRP and OSPF networks
What networks
do I know about
R2-E-O# show ip route
and how did I
learn about
O
172.17.0.0/16 [110/846] via 172.16.0.1, 00:02:32, Serial0/1
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks them?
O
C
O
O
D
172.16.0.4/30 [110/845] via 172.16.0.1, 00:02:32, Serial0/1
172.16.0.0/30 is directly connected, Serial0/1
172.16.1.0/24 [110/782] via 172.16.0.1, 00:02:32, Serial0/1
172.16.2.0/24 [110/846] via 172.16.0.1, 00:02:32, Serial0/1
172.31.0.0/16 [90/20640000] via 172.30.0.1, 00:03:46, Serial0/0
172.30.0.0/16 is variably subnetted, 5 subnets, 2 masks
D
172.30.2.0/24 [90/20514560] via 172.30.0.1, 01:22:36, Serial0/0
D
172.30.3.0/24 [90/20640000] via 172.30.0.1, 01:22:36, Serial0/0
C
172.30.0.0/30 is directly connected, Serial0/0
D
172.30.1.0/24 [90/20514560] via 172.30.0.1, 01:22:36, Serial0/0
D
172.30.4.0/24 [90/20640000] via 172.30.0.1, 01:22:36, Serial0/0
10.0.0.0/24 is subnetted, 1 subnets
C
10.0.0.0 is directly connected, FastEthernet0/1
C
192.168.1.0/24 is directly connected, FastEthernet0/0
R2-E-O#
Redistribution
into EIGRP
What do you expect to see?
Only OSPF networks – NO EIGRP networks
R3-O# show ip route
O
What networks
do I know about
and how did I
learn about
them?
172.17.0.0/16 [110/65] via 172.16.0.6, 00:09:06, Serial0/2
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
C
172.16.0.4/30 is directly connected, Serial0/2
C
172.16.0.0/30 is directly connected, Serial0/1
C
172.16.1.0/24 is directly connected, FastEthernet0/0
O
172.16.2.0/24 [110/65] via 172.16.0.6, 00:09:06, Serial0/2
R3-O#
Redistribution
into EIGRP
What do you expect to see?
Only OSPF networks – NO EIGRP networks
R4-O# show ip route
C
172.17.0.0/16 is
172.16.0.0/16 is
C
172.16.0.4/30
O
172.16.0.0/30
O
172.16.1.0/24
C
172.16.2.0/24
R4-0#
What networks
do I know about
and how did I
learn about
them?
directly connected, FastEthernet0/1
variably subnetted, 4 subnets, 2 masks
is directly connected, Serial0/0
[110/128] via 172.16.0.5, 00:09:52, Serial0/0
[110/65] via 172.16.0.5, 00:09:52, Serial0/0
is directly connected, FastEthernet0/0
Hey! I don’t see any of
the networks in the
OSPF domain! What
happened?
Redistribution
into EIGRP
 No change for R1-E!
 No OSPF networks
 Let’s see what happened (or didn’t happen)…
R2-E-O(config)# router eigrp 1
R2-E-O(config-router)# redistribute ospf 1
I will redistribute my OSPF
learned networks (and OSPF
network command networks)
into EIGRP, telling my
EIGRP neighbors about
these networks
R1-E# show ip route
C
172.31.0.0/16 is
172.30.0.0/16 is
C
172.30.2.0/24
C
172.30.3.0/24
C
172.30.0.0/30
D
172.30.0.0/16
C
172.30.1.0/24
C
172.30.4.0/24
R1-E#
directly connected, Loopback31
variably subnetted, 6 subnets, 3 masks
is directly connected, FastEthernet0/1
is directly connected, Loopback0
is directly connected, Serial0/0
is a summary, 00:02:41, Null0
is directly connected, FastEthernet0/0
is directly connected, Loopback1
Redistribution
into EIGRP
Should R2’s routing table change? No
R2-E-O# show ip route
O
172.17.0.0/16 [110/846] via 172.16.0.1, 00:02:32, Serial0/1
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
O
172.16.0.4/30 [110/845] via 172.16.0.1, 00:02:32, Serial0/1
C
172.16.0.0/30 is directly connected, Serial0/1
O
172.16.1.0/24 [110/782] via 172.16.0.1, 00:02:32, Serial0/1
O
172.16.2.0/24 [110/846] via 172.16.0.1, 00:02:32, Serial0/1
D
172.31.0.0/16 [90/20640000] via 172.30.0.1, 00:03:46, Serial0/0
172.30.0.0/16 is variably subnetted, 5 subnets, 2 masks
D
172.30.2.0/24 [90/20514560] via 172.30.0.1, 01:22:36, Serial0/0
D
172.30.3.0/24 [90/20640000] via 172.30.0.1, 01:22:36, Serial0/0
C
172.30.0.0/30 is directly connected, Serial0/0
D
172.30.1.0/24 [90/20514560] via 172.30.0.1, 01:22:36, Serial0/0
D
172.30.4.0/24 [90/20640000] via 172.30.0.1, 01:22:36, Serial0/0
10.0.0.0/24 is subnetted, 1 subnets
C
10.0.0.0 is directly connected, FastEthernet0/1
C
192.168.1.0/24 is directly connected, FastEthernet0/0
R2-E-O#
26
Redistribution
into EIGRP
R2-E-O(config)# router eigrp 1
R2-E-O(config-router)# redistribute ospf 1
R2-E-O# show ip eigrp top
IP-EIGRP Topology Table for AS(1)/ID(192.168.1.1)
P 172.30.2.0/24, 1 successors, FD is 20514560
via 172.30.0.1 (20514560/28160), Serial0/0
P 172.30.3.0/24, 1 successors, FD is 20640000
via 172.30.0.1 (20640000/128256), Serial0/0
P 172.30.0.0/30, 1 successors, FD is 20512000
via Connected, Serial0/0
P 172.31.0.0/16, 1 successors, FD is 20640000
via 172.30.0.1 (20640000/128256), Serial0/0
P 172.30.1.0/24, 1 successors, FD is 20514560
via 172.30.0.1 (20514560/28160), Serial0/0
P 172.30.4.0/24, 1 successors, FD is 20640000
via 172.30.0.1 (20640000/128256), Serial0/0
For now notice that
there are no
“OSPF networks” in
R2’s topology table.
They are still in the
routing table
because R2 also
runs OSPF, but this
is an EIGRP
command.
27
Redistribution
into EIGRP
BW/DLY
BW
redistribute protocol [process-id | as-number] [metric bw
delay reliability load mtu ]
default-metric bw delay reliability load mtu
 When redistributing into EIGRP from another routing protocol you must
convert the other routing protocol’s metric (OSPF’s cost, bandwidth) into
EIGRP’s metric (BW, DLY, Reliability and Load).
 This metric, referred to as the seed or default metric, is defined during
redistribution configuration.
 Three methods:
 Metric parameter with redistribute command
 Sets the default for all redistribute commands
 Default-metric command
 Sets the default for all redistribute commands
 Route-map
 Sets different metrics for routes learned from a single source
Redistribution into
EIGRP
10000 100 255 1
EIGRP 1
OSPF 1
EIGRP 2
50000 500 255 1
router eigrp 1
network 172.20.0.0
redistribute ospf 1
redistribute eigrp 2
default-metric 10000 100 255 1 1500
redistribute rip metric 50000 500 255 1 1500
RIP
 default-metric command is used where the metric parameter is not being
applied in the redistribute command.
 metric parameter takes precedence over the default-metric command
 Note: The metric will give all redistributed networks the same starting
metric.
 This is known as the seed metric
Redistribution
into EIGRP
1000 33 255 1
R2-E-O(config)# router eigrp 1
R2-E-O(config-router)# redistribute ospf 1
R2-E-O(config-router)# default-metric 1000 33 255 1 1500
OR
BW DLY
RLY Load MTU
R2-E-O(config)# router eigrp 1
BW DLY RLY Load MTU
R2-E-O(config-router)# redistribute ospf 1 metric 1000 33 255 1 1500
 Note:
 MTU is NOT one of the EIGRP metrics (never has been, never will be)
 MTU is included because it is tracked through the path to find the
smallest MTU.
Redistribution
into EIGRP
R2-E-O# show ip eigrp top
IP-EIGRP Topology Table for AS(1)/ID(192.168.1.1)
P 172.16.0.4/30, 1 successors, FD is 2568448
via Redistributed (2568448/0)
P 172.16.0.0/30, 1 successors, FD is 2568448
via Redistributed (2568448/0)
P 172.16.1.0/24, 1 successors, FD is 2568448
via Redistributed (2568448/0)
P 172.17.0.0/16, 1 successors, FD is 2568448
via Redistributed (2568448/0)
P 172.16.2.0/24, 1 successors, FD is 2568448
via Redistributed (2568448/0)
EIGRP topology table lists
the outgoing interface as
"via redistributed"
All the redistributed routes
have the same feasible
distance (FD) calculation
(2568448), because all use
the same component
metrics per the configured
default-metric command
 New Entries
31
Redistribution
into EIGRP
R2-E-O# show ip eigrp top 172.16.0.0/30
IP-EIGRP (AS 1): Topology entry for 172.16.0.0/30
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2568448
Routing Descriptor Blocks:
0.0.0.0, from Redistributed, Send flag is 0x0
Composite metric is (2568448/0), Route is External
Vector metric:
Minimum bandwidth is 1000 Kbit
Total delay is 330 microseconds
From default-metric command
Reliability is 255/255
Load is 1/255
"(this system)", meaning that the router
Minimum MTU is 1500
on which the command was issued (R2
Hop count is 0
in this case) redistributed the route.
External data:
Originating router is 192.168.1.1 (this system)
AS number of route is 1
External protocol is OSPF, external metric is 0
Administrator tag is 0 (0x00000000)
32
Great! Now I see all
the networks in the
OSPF domain but as
EIGRP routes.
Redistribution
into EIGRP
R1-E# show ip route
D EX 172.17.0.0/16 [170/3080448] via 172.30.0.2, 00:01:50, Serial0/0
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
D EX
172.16.0.4/30 [170/3080448] via 172.30.0.2, 00:01:50, Serial0/0
D EX
172.16.0.0/30 [170/3080448] via 172.30.0.2, 00:01:50, Serial0/0
D EX
172.16.1.0/24 [170/3080448] via 172.30.0.2, 00:01:50, Serial0/0
D EX
172.16.2.0/24 [170/3080448] via 172.30.0.2, 00:01:50, Serial0/0
C
172.31.0.0/16 is directly connected, Loopback31
 EX: External Route (redistributed)
172.30.0.0/16 is variably subnetted, 6 subnets, 3 masks
 is
170:
Administrative
distance
(90 for EIGRP internal
C
172.30.2.0/24
directly
connected,
FastEthernet0/1
routes)
C
172.30.3.0/24 is
directly connected, Loopback0
C
172.30.0.0/30
directly
Serial0/0
 is
R1-E
has theconnected,
same metric
(3080448) for all external
D
172.30.0.0/16 is
a summary,
00:12:08,
Null0
EIGRP
networks
(from the
OSPF domain)
C
172.30.1.0/24 is directly connected, FastEthernet0/0
C
172.30.4.0/24 is directly connected, Loopback1
Redistribution
into EIGRP
R2-E-O# show ip eigrp top
P 172.16.0.0/30, 1 successors, FD is 2568448
via Redistributed (2568448/0)
 R2 redistributed into EIGRP the routes learned via OSPF and its own
directly connected network 172.16.0.0/30.
 But not 192.168.1.0/24 and 10.0.0.0/8
 This is because 172.16.0.0/30 is an OSPF enabled interface (network
statement)
 Redistribute command, redistributes the following:
 All routes in the routing table learned by that routing protocol
 All connected routes of interfaces on which that routing protocol is
enabled
 Otherwise must be redistributed another way (connected or static) – coming
34
Redistribution
into EIGRP
What about the
10.0.0.0/24 network?
How can I redistribute
it into EIGRP?
R2-E-O(config)# router ospf 1
R2-E-O(config-router)# network 10.0.0.0 0.0.0.255 area 0
R2-E-O# show ip route
10.0.0.0/24 is subnetted, 1 subnets
C
10.0.0.0 is directly connected, FastEthernet0/1
No change to routing table
 Two ways to redistribute 10.0.0.0/24 network.
 Redistribute Connected
 Add OSPF network command
 Also propagates 10.0.0.0/24 throughout OSPF domain
The 10.0.0.0 network
is now included as
one of my EIGRP
routes.
Redistribution
into EIGRP
R1-E# show ip route
D EX
10.0.0.0 [170/3080448] via 172.30.0.2, 00:01:33, Serial0/0
R4-0# show ip route
O
10.0.0.0 [110/129] via 172.16.0.5, 00:04:02, Serial0/0
 10.0.0.0 is now redistributed into the EIGRP domain with the rest of
the OSPF networks.
Redistribution
into EIGRP
What about the
192.168.1.0 network?
How can I redistribute
it into EIGRP?
R2-E-O(config)# router eigrp 1
R2-E-O(config-router)# redistribute connected metric 1000 33 255 1 1500
R1-E# show ip route
10.0.0.0/24 is subnetted, 1 subnets
D EX
10.0.0.0 [170/3080448] via 172.30.0.2, 00:01:57, Serial0/0
D EX 192.168.1.0/24 [170/3080448] via 172.30.0.2, 00:01:57, Serial0/0
R1-E#
 192.168.1.0/24 is redistributed into EIGRP as a connected network.
 metric option is not required for this command (default 0, but beyond the scope of this
pres.)
 192.168.1.0/24 is redistributed into the EIGRP domain using the default metric but
it is NOT propagated throughout OSPF domain
Redistribution
into EIGRP
R2: Currently
router eigrp 1
network 172.30.0.0
auto-summary
redistribute ospf 1
default-metric 1000 33 255 1 1500
redistribute connected 1000 33 255 1 1500
!
 Where we left off…
router ospf 1
network 10.0.0.0 0.0.0.255 area 0
network 172.16.0.0 0.0.0.3 area 0
Redistributing from EIGRP into
OSPF
Redistribution
into OSPF
BW/DLY
BW
redistribute protocol [process-id | as-number] [metric
{metric-value | transparent}] [metric-type typevalue] [match {internal | external 1 | external 2 |
nssa-external}] [tag tag-value] [route-map map-tag]
[subnets]
 Several similarities and differences to redistributing into EIGRP.
 In this case we must convert the EIGRP metric to the Cisco OSPF
metric of Bandwidth.
Redistribution
into OSPF
redistribute protocol [process-id | as-number] [metric
{metric-value | transparent}] [metric-type type-value]
[match {internal | external 1 | external 2 | nssaexternal}] [tag tag-value] [route-map map-tag] [subnets]
 Metric - Defines the cost metric assigned to the route in the Type 5 (or Type 7 if
NSSA) LSA. metric transparent when taking from another OSPF process, pass
through the metric with the route.
 metric-type {1 | 2} - Defines the external metric type of 1 (E1 routes) or 2 (E2
routes).
 Match - If redistributing from OSPF, this keyword lets you match internal OSPF
routes, external (by type), and NSSA external routes, essentially filtering which routes
are redistributed.
 Tag - Assigns a unitless integer value to the route, which can be later matched by
other routers using a route-map.
 route-map - Apply the logic in the referenced route-map to filter routes, set metrics,
and set route tags.
 Subnets - Redistribute subnets of classful networks. Without this parameter, only
routes for classful networks are redistributed. (This behavior is particular to the OSPF
redistribute command.)
41
Redistribution
into OSPF
BW/DLY
BW=20
BW=20
redistribute protocol [process-id | as-number] [metric
{metric-value | transparent}] [metric-type type-value]
[match {internal | external 1 | external 2 | nssaexternal}] [tag tag-value] [route-map map-tag] [subnets]
 Defaults when redistributing into OSPF:
 When redistributing networks from all other sources the default
metric is 20.
 External metric type 2 (metric does not change throughout OSPF
routing domain)
 Only redistributes routes of classful (Class A, B, and C) networks,
and not for subnets
Redistribution
into OSPF
R2: Currently
router eigrp 1
network 172.30.0.0
auto-summary
redistribute ospf 1
default-metric 1000 33 255 1 1500
redistribute connected 1000 33 255 1 1500
!
 Where we left off…
router ospf 1
network 10.0.0.0 0.0.0.255 area 0
network 172.16.0.0 0.0.0.3 area 0
Redistribution
into OSPF
What do you expect to see?
EIGRP and OSPF networks
What networks
do I know about
R2-E-O# show ip route
and how did I
learn about
O
172.17.0.0/16 [110/846] via 172.16.0.1, 00:02:32, Serial0/1
them?
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
O
172.16.0.4/30 [110/845] via 172.16.0.1, 00:02:32, Serial0/1
C
172.16.0.0/30 is directly connected, Serial0/1
O
172.16.1.0/24 [110/782] via 172.16.0.1, 00:02:32, Serial0/1
O
172.16.2.0/24 [110/846] via 172.16.0.1, 00:02:32, Serial0/1
D
172.31.0.0/16 [90/20640000] via 172.30.0.1, 00:03:46, Serial0/0
172.30.0.0/16 is variably subnetted, 5 subnets, 2 masks
D
172.30.2.0/24 [90/20514560] via 172.30.0.1, 01:22:36, Serial0/0
D
172.30.3.0/24 [90/20640000] via 172.30.0.1, 01:22:36, Serial0/0
C
172.30.0.0/30 is directly connected, Serial0/0
D
172.30.1.0/24 [90/20514560] via 172.30.0.1, 01:22:36, Serial0/0
D
172.30.4.0/24 [90/20640000] via 172.30.0.1, 01:22:36, Serial0/0
10.0.0.0/24 is subnetted, 1 subnets
C
10.0.0.0 is directly connected, FastEthernet0/1
C
192.168.1.0/24 is directly connected, FastEthernet0/0
R2-E-O#
Redistribution
into OSPF
R2-E-O# show ip ospf data
OSPF Router with ID (192.168.1.1) (Process ID 1)
Router Link States (Area 0)
Link ID
172.16.1.1
172.30.0.6
192.168.1.1
R2-E-O#
ADV Router
172.16.1.1
172.30.0.6
192.168.1.1
Age
85
2000
1117
Seq#
0x80000005
0x80000006
0x80000003
Checksum
0x006220
0x006BB4
0x009742
Link count
5
4
3
 No External Type 5 LSAs
 No EIGRP networks being redistributed into OSPF
45
Redistribution
into OSPF
R2-E-O(config)# router ospf 1
R2-E-O(config-router)# redistribute eigrp 1
% Only classful networks will be redistributed
R2-E-O(config-router)#
R2-E-O# show ip ospf data
<Router Link States omitted>
Type-5 AS External Link States
Link ID
172.31.0.0
R2-E-O#
ADV Router
192.168.1.1
Age
9
Seq#
Checksum Tag
0x80000001 0x0094D4 0
 By default, only classful networks will be redistributed from EIGRP into OSPF.
 Subnets will not be redistributed
 Supernets will also be redistributed (such as 173.0.0.0/8)
Redistribution
into OSPF
Remember, routes are only
Redistributed if they are in the
Routing table
R2-E-O# show ip route
O
O
C
O
O
D
D
D
C
D
D
C
C
172.17.0.0/16 [110/846] via 172.16.0.1, 00:03:56, Serial0/1
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
172.16.0.4/30 [110/845] via 172.16.0.1, 00:03:56, Serial0/1
172.16.0.0/30 is directly connected, Serial0/1
172.16.1.0/24 [110/782] via 172.16.0.1, 00:03:56, Serial0/1
172.16.2.0/24 [110/846] via 172.16.0.1, 00:03:56, Serial0/1
172.31.0.0/16 [90/20640000] via 172.30.0.1, 00:18:29, Serial0/0
172.30.0.0/16 is variably subnetted, 5 subnets, 2 masks
172.30.2.0/24 [90/20514560] via 172.30.0.1, 01:37:19, Serial0/0
172.30.3.0/24 [90/20640000] via 172.30.0.1, 01:37:19, Serial0/0
172.30.0.0/30 is directly connected, Serial0/0
172.30.1.0/24 [90/20514560] via 172.30.0.1, 01:37:19, Serial0/0
172.30.4.0/24 [90/20640000] via 172.30.0.1, 01:37:19, Serial0/0
10.0.0.0/24 is subnetted, 1 subnets
10.0.0.0 is directly connected, FastEthernet0/1
192.168.1.0/24 is directly connected, FastEthernet0/0
47
Redistribution
into OSPF
I only see the class B
172.31.0.0/16 network
in the EIGRP domain.
172.17.0.0/16 [110/65] via 172.16.0.6, 00:01:16, Serial0/2
R3-O# show ip route
O
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
C
172.16.0.4/30 is directly connected, Serial0/2
C
172.16.0.0/30 is directly connected, Serial0/1
C
172.16.1.0/24 is directly connected, FastEthernet0/0
O
172.16.2.0/24 [110/65] via 172.16.0.6, 00:01:16, Serial0/2
O E2 172.31.0.0/16 [110/20] via 172.16.0.2, 00:01:16, Serial0/1
10.0.0.0/24 is subnetted, 1 subnets
O
10.0.0.0 [110/65] via 172.16.0.2, 00:01:17, Serial0/1
R3-O#
 Only the class B network 172.31.0.0/16 is redistributed into OSPF
Redistribution
into OSPF
R3-O# show ip ospf data
<Router Link States omitted>
Type-5 AS External Link States
Link ID
172.31.0.0
R3-O#
ADV Router
192.168.1.1
Age
88
Seq#
Checksum Tag
0x80000001 0x0094D4 0
 External Type 5 LSA
49
Redistribution
into OSPF
R2-E-O(config)# router ospf 1
I will add the subnets
option.
R2-E-O(config-router)# redistribute eigrp 1 subnets
No warning message “Only classful networks will be redistributed”
 Subnets – Subnets are now included in the redistribution.
Redistribution
into OSPF
R2-E-O# show ip ospf data
Type-5 AS External Link States
Link ID
172.30.0.0
172.30.1.0
172.30.2.0
172.30.3.0
172.30.4.0
172.31.0.0
R2-E-O#
ADV Router
192.168.1.1
192.168.1.1
192.168.1.1
192.168.1.1
192.168.1.1
192.168.1.1
Age
79
79
79
79
79
220
Seq#
0x80000001
0x80000001
0x80000001
0x80000001
0x80000001
0x80000001
Checksum
0x008EDE
0x0095D3
0x008ADD
0x007FE7
0x0074F1
0x0094D4
Tag
0
0
0
0
0
0
 R2 now includes Type 5 LSAs for subnets
51
Redistribution
into OSPF – E2
BW=20
R3-O#show ip route
O
Now I see all
networks and subnets
172.17.0.0/16 [110/65] via 172.16.0.6, 00:13:41, Serial0/2
from the EIGRP
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
domain.
External OSPF routes are E2 with a default cost of 20.
C
172.16.0.4/30 is directly connected, Serial0/2
C
172.16.0.0/30
is directly
connected,
metric-type
E2 - The
cost of a Serial0/1
type 2 route
C
is always the external
cost, irrespective
the interiorFastEthernet0/0
cost to reach that route.
172.16.1.0/24
is directly of
connected,
O
172.16.2.0/24 [110/65] via 172.16.0.6, 00:13:41, Serial0/2
O E2 172.31.0.0/16 [110/20] via 172.16.0.2, 00:13:41, Serial0/1
172.30.0.0/16 is variably subnetted, 5 subnets, 2 masks
O E2
172.30.2.0/24 [110/20] via 172.16.0.2, 00:00:12, Serial0/1
O E2
172.30.3.0/24 [110/20] via 172.16.0.2, 00:00:12, Serial0/1
O E2
172.30.0.0/30 [110/20] via 172.16.0.2, 00:00:12, Serial0/1
O E2
172.30.1.0/24 [110/20] via 172.16.0.2, 00:00:14, Serial0/1
O E2
172.30.4.0/24 [110/20] via 172.16.0.2, 00:00:14, Serial0/1
10.0.0.0/24 is subnetted, 1 subnets
O
10.0.0.0 [110/65] via 172.16.0.2, 00:00:14, Serial0/1
Redistribution
into OSPF
BW=20
BW=20
R4-0# show ip route
C
172.17.0.0/16 is directly connected, FastEthernet0/1
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
External OSPF routes are E2 with a default cost of 20.
C
172.16.0.4/30 is directly connected, Serial0/0
O
metric-type
2 - The
of a type 00:04:02,
2 route is always
the
172.16.0.0/30
[110/128]
viacost
172.16.0.5,
Serial0/0
O
external
cost, irrespective of the interior cost to reach that route.
172.16.1.0/24 [110/65] via 172.16.0.5, 00:04:02, Serial0/0
C
172.16.2.0/24 is directly connected, FastEthernet0/0
O E2 172.31.0.0/16 [110/20] via 172.16.0.5, 00:04:02, Serial0/0
172.30.0.0/16 is variably subnetted, 5 subnets, 2 masks
O E2
172.30.2.0/24 [110/20] via 172.16.0.5, 00:01:46, Serial0/0
O E2
172.30.3.0/24 [110/20] via 172.16.0.5, 00:01:46, Serial0/0
O E2
172.30.0.0/30 [110/20] via 172.16.0.5, 00:01:46, Serial0/0
O E2
172.30.1.0/24 [110/20] via 172.16.0.5, 00:01:46, Serial0/0
O E2
172.30.4.0/24 [110/20] via 172.16.0.5, 00:01:46, Serial0/0
10.0.0.0/24 is subnetted, 1 subnets
Redistribution
into OSPF
R4-0# show ip ospf data
Type-5 AS External Link States
Link ID
172.30.0.0
172.30.1.0
172.30.2.0
172.30.3.0
172.30.4.0
172.31.0.0
R4-0#
ADV Router
192.168.1.1
192.168.1.1
192.168.1.1
192.168.1.1
192.168.1.1
192.168.1.1
Age
113
113
113
113
113
254
Seq#
0x80000001
0x80000001
0x80000001
0x80000001
0x80000001
0x80000001
Checksum
0x008EDE
0x0095D3
0x008ADD
0x007FE7
0x0074F1
0x0094D4
Tag
0
0
0
0
0
0
 R4 now includes Type 5 LSAs for subnets
54
Redistribution
into OSPF
R2-E-O(config)#router ospf 1
R2-E-O(config-router)#redistribute connected ?
metric
Metric for redistributed routes
metric-type OSPF/IS-IS exterior metric type for redistributed routes
route-map
Route map reference
subnets
Consider subnets for redistribution into OSPF
tag
Set tag for routes redistributed into OSPF
<cr>
R2-E-O(config)#router ospf 1
R2-E-O(config-router)#redistribute connected
% Only classful networks will be redistributed
R2-E-O(config-router)#redistribute connected
subnets
 Let’s redistribute the 192.168.1.0/24 network into OSPF as a connected network.
 This is okay because 192.168.1.0/24 is a Class C network.
 If it was a subnet then…
Redistribution
into OSPF
R4-0# show ip route
<other output omitted>
E2 192.168.1.0/24 [110/20] via 172.16.0.5, 00:03:08, Serial0/0
R4-0# show ip ospf data
Type-5 AS External Link States
Link ID
<omitted>
192.168.1.0
R4-0#
ADV Router
Age
Seq#
Checksum Tag
192.168.1.1
193
0x80000001 0x0012B8 0
Summary
so far…
1000 33 255 1
BW=20
BW=20
R2 summary:
router eigrp 1
network 172.30.0.0
auto-summary
redistribute ospf 1
OSPF learned networks are distributed
into the EIGRP domain
default-metric 1000 33 255 1 1500
Use the metrics for BW DLY RLY Load
redistribute connected metric 1000 33 255 1 1500
Distribute any directly connected networks
and use these metrics for BW DLY RLY Load
!
router ospf 1
network 10.0.0.0 0.0.0.255 area 0
 So far…
network 172.16.0.0 0.0.0.3 area 0
redistribute eigrp 1 subnets
redistribute connected
EIGRP learned networks are distributed
into the OSPF domain, default metric of 20
Distribute any directly connected networks
and use default metric of 20
Redistribution
into OSPF – E2
R3-O#show ip route
O
C
C
C
O
O E2
O
O
O
O
E2
E2
E2
E2
O
O E2
172.17.0.0/16 [110/65] via 172.16.0.6, 00:13:41, Serial0/2
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
172.16.0.4/30 is directly connected, Serial0/2
172.16.0.0/30 is directly connected, Serial0/1
172.16.1.0/24 is directly connected, FastEthernet0/0
172.16.2.0/24 [110/65] via 172.16.0.6, 00:13:41, Serial0/2
172.31.0.0/16 [110/20] via 172.16.0.2, 00:13:41, Serial0/1
172.30.0.0/24 is subnetted, 4 subnets
External
OSPF
routes are E2 with a
172.30.2.0 [110/20] via 172.16.0.2,
00:11:25,
Serial0/1
default
cost ofSerial0/1
20.
172.30.3.0 [110/20] via 172.16.0.2,
00:11:25,
172.30.1.0 [110/20] via 172.16.0.2, 00:11:25, Serial0/1
metric-type 2 - The cost of a type 2
172.30.4.0 [110/20] via 172.16.0.2, 00:11:25, Serial0/1
route is always the external cost,
10.0.0.0/24 is subnetted, 1 subnets
irrespective of the interior cost to reach
10.0.0.0 [110/65] via 172.16.0.2, 00:13:43, Serial0/1
that 00:07:30,
route.
192.168.1.0/24 [110/20] via 172.16.0.2,
Serial0/1
58
Redistribution
into OSPF – E2
R4-0#show ip route
C
C
O
O
C
O E2
O
O
O
O
E2
E2
E2
E2
O
O E2
172.17.0.0/16 is directly connected, FastEthernet0/1
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
172.16.0.4/30 is directly connected, Serial0/0
172.16.0.0/30 [110/128] via 172.16.0.5, 00:14:05, Serial0/0
172.16.1.0/24 [110/65] via 172.16.0.5, 00:14:05, Serial0/0
172.16.2.0/24 is directly connected, FastEthernet0/0
172.31.0.0/16 [110/20] via 172.16.0.5, 00:14:05, Serial0/0
172.30.0.0/24 is subnetted, 4 subnets
External
OSPF
routes are E2
172.30.2.0 [110/20] via 172.16.0.5,
00:11:49,
Serial0/0
default
cost ofSerial0/0
20
172.30.3.0 [110/20] via 172.16.0.5,
00:11:49,
172.30.1.0 [110/20] via 172.16.0.5, 00:11:49, Serial0/0
172.30.4.0 [110/20] via 172.16.0.5, 00:11:49, Serial0/0
10.0.0.0/24 is subnetted, 1 subnets
10.0.0.0 [110/129] via 172.16.0.5, 00:14:07, Serial0/0
192.168.1.0/24 [110/20] via 172.16.0.5, 00:07:54, Serial0/0
with a
59
Redistribution
into OSPF
modifying the
metric
R2-E-O(config)#router ospf 1
R2-E-O(config-router)#redistribute eigrp 1 subnets metric 100
R2-E-O(config-router)#redistribute connected
R4-0#show ip route <external route>
O E2 172.31.0.0/16 [110/100] via
172.30.0.0/24 is subnetted,
O E2
172.30.2.0 [110/100] via
O E2
172.30.3.0 [110/100] via
O E2
172.30.1.0 [110/100] via
O E2
172.30.4.0 [110/100] via
O E2 192.168.1.0/24 [110/20] via
172.16.0.5,
4 subnets
172.16.0.5,
172.16.0.5,
172.16.0.5,
172.16.0.5,
172.16.0.5,
00:00:04, Serial0/0
00:00:05,
00:00:05,
00:00:05,
00:00:05,
00:12:36,
Serial0/0
Serial0/0
Serial0/0
Serial0/0
Serial0/0
 192.168.1.0/24 still has a cost of 20. Why?
 It was redistributed with the redistribute connected command without the
metric 100 parameter. <redistribute connected metric 100>
60
Redistribution
into OSPF – E1
R2-E-O(config)# router ospf 1
R2-E-O(config-router)# redistribute eigrp 1 subnets metric-type 1
R2-E-O# show run
Notice that the previous metric 100
router ospf 1
parameter is still included!
log-adjacency-changes
redistribute connected
redistribute eigrp 1 metric 100 metric-type 1 subnets
network 10.0.0.0 0.0.0.255 area 0
network 172.16.0.0 0.0.0.3 area 0
 metric-type {1 | 2} - Defines the external metric type of 1 (E1 routes) or 2 (E2
routes).
 metric-type 1 - A type 1 cost is the addition of the external cost and the internal cost
used to reach that route.
 metric-type 2 - The cost of a type 2 route is always the external cost, irrespective of
the interior cost to reach that route.
61
Redistribution
into OSPF
R3-O#show ip route
O E1 172.31.0.0/16 [110/164] via 172.16.0.2, 00:00:23, Serial0/1
172.30.0.0/24 is subnetted, 4 subnets
O E1
172.30.2.0 [110/164] via 172.16.0.2, 00:00:24, Serial0/1
O E1
172.30.3.0 [110/164] via 172.16.0.2, 00:00:24, Serial0/1
O E1
172.30.1.0 [110/164] via 172.16.0.2, 00:00:24, Serial0/1
O E1
172.30.4.0 [110/164] via 172.16.0.2, 00:00:24, Serial0/1
10.0.0.0/24 is subnetted, 1 subnets
O
10.0.0.0 [110/65] via 172.16.0.2, 00:21:45, Serial0/1
O E2 192.168.1.0/24 [110/20] via 172.16.0.2, 00:15:32, Serial0/1
 E1 routes, seed metric of 100 plus internal cost.
 192.168.1.0/24 still has a cost of 20.
 It was redistributed with the redistribute connected command without
the metric-type 1 parameter, E2 is the default.
<redistribute connected metric 100 metric-type 1>
62
More Redistribution Examples
63
Same Protocol
Stack
 You can only redistribute routes from routing protocols that support the
same protocol stack.
 IPv4 to IPv4
 IPv6 to IPv6
64
RIPv2 and OSPF Example
 Routing tables prior to redistribution
65
X
 The passive-interface command is configured for interface serial
0/0/2 to prevent RIPv2 from sending route advertisements out that
interface.
 OSPF is configured on interface serial 0/0/2.
66
 The goal of redistribution in this network is for all routers to recognize all
routes within the company.
 RIPv2 is redistributed into the OSPF process, and the metric is set using the
redistribute command (help prevent routing loops - later).
 A metric value of 300 is selected because it is a worse metric than any
belonging to a native OSPF route.
 Routes from OSPF process 1 are redistributed into the RIPv2 process with
a metric of 5.
 A value of 5 is chosen because it is higher than any metric in the RIP
network.
67
R
10.0.0.8/30
O E2
10.0.0.0/30
 There is complete reachability; however, Routers A and C now have many
more routes to keep track of than before.
 They also will be affected by any topology changes in the other routing
domain.
68
 For RIPv2 on Router A, the summarization command is configured on the
interface connecting to Router B, interface S0/0/0.
 Interface S0/0/0 advertises the summary address instead of the
individual subnets.
 10.0.0.0 255.252.0.0 summarizes the four subnets on Router A
(including the 10.0.0.0/30 subnet).
69
 For OSPF, summarization must be configured on an area border router
(ABR) or an ASBR.
 Router C summarization command is configured under the OSPF process
on Router C.
 10.8.0.0 255.252.0.0 summarizes the four subnets on Router C.
70
Redistribution Techniques and
Issues
71
501
Seed Metric
Largest metric
is 500
OSPF1
RIP
501
router ospf 1
network 172.20.0.0
redistribute rip
default-metric 501
or
redistribute rip metric 501
 When redistributing information, the seed metric should be set to a value
larger than the largest metric within the receiving autonomous system (aka
the largest native metric).
 This will help prevent suboptimal routing and routing loops.
 The default seed metric value for routes that are redistributed into each IP
routing protocol.
 A metric of infinity tells the router that the route is unreachable and, therefore,
should not be advertised.
 When redistributing routes into RIP, IGRP, and EIGRP, you must specify
a seed metric, or the redistributed routes will not be advertised.
 For OSPF, the redistributed routes have a default type 2 (E2) metric of 20,
(except for redistributed BGP routes, which have a default type 2 metric of 1)
73
One-Point Redistribution
 One-point redistribution has only one router redistributing between two
routing protocols.
 A one-way redistribution issue that could occur…
74
 R2 and R3 are both running
OSPF and EIGRP
 Only R2 is redistributing
between OSPF en EIGRP
 R1 has an External Route
10.0.0.0 that it is redistributing
into its AS.
 R1 is propagating this route to
both R2 and R3.
10.0.0.0 via R1 has AD 170 (EX EIGRP)
10.0.0.0 via R2 has AD 110 (OSPF)
So, I will choose (include in my routing
table) the path via R2 (OSPF)
 R3 receives routing update information for the external route 10.0.0.0.
directly from:
 R1 via EIGRP (AD = 170)
 R2 via OSPF (AD = 110)
 Because the AD of OSPF (110) is lower than AD of external EIGRP routes
(170), R3 selects the OSPF route.
 Suboptimal routing
 Instead of sending packets directly from router R3 to router R1, router R3
prefers the path via router R2, resulting in suboptimal routing.
 Solution: R2 should redistribute EIGRP route into OSPF with an AD of 115.
 We will see how to do this later.
75
Multipoint redistribution
 Multipoint redistribution has two separate routers running both routing
protocols.
 Two possibilities exist:
 Multipoint one-way redistribution
 Multipoint two-way redistribution
 Likely to introduce potential routing loops
76
10.0.0.0 via R1 has AD 170 (EX EIGRP)
10.0.0.0 via R3 has AD 110 (OSPF)
A one-way
So, I willmultipoint
choose (include in my routing
table) the pathissue.
via R3 (OSPF)
redistribution
10.0.0.0 via R1 has AD 170 (EX EIGRP)
10.0.0.0 via R2 has AD 110 (OSPF)
So, I will choose (include in my routing table)
the path via R2 (OSPF)
 R1 (EIGRP) is announcing
routes, including the
external route, to R2 and
R3.
 R2 and R3 are both running
two routing protocols
(EIGRP and OSPF) and
redistributing EIGRP into
OSPF.
 Therefore, R2 and R3 receive routing update information for the external
route 10.0.0.0:
 via EIGRP from router R1 and
 via OSPF (R2 from R3, and R3 from R2).
 The AD of OSPF (110) is lower than AD of external EIGRP (170):
 So R2 selects the OSPF route instead of sending packets directly to R1
 R2 prefers the path via router R3
 Routing Loop!
77
10.0.0.0 via R1 has AD 170 (EX EIGRP)
10.0.0.0 via R3 has AD 110 (OSPF)
So, I will choose (include in my routing
table) the path via R3 (OSPF)
10.0.0.0 via R1 has AD 170 (EX EIGRP)
10.0.0.0 via R2 has AD 110 (OSPF)
So, I will choose (include in my routing table)
the path via R2 (OSPF)
 To prevent routing loops in multipoint redistribution scenario the following
recommendations should be considered:
 Tag routes in redistribution points and filter based on these tags when
redistributing (later)
 Modify the Administrative Distance of redistributed routes (later)
 Use default routes to avoid having to do two-way redistribution
78
A multi-way multipoint
redistribution issue
 The best path between R1 and R4 is via R3
 But during redistribution from routing protocol B to routing protocol A, the
metric is lost
 Domain A doesn’t know about metrics in Domain B
 R1 will send packets toward router R4 via router R2 (its best path outside its
domain)
 Resulting in suboptimal routing.
79
Modifying Administrative
Distance
80
AD
 The administrative distance affects only the choice of path for identical IP
routes.
 In other words, routes that have identical prefix and mask.
 Routes with a distance of 255 are not installed in the routing table.
81
Router(config-router)# distance administrative-distance [address
wildcard-mask [ip-standard- list] [ip-extended-list]]
 This command can be used for all protocols.
 There are additional options for each routing protocol.
82
 distance eigrp 80 130
 Sets the administrative distance for internal EIGRP routes to 80 and for
external EIGRP routes to 130.
 distance 90 192.168.7.0 0.0.0.255
 Sets the administrative distance to 90 for all routes learned from routers
on the Class C network 192.168.7.0
 distance 120 172.16.1.3 0.0.0.0
 Sets the administrative distance to 120 for all routes from the router with
the address 172.16.1.3.
83
 distance ospf external 100 inter-area 100 intra-area 100
 Sets the administrative distance for external, inter-area, and intra-area
OSPF routes to 100 (default values are 110).
 distance 90 10.0.0.0 0.0.0.255, distance 110 10.11.0.0
0.0.0.255, and distance 130 10.11.12.0 0.0.0.255
 Sets the administrative distance to 90, 110, and 130 respectively, for all
routes learned from routers with specific addresses
 Routes from a router with address 10.10.0.1 will have an AD of 90
 Routes from a router with address 10.11.12.1 will have an AD of 130.
84
Example
R1 and R2
 OSPF (AD 110) is by
default considered more
believable than RIPv2
(120)
 If R1 learns about
network 10.3.3.0:
 via R2 (OSPF)
 Via R3 (RIPv2)
 The OSPF route is used
because OSPF has a
lower administrative
distance than RIPv2,
even though the path via
OSPF might be the
longer (worse) path.
AD = 110
Preferred
AD = 120
10.3.3.0/24
85
Example
R1 and R2







Note: RIPv2 routes
redistributed into OSPF have
an OSPF seed metric of
10,000 (higher than any other
OSPF route).
This does not prevent our
previous problem
Makes these routes less
preferred than native OSPF
routes
Protects against route
feedback.
Prevents R1 from choosing
R2 for OSPF routes it learns
from internal OSPF routers.
The redistribute command
also sets the metric type to 1
(external type 1) so that the
route metrics continue to
accrue.
The routers also redistribute
subnet information.
AD = 110
Metric = 10,000
Metric = 10,000
Metric
=5
AD = 120
10.3.3.0/24
86
Example
R1 and R2
 The OSPF routes
redistributed into RIPv2
have a RIP seed metric
of five hops to also
protect against route
feedback.
AD = 110
Metric = 10,000
Metric = 10,000
Metric
=5
AD = 120
10.3.3.0/24
87
My best path to all RIP networks is
via R1 because OSPF (110) is
better than RIP (120).
 R2, receives information about the RIPv2 domain routes (also called the
native RIPv2 routes) from both OSPF and RIPv2.
 R2 prefers the OSPF routes because OSPF has a lower administrative
distance
 Therefore, none of the RIPv2 routes appears in R2’s routing table.
 All routes are via OSPF or directly connected.
88
Solution: Modifying the AD
 You can change the administrative distance of the redistributed RIPv2 routes
to ensure that the boundary routers select the native RIPv2 routes.
 The distance command on R1 and R2 changes the administrative distance of
the OSPF routes to the networks that match access list 64 to 125 (from 110).
 Access list 64 is used to match all the native RIPv2 routes.
89
 R1 and R2 are assign an
AD of 125 to routes
listed in access list 64
(routes learned from
OSPF).
 R1 and R2 prefer the
native RIPv2 routes (AD
120) over the
redistributed OSPF
routes (AD 125) in their
routing tables.
 R1 will put the
10.200.200.34 network in
its routing table as a RIP
route (AD 120) instead of
the OSPF (AD 125) route
it learned via R2.
AD = 110
Metric = 10,000
AD = 125
Metric = 10,000
AD = 125
Metric
=5
AD = 120
Preferred
90
My best path to all RIP networks is
via R4 because RIP (120) is better
than redistributed RIP (125).
 However, some routing information is lost with this configuration.
 For example, depending on the actual bandwidths, the OSPF path
might have been better for the 10.3.1.0 network; it might have made
sense not to include 10.3.1.0 in the access list for R2.
91
Verifying Redistribution
 The best way to verify redistribution operation is as follows:
 Know your network topology, particularly where redundant routes exist.
 Study the routing tables on a variety of routers in the internetwork using
the show ip route
 Perform a trace using the traceroute on some of the routes that go
across the autonomous systems to verify that the shortest path is being
used for routing.
92
More on OSPF and External
Routes
Determining
the Next-hop
for Type 2
External
Routes
- Intra-area
172.30.26.0/23
Metric = 20
Metric
= 20
LSA 5
Best path
 Review later slides for explanation
94
Determining
the Next-hop
for Type 2
External
Routes
- Interarea
LSA 4: I am ABR
R4, I can reach
ASBR R1 and my
cost to the ASBR
is 64.
172.30.26.0/23
LSA 4: I am ABR
R3, I can reach
ASBR R1 and my
cost to the ASBR
is 1.
Metric
= 20
Best path
R5# show ip route
O E2
172.30.26.0/23 [110/20] via 172.16.35.3, 05:48:42, Serial0/0
 Review later slides for explanation
95
Comparing E1
and E2
EIGRP
ASBR1
OSPF
E2 metric=10
E2 metric=20
ASBR2
 The benefits of the different external route types apply mostly to
when multiple ASBRs advertise the same subnet.
 Two ASBRs, ASBR1 and ASBR2, between OSPF and another
routing domain.
 Goal is to always send traffic through ASBR1.
 Configuration:
 Use E2 routes
 Set the metric for ASBR1's redistributed routes to a lower metric
than ASBR2.
 Routers ignore the internal metrics when calculating the E2 metrics,
so every router will choose ASBR1 as the better ASBR.
96
Comparing E1
and E2
EIGRP
OSPF
ASBR1
E1
E1
ASBR2
 Goal is to:
 Balance the traffic
 Make each router pick the closest ASBR
 Configuration:
 Use E1 routes
 Routers closer to each ASBR choosing best routes based on the
lower OSPF costs.
97
Comparing
E1 and E2
EIGRP
OSPF
ASBR1
E1
E2
ASBR2
 Note: OSPF routers will always prefers E1 routes over E2 routes for
the same networks.
98
FYI:
More on OSPF and External
Routes
Redistribution
into OSPF
EIGRP
OSPF
Area 0
Area 1
 New Topology
100
Redistribution
into OSPF
redistribute protocol [process-id | as-number] [metric
{metric-value | transparent}] [metric-type type-value]
[match {internal | external 1 | external 2 | nssaexternal}] [tag tag-value] [route-map map-tag] [subnets]
 Default if no metric configuration exists
 Cost 1 for routes learned from BGP
 Cost 20 for all other route sources
 default-metric cost OSPF subcommand
 Setting the default for all redistribute commands
 metric cost parameters on the redistribute command
 Setting the metric for one route source
 Metric transparent parameters on the redistribute command
 When taking routes from another OSPF process, using the metrics used by that
route source
 Use the route-map parameter on the redistribute command
 Setting different metrics for routes learned from a single source
101
Redistribution
into OSPF
 Router that performs redistribution becomes ASBR (Autonomous
System Border Router).
 Injects external routes into OSPF creating a Type 5 LSA for each
network/subnet .
 Type 5 LSA includes:
 LSID: the subnet number
 Mask: The subnet mask
 Advertising router: The RID of the ASBR injecting the route
 Metric: The metric as set by the ASBR
 External Metric Type: The external metric type, either 1 or 2
102
Redistribution
into OSPF
LSA 5
 ASBR floods Type 5 LSAs throughout area.
 If ABR is:
 Normal (non-stubby) areas:
 Flood Type 5 LSAs into area
 Stub and Totally Stubby areas:
 No Type 5 LSAs flooded
 Default route injected by ABR
103
Redistributing External Type 2
Routes
Redistribution
into OSPF
LSA 5
172.30.26.0/23
Metric = 20
Metric
= 20
 E2 route’s metric is simply the metric in the Type 5 LSA.
 Default = 20
 metric parameter
 R4 has two routes to 172.30.26.0/23:
 Via R1
 Via R8
 To avoid loops, OSPF routers use two tiebreaker systems to allow a router
to choose a best external route.
 Router in question resides in the same area as the ASBR (intra-area)
 Router in question resides in a different area (interarea) than the ASBR
105
Determining
the Next-hop
for Type 2
External
Routes
- Intra-area
172.30.26.0/23
Metric = 20
Metric
= 20
LSA 5
 Router has multiple routes for same E2 destination network:
 Selects the best route based on the lowest cost to reach any ASBR(s)
that advertised the lowest E2 metric.
 R4: Both routes use metric 20 in this case, so the routes tie.
 Tiebreaker:
1. Find the advertising ASBR(s) as listed in the Type 5 LSA(s)
2. Using the intra-area LSDB topology calculate the best route to reach
the ASBR(s). (This is the route that will be entered into the routing
table.)
3. This determines the outgoing interface and next hop based address to
to reach the ASBR
4. The route's metric is unchanged in the routing table as listed in
theType 5 LSA
106
Determining
the Next-hop
for Type 2
External
Routes
- Intra-area
172.30.26.0/23
Metric = 20
Metric
= 20
LSA 5
Best path
1. R4 looks in the Type 5 LSA, and sees RID 1.1.1.1 (R1) is the
advertising ASBR.
2. R4 then looks at its area 0 LSDB entries, including the Type 1 LSA
for RID 1.1.1.1, and calculates all possible area 0 routes to reach
1.1.1.1.
3. R4's best route to reach RID 1.1.1.1 happens to be through its
S0/0/0 interface, to next-hop RD1 (172.16.14.1), so R4's route to
172.16.26.0/23 uses these details.
4. The route lists metric 20, as listed in the Type 5 LSA.
107
Determining
the Next-hop
for Type 2
External
Routes
- Interarea
172.30.26.0/23
LSA 5
Metric = 20
Metric
= 20
 When router is in a different area same issues remain.
 Different tiebreaker to reach ASBR.
 Calculation requires more information that previous Intra-area
example.
 To calculate their best route to reach the ASBR, a router in another
area:
 Adds the cost to reach an ABR between the areas
 Plus that ABR's cost to reach the ASBR
108
Determining
the Next-hop
for Type 2
External
Routes
- Interarea
172.30.26.0/23
64
1
64
64
Best path
 R5 has two possible routes to reach ASBR:
 Via R3
 Via R4
 Although the metric is 20, R5 will use the cost to the ABR PLUS the ABR’s
cost to the ASBR to determine the best path.
 Via R3: 64 + 1 = 65
 Via R4: 64 + 64 = 128
 R5 chooses the route via R3 because it is a better path (65).
 The router’s process for doing this is:
1. Calculate the cost to reach the ABR, based on the area's topology
database
2. Add the cost from the ABR to the ASBR, as listed in a Type 4 LSA
 Let’s talk about that Type 4 LSA!
109
Determining
the Next-hop
for Type 2
External
Routes
- Interarea
172.30.26.0/23
LSA 4: I am ABR
R3, I can reach
ASBR R1 and my
cost to the ASBR
is 1.
LSA 4: I am ABR
R4, I can reach
ASBR R1 and my
cost to the ASBR
is 64.
LSA 4
 The following slides provide additional information on LSA 4s if you are
interested...
 Otherwise
 The End 
110
Determining
the Next-hop
for Type 2
External
Routes
- Interarea
172.30.26.0/23
LSA 4: I am ABR
R3, I can reach
ASBR R1 and my
cost to the ASBR
is 1.
LSA 4: I am ABR
R4, I can reach
ASBR R1 and my
cost to the ASBR
is 64.
LSA 4
 Type 4 Summary ASBR LSA:
 RID of the ASBR
 RID of the ABR that created and flooded the LSA 4
 ABR's cost to reach the ASBR
 ABRs create Type 4 LSAs after receiving an external Type 5 LSA from an
ASBR.
 ABR forwards a Type 5 LSA into an area
 ABR looks at the RID of the ASBR that created the Type 5 LSA..
 ABR creates a Type 4 LSA listing that ASBR, and the cost to reach
that ASBR, flooding that LSA into the neighboring areas.
111
Determining
the Next-hop
for Type 2
External
Routes
- Interarea
LSA 4: I am ABR
R4, I can reach
ASBR R1 and my
cost to the ASBR
is 64.
172.30.26.0/23
LSA 4: I am ABR
R3, I can reach
ASBR R1 and my
cost to the ASBR
is 1.
LSA 4
Best path
 ABR R3 creates and floods Type 4 Summary ASBR LSA into area 1.
 ASBR 1.1.1.1 (R1), ABR 3.3.3.3 (R3), and cost 1 (R3's cost to reach
ASBR).
 ABR R4 creates and floods Type 4 Summary ASBR LSA into area 1.
 ASBR 1.1.1.1 (R1), ABR 4.4.4.4 (R4), and lists cost 64 (R4's cost to
reach ASBR).
 When R5 finds two routes for subnet 172.30.26.0/23, and finds both have a
metric of 20
 Break the tie.
 For each route: Add intra-area cost to reach the ABR PLUS the ABR's
cost to reach the ASBR (as listed in the Type 4 LSA).
 R5 determines best route is through R3 has the lower cost (65).
112
Determining
the Next-hop
for Type 2
External
Routes
- Interarea
LSA 4: I am ABR
R4, I can reach
ASBR R1 and my
cost to the ASBR
is 64.
172.30.26.0/23
LSA 4: I am ABR
R3, I can reach
ASBR R1 and my
cost to the ASBR
is 1.
Best path
R5# show ip route
O E2
172.30.26.0/23 [110/20] via 172.16.35.3, 05:48:42, Serial0/0
113
CIS 185 CCNP ROUTE
Ch. 4 Manipulating Routing Updates
Rick Graziani
Cabrillo College
graziani@cabrillo.edu
Download