odom_021512_ospf_slides

advertisement
OSPF Concepts and Configuration
Presented by
Wendell Odom, CCIE No. 1624
pearsonITcertification.com/odom
Welcome – Our Agenda Today
• Tutorial
• Q&A - Use WEBEX event CHAT to ask Wendell a
Question
• Live Event Survey
Feedback wanted. Attendees from the Live event, please
complete survey and be registered to win a FREE Cisco
Press or Pearson IT Certification book, eBook or video of
your choice. Three (3) winners.
SPECIAL OFFER – Webcast Attendees
Save 30%, plus free U.S. ground shipping
Use coupon code ODOMWEBCAST
Visit pearsonITcertification.com/odom for all
of Wendell Odom’s products
Plus Limited Time Offer – Save 50% on
NEW Premium Edition eBook & Practice
Test and CCNA Video Mentor.
No code required.
Today’s Sample Network
Fa0/0
10.1.12.2
S0/0/1
R2
10.2.2.2
10.1.12.1
S0/0/0
Fa0/0
10.1.1.1
S0/0/1
R1
10.1.13.1
S0/0/0
10.1.13.3
Fa0/0
R3
10.3.3.3
S0/1/0
10.1.14.1
S0/0/0
Fa0/0
10.1.14.4
R4
R4
10.4.4.4
For copies of key figures during the live show, browse to
Certskills.com, lower right.
OSPF Configuration Options
1) Enable OSPF
2) Enable OSPF on interfaces
3) Set Router ID
4) Set Hello and Dead Intervals
5) Tune OSPF metrics
6) Enable OSPF authentication
7) Set Number of equal routes
(router ospf process-id)
(network DDN WC_mask area area-id)
(router-id DDN, or
interface loopback number)
(ip ospf hello-interval number,
ip ospf dead-interval number)
(ip ospf cost number, or
bandwidth number, or
auto-cost-reference-bandwidth number )
(ip ospf authentication, or
area authentication)
(maximum-paths number)
Likely Points of CCNA Config Confusion
1) Mechanics of network commands and wildcard
masks
2) “Best” options for same
3) OSPF Process ID matching (or not)
4) Unique OSPF Router ID
OSPF WC Mask Options
Exact Match (0.0.0.0)
Match Subnet (255.255.255.255
– Subnet_Mask)
Match Classful Network
(255.255.255.255 –
Network_Mask)
Match All (255.255.255.255)
Exact Match
network 10 .
10.1.12.1
1. 12 .
1
10 .
1.
1.
1
10 .
1 . 12 .
1
10 .
1 . 13 .
1
10 .
1 . 14 .
1
S0/0/0
Fa0/0
10.1.1.1
S0/0/1
R1
10.1.13.1
S0/1/0
10.1.14.1
0.
0.
0.
0
OSPF WC Mask Options
Exact Match (0.0.0.0)
Match Subnet (255.255.255.255
– Subnet_Mask)
Match Classful Network
(255.255.255.255 –
Network_Mask)
Match All (255.255.255.255)
Match Subnet
255 . 255 . 255 . 255
255 . 255 . 255 . 0 Subnet Mask
0.
0.
0 . 255 Wildcard Mask
Match Subnet
network 10 .
10.1.12.1
1. 12 .
1
0
10 .
1.
1.
1
10 .
1 . 12 .
1
10 .
1 . 13 .
1
10 .
1 . 14 .
1
S0/0/0
Fa0/0
10.1.1.1
S0/0/1
R1
10.1.13.1
S0/1/0
10.1.14.1
0.
0.
0 .255
OSPF WC Mask Options
Exact Match (0.0.0.0)
Match Subnet (255.255.255.255
– Subnet_Mask)
Match Classful Network
(255.255.255.255 –
Network_Mask)
Match All (255.255.255.255)
Match Class A Network
255 . 255 . 255 . 255
255 . 0 . 0 . 0 Default Class A Network Mask
0 . 255 . 255 . 255 Wildcard Mask
Match Network
network 10 .
10.1.12.1
1. 12
0.
0.
1
0
10 .
1.
1.
1
10 .
1 . 12 .
1
10 .
1 . 13 .
1
10 .
1 . 14 .
1
S0/0/0
Fa0/0
10.1.1.1
S0/0/1
R1
10.1.13.1
S0/1/0
10.1.14.1
0 .255 . 255 .255
OSPF WC Mask Options
Exact Match (0.0.0.0)
Match Subnet (255.255.255.255
– Subnet_Mask)
Match Classful Network
(255.255.255.255 –
Network_Mask)
Match All (255.255.255.255)
Match All
network 10
0.
10.1.12.1
1. 12
0.
0.
1
0
10 .
1.
1.
1
10 .
1 . 12 .
1
10 .
1 . 13 .
1
10 .
1 . 14 .
1
S0/0/0
Fa0/0
10.1.1.1
S0/0/1
R1
10.1.13.1
S0/1/0
10.1.14.1
255 .255 . 255 .255
Exact Match (0.0.0.0)
Match Subnet (255.255.255.255
– Subnet_Mask)
Match Classful Network
(255.255.255.255 –
Network_Mask)
Match All (255.255.255.255)
Single Area OSPF Design
Area 0
Fa0/0
10.1.12.2
S0/0/1
R2
10.2.2.2
10.1.12.1
S0/0/0
Fa0/0
10.1.1.1
S0/0/1
R1
10.1.13.1
S0/0/0
10.1.13.3
Fa0/0
R3
10.3.3.3
S0/1/0
10.1.14.1
S0/0/0
Fa0/0
10.1.14.4
R4
R4
10.4.4.4
Single Area OSPF Config
router ospf 1
network 0.0.0.0
255.255.255.255
area 0
Fa0/0
10.1.12.2
router ospf 1
network 10.1.0.0
0.0.255.255 area 0
10.1.12.1
S0/0/0
Fa0/0
10.1.1.1
S0/0/1
R1
10.1.13.1
S0/0/1
router ospf 1
network 0.0.0.0
R2
255.255.255.255
S0/0/0
10.1.13.3
10.2.2.2
area 0
Fa0/0
R3
10.3.3.3
S0/1/0
10.1.14.1
router ospf 4
network 10.1.14.0
network 10.4.4.0
0.0.0.255
0.0.0.255
S0/0/0
Fa0/0
10.1.14.4
R4
R4
10.4.4.4
area 0
area 0
Multi-Area OSPF Design
Area 0
Fa0/0
10.1.12.2
S0/0/1
R2
10.2.2.2
10.1.12.1
S0/0/0
Fa0/0
10.1.1.1
S0/0/1
R1
10.1.13.1
S0/0/0
10.1.13.3
Fa0/0
R3
10.3.3.3
S0/1/0
10.1.14.1
Area 14
S0/0/0
Fa0/0
10.1.14.4
R4
R4
10.4.4.4
Multi-Area OSPF Config
(Unchanged)
router ospf 1
network 10.1.1.1
network 10.1.12.1
network 10.1.13.1
network 10.1.14.1
0.0.0.0
0.0.0.0
0.0.0.0
0.0.0.0
area
area
area
area
10.1.12.1
S0/0/0
Fa0/0
10.1.1.1
S0/0/1
R1
10.1.13.1
0
0
0
14
Fa0/0
10.1.12.2
S0/0/1
10.2.2.2
R2
(Unchanged)
S0/0/0
10.1.13.3
Fa0/0
R3
10.3.3.3
S0/1/0
10.1.14.1
router ospf 4
network 10.1.14.0
network 10.4.4.0
0.0.0.255
0.0.0.255
S0/0/0
Fa0/0
10.1.14.4
R4
R4
10.4.4.4
area 14
area 14
What are the OSPF Router IDs?
Fa0/0
10.1.12.2
S0/0/1
R2
10.2.2.2
10.1.12.1
S0/0/0
Fa0/0
10.1.1.1
S0/0/1
R1
10.1.13.1
S0/0/0
10.1.13.3
Fa0/0
R3
10.3.3.3
S0/1/0
10.1.14.1
S0/0/0
Fa0/0
10.1.14.4
R4
R4
10.4.4.4
More Resources
Like WendellOdom
Wendell’s Blogs, including an OSPF lab related to
today’s webinar: certskills.com/blogs
Find lists of Cisco certification tools, suggestions,
& links at certskills.com
Register to win a CCNA Exam and CCNA Products
at pearsonitcertification.com/ccnasale
Ends March 31, 2012
SAVE 30%
Use coupon code ODOMWEBCAST at checkout to
receive discount, plus FREE U.S. ground shipping.
Visit pearsonITcertification.com/odom for all products,
articles, & podcasts by Wendell Odom.
Introducing
Premium Edition eBook + Practice Tests
SAVE 50%
…..for a limited time
Simply add to cart, 50%
discount is automatically
applied.
Visit pearsonITcertification.com/odom for all products,
articles, & podcasts by Wendell Odom.
Q&A
Thank you.
Expect an e-mail with information on how you can access the
recorded session and survey link.
More Webcasts @ pearsonITcertification.com/webcasts.
Feedback wanted. Attendees from the Live event, please complete
survey and be registered to win a FREE Cisco Press or Pearson IT
Certification book, eBook or video of your choice. Three winners.
Connect with Us
FREE Podcasts
on Certification
pearsonITcertification.com/podcasts
Download
Related flashcards
Create Flashcards