Optimizing Converged

Cisco Networks (ONT)

Module 3: Introduction to IP QoS

© 2006 Cisco Systems, Inc. All rights reserved.

Lesson 3.4: Using

MQC for

Implementing QoS

© 2006 Cisco Systems, Inc. All rights reserved.

Objectives

 Identify the features of each method for QoS policy implementation.

 Describe the guidelines for using CLI to implement QoS policy.

 Describe the Modular QoS Command Line (MQC)

© 2006 Cisco Systems, Inc. All rights reserved.

Methods for Implementing QoS Policy

Method

Legacy CLI

MQC

Cisco AutoQoS

Description

– Coded at the CLI

– Requires each interface to be individually configured

– Time-consuming

– Coded at the CLI

– Uses configuration modules

– Best method for QoS fine tuning

– Applies a possible QoS configuration to the interfaces

– Fastest way to implement QoS

Cisco SDM QoS wizard – Application for simple QoS configurations

© 2006 Cisco Systems, Inc. All rights reserved.

Configuring QoS at the CLI

 Uses the CLI via console and Telnet

 Traditional method

 Nonmodular

 Cannot separate traffic classification from policy definitions

 Time-consuming and potentially error-prone task

 Used to augment and fine-tune newer Cisco AutoQoS method

© 2006 Cisco Systems, Inc. All rights reserved.

Guidelines for Using the CLI

Configuration Method

 Build a traffic policy:

Identify the traffic pattern.

Classify the traffic.

Prioritize the traffic.

Select a proper QoS mechanism:

Queuing

Compression

 Apply the traffic policy to the interface.

© 2006 Cisco Systems, Inc. All rights reserved.

Legacy CLI QoS Example

 interface multilink

 ip address 10.1.61.1 255.255.255.0

 load-interval 30

 custom-queue-list 1

 ppp multilink

 ppp multilink fragment-delay 10

 ppp multilink interleave

 multilink-group 1

 ip tcp header-compression iphc-format

 !

 queue-list 1 protocol ip 2 tcp 23

 For interactive traffic, you can use CQ and TCP header compression.

© 2006 Cisco Systems, Inc. All rights reserved.

Modular QoS CLI

 A command syntax for configuring QoS policy

 Reduces configuration steps and time

 Configures policy, not “raw” per-interface commands

 Uniform CLI across major Cisco IOS platforms

 Uniform CLI structure for all QoS features

 Separates classification engine from the policy

© 2006 Cisco Systems, Inc. All rights reserved.

Modular QoS CLI Components

© 2006 Cisco Systems, Inc. All rights reserved.

Step 1: Creating Class Maps:

“What Traffic Do We Care About?”

 Each class is identified using a class map.

 A traffic class contains three major elements:

A case-sensitive name

A series of match commands

An instruction on how to evaluate the match commands if more than one match command exists in the traffic class

 Class maps can operate in two modes:

Match all: All conditions have to succeed.

Match any: At least one condition must succeed.

 The default mode is match all.

© 2006 Cisco Systems, Inc. All rights reserved.

Configuring Class Maps

 Enter class-map configuration mode. Specify the matching strategy.

router(config)# class-map [match-all | match-any] class-map-name

 Use at least one condition to match packets.

router(config-cmap)# match any match not match-criteria

 Use descriptions in large and complex configurations. The description has no operational meaning.

router(config-cmap)# description description

© 2006 Cisco Systems, Inc. All rights reserved.

Classifying Traffic with ACLs

 Standard ACL router(config)# access-list access-list-number {permit | deny | remark}

source [mask]

 Extended ACL router(config)# access-list access-list-number {permit | deny} protocol

source source-wildcard [operator port] destination

destination-wildcard [operator port] [established] [log]

 Use an ACL as a match criterion router(config-cmap)# match access-group access-list-number

© 2006 Cisco Systems, Inc. All rights reserved.

Step 2: Policy Maps:

“What Will Be Done to This Traffic?”

 A policy map defines a traffic policy, which configures the QoS features associated with a traffic class that was previously identified using a class map.

 A traffic policy contains three major elements:

A case-sensitive name

A traffic class

The QoS policy that is associated with that traffic class

 Up to 256 traffic classes can be associated with a single traffic policy.

 Multiple policy maps can be nested to influence the sequence of QoS actions.

© 2006 Cisco Systems, Inc. All rights reserved.

Configuring Policy Maps

 Enter policy-map configuration mode. Policy maps are identified by a case-sensitive name.

router(config)# policy-map policy-map-name

 Enter the per-class policy configuration mode by using the name of a previously configured class map. Use the class-default name to configure the policy for the default class.

router(config-pmap)# class {class-name | class-default}

 Optionally, you can define a new class map by entering the condition after the name of the new class map. Uses the match-any strategy.

router(config-pmap)# class class-name condition

© 2006 Cisco Systems, Inc. All rights reserved.

Step 3: Attaching Service Policies:

“Where Will This Policy Be Implemented?”

 Attach the specified service policy map to the input or output interface router(config-if)# service-policy {input | output} policy-map-name class-map HTTP match protocol http

!

policy-map PM class HTTP bandwidth 2000 class class-default bandwidth 6000

!

interface Serial0/0 service-policy output PM

Service policies can be applied to an interface for inbound or outbound packets

© 2006 Cisco Systems, Inc. All rights reserved.

Modular QoS CLI Configuration Example

1 router(config)# class-map match-any business-critical-traffic router(config-cmap)# match protocol http url “*customer*” router(config-cmap)# match protocol http url citrix

2 router(config)# policy-map myqos policy router(config-pm am)# class business-critical-traffic router(config-pm am-c)# bandwidth 1000

3 router(config)# interface serial 0/0 router(config-if)# service-policy output myqos policy

© 2006 Cisco Systems, Inc. All rights reserved.

Boolean Nesting

Goal

Salaries

Football

Players

Hockey

Players

Goal: Find books that cover the salaries of either football players or hockey players.

Solution: Boolean (salaries AND [football players OR hockey players]).

© 2006 Cisco Systems, Inc. All rights reserved.

MQC Example

 Voice traffic needs priority, low delay, and constant bandwidth.

 Interactive traffic needs bandwidth and low delay.

© 2006 Cisco Systems, Inc. All rights reserved.

MQC Configuration

hostname Office

!

class-map VoIP match access-group 100 class-map Application match access-group 101

!

policy-map QoS-Policy

Classification class VoIP priority 100 class Application bandwidth 25 class class-default fair-queue

QoS Policy

!

interface Serial0/0 service-policy output QoS-Policy

QoS Policy on Interface

!

access-list 100 permit ip any any precedence 5 access-list 100 permit ip any any dscp ef access-list 101 permit tcp any host 10.1.10.20

access-list 101 permit tcp any host 10.1.10.40

Classification

© 2006 Cisco Systems, Inc. All rights reserved.

Basic Verification Commands

 Display the class maps router# show class-map

 Display the policy maps router# show policy-map

 Display the applied policy map on the interface router# show policy-map interface type number

© 2006 Cisco Systems, Inc. All rights reserved.

Summary

 There are 4 basic ways to implement QoS policy on Cisco devices:

CLI, MQC, AutoQoS and SDM. Choosing a method will depend on the complexity of the network on the expertise of the administrator.

 The Cisco MQC offers significant advantages over the legacy CLI method for implementing QoS. By using MQC, a network administrator can significantly reduce the time and effort it takes to configure QoS in a complex network.

 There are three steps to follow when configuring QoS using Cisco

MQC configuration. Each step answers a question concerning the classes assigned to different traffic flows:

What traffic do we care about?

What will happen to the classified traffic?

Where will the policy apply?

© 2006 Cisco Systems, Inc. All rights reserved.

Self Check

1.

What is a class map?

2.

How many class maps can be configured on a Cisco router?

3.

What is a traffic policy?

4.

What are the 3 basic elements of a traffic policy?

5.

What command is used to assign a policy map to an interface?

© 2006 Cisco Systems, Inc. All rights reserved.

Q and A

© 2006 Cisco Systems, Inc. All rights reserved.

Resources

 Modular Quality of Service Command-Line Interface http://www.cisco.com/en/US/partner/products/sw/iosswrel/ps501

4/products_feature_guide_book09186a0080088141.html

 QoS Policing: Cisco Modular Quality of Service

Command Line Interface http://www.cisco.com/en/US/partner/tech/tk543/tk545/technologi es_white_paper09186a0080123415.shtml

© 2006 Cisco Systems, Inc. All rights reserved.

© 2006 Cisco Systems, Inc. All rights reserved.