Configuring Campus Switches to Support Voice

advertisement
Configuring Campus
Switches to Support
Voice
BCMSN Module 7 Lesson 1
BCMSN 7 - 1
© 2006 Cisco Systems, Inc. All rights reserved.
Cisco Confidential
1
Objectives
 Explain why an organization would want to run VoIP on the network
 Describe the main components of a VoIP network, including IP-enabled PBX, user
end-devices, gateways and gatekeepers, and the IP network
 Compare the uniform bandwidth consumption of voice traffic to the intermittent
bandwidth consumption of data traffic
 Describe a VoIP call flow through a network and where contention for bandwidth
between data traffic and voice traffic will occur
 Explain an auxiliary VLAN
 Identify a solution for latency, jitter, bandwidth, packet loss, reliability, and security
 Explain the importance of high availability in the campus network to support a VoIP
implementation
 Explain the use of AutoQoS in Cisco Catalyst switches
 Describe the commands that enable AutoQoS on Cisco Catalyst switches
BCMSN 7 - 1
© 2006 Cisco Systems, Inc. All rights reserved.
Cisco Confidential
2
Purpose of this Lesson
 Coverage of topics new to the “Configuring Campus
Switches to Support Voice and Video Applications”
module of BCMSN.
 What’s new in this module?
More information about Converged Networks.
Updated content for VoIP components and functionality.
Description of traffic types and call flow for VoIP.
New auto qos commands for voice.
Overall content is updated and reorganized.
 This lesson does not cover QoS. The QoS module of
BCMSN is largely unchanged.
BCMSN 7 - 1
© 2006 Cisco Systems, Inc. All rights reserved.
Cisco Confidential
3
The Basics
 VoIP is a technology that digitizes sound, divides that
sound into packets, and transmits those packets over
an IP network.
 VoIP evolved into IP telephony, delivering packetization
to the desktop through IP phones. IP telephony uses
telephone-like handsets, and users dial regular
telephone numbers.
 IP Communications, also called unified communications
or converged communications, is the next stage in the
evolution. Tying together telephone, voice mail, e-mail,
and information services, via familiar-looking telephone
equipment.
BCMSN 7 - 1
© 2006 Cisco Systems, Inc. All rights reserved.
Cisco Confidential
4
Benefits of a Converged Network
 More efficient use of bandwidth and equipment
 Lower transmission costs
 Consolidated network expenses
 Increased revenue from new services
 Service innovation
 Access to new communications devices
 Flexible new pricing structures
BCMSN 7 - 1
© 2006 Cisco Systems, Inc. All rights reserved.
Cisco Confidential
5
VoIP Network Components
BCMSN 7 - 1
© 2006 Cisco Systems, Inc. All rights reserved.
Cisco Confidential
6
VoIP Call Flow
BCMSN 7 - 1
© 2006 Cisco Systems, Inc. All rights reserved.
Cisco Confidential
7
Codecs
 A codec (Coder/Decoder) converts analog signals to a
digital bitstream, and another identical codec at the far
end of the communication converts the digital bitstream
back into an analog signal.
 Codecs generally provide a compression capability to
save network bandwidth.
BCMSN 7 - 1
© 2006 Cisco Systems, Inc. All rights reserved.
Cisco Confidential
8
Auxiliary VLANs
BCMSN 7 - 1
© 2006 Cisco Systems, Inc. All rights reserved.
Cisco Confidential
9
Self Check
1. What is a codec used for in VoIP?
2. Which VoIP component provides translation between
VoIP and non-VoIP networks?
3. What is call control signaling?
4. What protocol is used to carry actual voice samples?
5. What is the auxiliary VLAN feature supported by
some Catalyst switches?
BCMSN 7 - 1
© 2006 Cisco Systems, Inc. All rights reserved.
Cisco Confidential
10
QoS
BCMSN 7 - 1
© 2006 Cisco Systems, Inc. All rights reserved.
Cisco Confidential
11
Converged Networks Require QoS
 Traditional telephony networks reserve resources and
guarantee voice quality.
 Traditional data networks are best effort, with no
guarantee of delivery, delay or timing. Depend on TCP
upper-layer protocols for reliability.
 Converged networks must use QoS to ensure that
voice and data can be supported on the same network.
BCMSN 7 - 1
© 2006 Cisco Systems, Inc. All rights reserved.
Cisco Confidential
12
Characteristics of Voice and Data
BCMSN 7 - 1
© 2006 Cisco Systems, Inc. All rights reserved.
Cisco Confidential
13
Voice QoS Requirements
Provisioning for Voice
 Latency ≤ 150 ms
Voice
One-Way
Requirements
 Jitter ≤ 30 ms
 Loss ≤ 1%
 17–106 kbps guaranteed priority
bandwidth per call
 150 bps (+ layer 2 overhead)
guaranteed bandwidth for
voice-control traffic per call
 CAC (call admission control) must
be enabled
BCMSN 7 - 1
© 2006 Cisco Systems, Inc. All rights reserved.
Cisco Confidential
•
•
•
•
•
Smooth
Benign
Drop sensitive
Delay sensitive
UDP priority
14
QoS Basics
BCMSN 7 - 1
© 2006 Cisco Systems, Inc. All rights reserved.
Cisco Confidential
15
AutoQoS
One command per interface to enable and configure QoS.
BCMSN 7 - 1
© 2006 Cisco Systems, Inc. All rights reserved.
Cisco Confidential
16
AutoQoS Benefits
 Application Classification
 Policy Generation
 Configuration
 Monitoring and Reporting
 Consistency
BCMSN 7 - 1
© 2006 Cisco Systems, Inc. All rights reserved.
Cisco Confidential
17
Configuring AutoQoS
 Single command at the interface level configures
interface and global QoS.
 Supported on static, dynamic-access, voice VLAN
access, and trunk ports.
 CDP must be enabled for AutoQoS to function properly.
BCMSN 7 - 1
© 2006 Cisco Systems, Inc. All rights reserved.
Cisco Confidential
18
AutoQoS VoIP for Catalyst Switches
CAT2970(config-if)#auto qos voip cisco-phone
BCMSN 7 - 1
!
mls qos map cos-dscp 0 8 16 26 32 46 48 56
mls qos srr-queue output cos-map queue 1 threshold 3 5
mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 2 4
mls qos srr-queue output cos-map queue 4 threshold 2 1
mls qos srr-queue output cos-map queue 4 threshold 3 0
mls qos srr-queue output dscp-map queue 1 threshold 3 40 41 42 43 44 45 46
mls qos srr-queue output dscp-map queue 2 threshold 3 24 25 26 27 28 29 30
mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54
mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62
mls qos srr-queue output dscp-map queue 3 threshold 3 16 17 18 19 20 21 22
mls qos srr-queue output dscp-map queue 3 threshold 3 32 33 34 35 36 37 38
mls qos srr-queue output dscp-map queue 4 threshold 1 8
mls qos srr-queue output dscp-map queue 4 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3 0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
!
interface GigabitEthernet0/1
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
!
19
© 2006 Cisco Systems, Inc. All rights reserved.
Cisco Confidential
47
31
55
63
23
39
AutoQoS VoIP: WAN
interface Serial2/0
bandwidth 768
ip address 10.1.102.2 255.255.255.0
encapsulation ppp
auto qos voip trust
!
class-map
match ip
class-map
match ip
match ip
match-any AutoQoS-VoIP-RTP-Trust
dscp ef
match-any AutoQoS-VoIP-Control-Trust
dscp cs3
dscp af31
!
!
policy-map AutoQoS-Policy-Trust
class AutoQoS-VoIP-RTP-Trust
priority percent 70
class AutoQoS-VoIP-Control-Trust
bandwidth percent 5
class class-default
fair-queue
!
BCMSN 7 - 1
© 2006 Cisco Systems, Inc. All rights reserved.
Cisco Confidential
!
interface Multilink2001100117
bandwidth 768
ip address 10.1.102.2 255.255.255.0
service-policy output AutoQoS-Policy-Trust
ip tcp header-compression iphc-format
no cdp enable
ppp multilink
ppp multilink fragment delay 10
ppp multilink interleave
ppp multilink group 2001100117
ip rtp header-compression iphc-format
!
…
!
interface Serial2/0
bandwidth 768
no ip address
encapsulation ppp
auto qos voip trust
no fair-queue
ppp multilink
ppp multilink group 2001100117
!
20
Configuring AutoQoS: Native OS
Switch(config-if)#
auto qos voip trust
 The uplink interface is connected to a trusted switch or
router, and the VoIP classification in the ingress packet is
trusted.
Switch(config-if)#
auto qos voip cisco-phone
 Automatically enables the trusted boundary feature,
which uses the CDP to detect the presence or absence of
a Cisco IP Phone.
 If the interface is connected to a Cisco IP Phone, the QoS
labels of incoming packets are trusted only when the
Cisco IP Phone is detected.
BCMSN 7 - 1
© 2006 Cisco Systems, Inc. All rights reserved.
Cisco Confidential
21
Monitoring AutoQoS
Switch#
show auto qos [interface interface-id]
 Displays the AutoQoS configuration that was initially
applied
 Does not display any user changes to the configuration
that might be in effect
Switch#show auto qos
Initial configuration applied by AutoQoS:
wrr-queue bandwidth 20 1 80 0
no wrr-queue cos-map
wrr-queue cos 1 0 1 2 4
wrr-queue cos 3 3 6 7
wrr-queue cos 4 5
mls qos map cos-dscp 0 8 16 26 32 46 48 56
!
interface FastEthernet0/3
mls qos trust device cisco-phone
mls qos trust cos
BCMSN 7 - 1
© 2006 Cisco Systems, Inc. All rights reserved.
Cisco Confidential
22
Self Check
1. Describe the characteristics of a traditional data
network.
2. Describe the QoS requirements of voice traffic.
3. What 3 QoS quality factors directory affect voice
quality?
4. What is the Cisco Auto QoS feature?
5. What Cisco protocol must be enabled for AutoQoS to
function properly?
BCMSN 7 - 1
© 2006 Cisco Systems, Inc. All rights reserved.
Cisco Confidential
23
Summary
 Converged networks reduce costs and increase
productivity.
 VoIP equipment consists of a VoIP phone and a
network infrastructure capable of supporting VoIP.
 Auxiliary VLANs provide the ability to apply QoS to
voice traffic without affecting the flow of data from the
client PC.
 To ensure high quality VoIP, implementation of QoS is
required.
 AutoQoS is a simple way to implement a trust boundary
for VoIP.
BCMSN 7 - 1
© 2006 Cisco Systems, Inc. All rights reserved.
Cisco Confidential
24
Q and A
BCMSN 7 - 1
© 2006 Cisco Systems, Inc. All rights reserved.
Cisco Confidential
25
Resources
 FCC VoIP Frequently Asked Questions
http://www.fcc.gov/voip/
 VoIP Provider Information
http://voipreview.org/faq.aspx
 Cisco Press Book:
“Internet Phone Services Simplified”, by Jim Doherty, Neil
Anderson, 2006.
BCMSN 7 - 1
© 2006 Cisco Systems, Inc. All rights reserved.
Cisco Confidential
26
BCMSN 7 - 1
© 2006 Cisco Systems, Inc. All rights reserved.
Cisco Confidential
27
Download
Related flashcards
Create Flashcards