Uploaded by jonny.williams

Campus Fabric Deploy Lab Guide 22.1.3

advertisement
Campus Fabric Deploy
Lab Guide
22.1.3
Campus Fabric Deploy Lab Guide
Contents
Lab 1: Switch Initialization .........................................................................................3
Section
A: Familiarization
with Switch CLI ................................................................4
Class Name
Student
Guide
Section B: Initialize VSP8K for Automatic On-Boarding .............................................7
Section C: Initialize VSP8K for Manual Configuration ................................................9
Section D: Configuring the 5520 ........................................................................... 11
Section E: ERS CLI Overview and Initial Setup ....................................................... 14
Section F: EXOS Initial Configuration ..................................................................... 18
Section G: Out-Of-Band Network .......................................................................... 19
Section H: Lab 1 Configuration Summary .............................................................. 20
Lab 2: Fabric Infrastructure ..................................................................................... 23
Section A: Execute SPBM Script on VOSS............................................................... 24
Section B: VOSS Fabric Configuration .................................................................... 26
Section C: Verify SPBM Configuration on VOSS ...................................................... 28
Section D: BOSS Fabric Configuration.................................................................... 29
Section E: Verify SPBM Configuration on the ERS ................................................... 31
Section F: Lab 2 Configuration Summary ............................................................... 32
Lab 3: Fabric Management ...................................................................................... 35
Section A: Connectivity Fault Manager................................................................... 36
Section B: Configure I-SID for Management .......................................................... 39
Section C: Configure IP-Shortcuts for Management ................................................ 41
Section D: Lab 3 Configuration Summary .............................................................. 45
Lab 4: Configure Layer 2 VSNs................................................................................. 47
Section A: L2VSN ERS Configuration ..................................................................... 48
Section B: L2VSN VSP Configuration...................................................................... 49
Section C: Verify L2 VSNs ..................................................................................... 50
Section D: Lab 4 Configuration Summary .............................................................. 51
Lab 5: Configure Layer 3 VSN .................................................................................. 52
Section A: Configure Layer 3 VSN on VSP2 ............................................................ 53
Section B: Configure Layer 3 VSN on VSP1 ............................................................ 54
Section C: Configure Layer 2 VSN on ERS1 ............................................................ 56
© 2022 Extreme Networks, Inc. All rights reserved
1
Campus Fabric Deploy Lab Guide
Section D: Verify L3VSN ....................................................................................... 56
Section E: Lab 5 Configuration Summary ............................................................... 58
Lab 6: vIST Core Switch pair (SMLT) ........................................................................ 60
Class Name Student Guide
Section A: Configure the vIST ............................................................................... 61
Section B: SMLT Configuration .............................................................................. 62
Section C: EXOS edge configuration with Fabric Attach .......................................... 64
Section D: EXOS VLAN Creation Using Fabric Attach............................................... 66
Section E: Configure SLPP and SLPP-Guard ........................................................... 67
Section F: Configure RSMLT ................................................................................. 68
Section G: Lab 6 Configuration Summary .............................................................. 71
© 2022 Extreme Networks, Inc. All rights reserved
2
Campus Fabric Deploy Lab Guide
Lab 1: Switch Initialization
Lab Overview:
Class Name Student Guide
This lab provides an introduction to the lab environment and switch management in
preparation for the campus fabric configuration. For the device names, x is your
designated lab and student number, for example 51-EXOS.
Resources/Tools:
Minimum revisions
•
•
•
•
VSP8K
5520
ERS
EXOS
VOSS8400.8.4.3.0.GA
5520.8.4.3.0.voss
BOSS 790003s.img
summitX-31.2.1.1.xos
Objectives:
When you finish this lab, you will be able to:
•
•
•
•
•
Verify that the correct software version is running on your switch
Examine a known good configuration
Reset switch to factory defaults
Explore the VOSS, BOSS and EXOS Command Line Interface (CLI)
Perform initial configuration of the switch
Note: The lab guide uses yellow highlighted text to identify configuration values that
need to be modified based on the switch you’re configuring. The x represents your
student number from 1 through 12. The double xx represents cases where two digits
are required, 01, 02, etc. through 12. Please refer to the Appendix that accompanies
this guide for the specific values.
© 2022 Extreme Networks, Inc. All rights reserved
3
Campus Fabric Deploy Lab Guide
Section A: Familiarization with Switch CLI
Review the information in this section on the Command Line Interface (CLI) structure
incorporated on the VSP/ERS/EXOS products. Because they all use different software:
Class Name
Student Guide
VOSS, BOSS, EXOS, each has their own CLI.
•
•
•
VOSS - Virtual service platform Operating System Software. VOSS runs on
the numerous hardware platforms including Virtual Service Platform (VSP)
and universal hardware.
BOSS - acronym from legacy term BayStack Operating system Switching
Software. BOSS runs on stackable switches, such as the ERS 4800/4900, the
ERS 5900 and the ERS 3500/3600. VSP 7000 (End-Of-Sale)
ExtremeXOS – Extreme Networks Operating Software a full featured
switching and routing system built upon a Linux Kernel and runs on numerous
hardware platforms. It’s positioned on the edge of fabric deployments using
Fabric Attach.
VOSS and BOSS CLI Structure
The VOSS and BOSS software offer similar CLI structure and modes. They incorporate
CLI commands that are context sensitive. Some commands are only available in select
modes. Other commands may be available in multiple modes, but have different options
depending on which mode you are in. The following list describes the command
modes:
•
•
•
•
User EXEC mode―the initial mode of access. Only a limited number of
commands are available in the User EXEC mode. Most EXEC commands are
one-time commands, such as show commands, which show the current
configuration status. The EXEC commands are not saved across restarts.
Privileged EXEC mode―access this mode from the User EXEC mode. The
user name and password combination determines your access level in the
Privileged EXEC mode and higher modes. Enter enable to access this mode
from the User EXEC mode. As with the User EXEC mode commands, most
Privileged EXEC commands are one-time commands, such as show
commands, which show the current configuration status. The Privileged
EXEC mode commands are also not saved across restarts.
Global Configuration mode―access this mode from the Privileged EXEC
mode. Enter config {terminal|network} to access the Global Configuration
mode. Use this mode to make changes to the running configuration. If you
save the configuration, these settings survive a restart of the system.
Interface Configuration mode―access this mode from the Global
Configuration mode. Enter interface {GigabitEthernet <slot/port[slot/port][,..]> | loopback <1-256> | mgmtEthernet mgmt | mlt <1-512> |
vlan <2-4059>} to access the Interface Configuration mode. Use this mode to
modify either a logical interface, such as a VLAN, or a physical interface, such
as a port or slot.
© 2022 Extreme Networks, Inc. All rights reserved
4
Campus Fabric Deploy Lab Guide
•
Router Configuration mode―access this mode from the Global
Configuration mode. Enter router {bgp| isis| ospf| rip| vrf WORD<0-16> |
vrrp} to access the Router Configuration mode. Use this mode to modify a
protocol.
Class Name Student Guide
EXOS CLI Structure
The ExtremeXOS command line interface requires that you login in with the admin
privilege level to make configuration changes. Compared to the VOSS/BOSS CLI, the
EXOS CLI is simpler with commands entered at the first level prompt without having to
change command modes.
The components to be configured are typically named using the create command and
then modified using the config command. Typing ? provides help and pressing tab
within a command string will show you the command options.
show port config
show vlan
enable port <number>
create vlan <name>
config vlan
show iproute
save config
show management
enable ssh
unconf switch all
config snmp sysname <name>
© 2022 Extreme Networks, Inc. All rights reserved
5
Campus Fabric Deploy Lab Guide
CLI Comparison
Here are some examples of useful CLI commands for each switch OS.
Class Name Student
VOSSGuide
BOSS
EXOS
Switch System Level
show sys-info
show license
show software
show sys-info
show license
show switch
show version
show license
Switch Configuration
show running | include <text>
save config
more config
boot config flag factorydefault
show running | match
<text>
save config
boot partial-default
show config | include <text>
show config <module>
save config
unconfigure switch <all>
Layer 1 Configuration
show inter gig
show inter gig state
show lldp neighbor
show interface <verbose>
show lldp neighbor
show port config no-refresh
show port 1 info detail
show lldp neighbor
Link Aggregation (LAG) (MLT)
mlt <id>
show mlt
mlt <id>
show mlt
enable sharing <m> group <p>
show sharing
Layer 2 Configuration
show vlan basic
show vlan members
vlan create <vid> type portmstprstp 0
vlan mem add <vid> pp
show vlan mac-address-entry
show spanning-tree mode
show vlan
vlan create <vid> type port
vlan mem add <vid> pp
show mac-address-table
show spanning-tree mode
show vlan
create vlan <name> tag <vid>
config <name> add port 1,2 tag
show stp
show fdb
Layer 3 Configuration
show
show
show
show
ip
ip
ip
ip
route
interface
vrf
arp
show ip
show ip route
show arp
show iproute
show ipconfig
show iparp
Maintenance
show application iqagent
show log file tail
show log sort-reverse
show tech
show log
show iqagent
© 2022 Extreme Networks, Inc. All rights reserved
6
Campus Fabric Deploy Lab Guide
Section B: Initialize VSP8K for Automatic On-Boarding
In this section you will initialize VSP8K by deleting the configuration file and rebooting
the switch. You’ll then observe the configuration for on-boarding.
Class Name Student Guide
1. Connect to PC-A desktop. Refer to the Appendix for instructions on how to
establish this session.
2. From PC-A, connect to your VSP8K console. (Refer to the Appendix)
3. Login and enter Global Configuration Mode:
Username: rwa
Password: rwa
X-VSP1:1>enable
4. Check the software version of the switch. The switch should have a primary
release of 8.3.0.0.GA or later (preferably VOSS8400.8.4.3.0.GA). If necessary,
contact the instructor to upgrade the switch.
X-VSP1:1#show software
5. List the configuration files on internal flash. The default primary config-file is
/intflash/config.cfg. You may change the switch configuration file if desired by
using the “boot conf choice” command. For this lab, the default config.cfg will be
used.
X-VSP1:1#ls *.cfg
X-VSP1:1#sho boot config choice
6. Set the switch for Automatic On-Boarding. To accomplish this, delete the
configuration file. When the switch boots, it will not find the specified primary or
backup configuration file in internal flash resulting in the On-Boarding
configuration being used as the running configuration.
X-VSP1:1#delete config.cfg
X-VSP1:1#reset –y
7. Wait about 5 minutes for the switch to reset and then login.
Username: rwa
Password: rwa
VSP8024:1>enable
© 2022 Extreme Networks, Inc. All rights reserved
7
Campus Fabric Deploy Lab Guide
8. Observe the switch automation features including ports and protocols enabled by
default. Answer the questions as you observe the output.
Class Name Student
Guide
VSP8024:1#show
vlan private-vlan
VSP8024:1#show vlan members
What VLANs have been automatically created?
Answer: VLAN 4048 mapped to I-SID 15999999 and secondary VLAN.
Are there any active port members?
Answer: 4048 has active members on links with “port-state up”. No SPBM (4051,4052)
active members because a Nickname server is not configured.
VSP8024:1#show mgmt interface
VSP8024:1#show mgmt ip
Are there any management interfaces configured?
Answer: The two management interfaces (Mgmt-oob1, Mgmt-vlan) are automatically
created while OOB is assigned an IP address via DHCP. For our lab, no DHCP server
resides on VLAN 4048.
VSP8024:1#show spbm
VSP8024:1#show isis
What is the state of SPBM and IS-IS?
Answer: The results: spbm : enable and ISIS AdminState : enabled
VSP8024:1#show inter gig state
VSP8024:1#show inter gig auto-sense
VSP8024:1#show fa interface
VSP8024:1#show fa elements
VSP8024:1#show lldp neighbor
© 2022 Extreme Networks, Inc. All rights reserved
8
Campus Fabric Deploy Lab Guide
What is the state of the ports and their protocols?
Answer: Notice that Port Auto-sense is enabled on all ports and have determined the
Auto-Sense state on ports with active links. You may possibly see a few connected
ports:
Class Name Student Guide
•
ERS and VOSS connected to ports 1/1 and 1/3
•
the EXOS switch as an FA proxy connected to port 5
Note: For this lab, we will not be automatically on-boarding using the automation for
VLANs, mgmt or fabric.
9. As a final step, look at the contents of the running configuration and locate the
parameter settings that enable automation.
VSP8024:1#show running-config
Note: Use the “spacebar” to advance by page and press “Enter” to advance by line.
Press “q” to quit.
Section C: Initialize VSP8K for Manual Configuration
The VSP8K (VOSS Switch VSP1) will now be set to factory defaults for manual
configuration.
1. Reset the device to use the factory defaults by setting the boot flag. Saving the
configuration will create the file config.cfg since one does not exist.
VSP8024:1#config t
VSP8024:1(config)#boot config flag factorydefaults
VSP8024:1(config)#save config
VSP8024:1(config)#reset –y
Note: Setting the factorydefaults flag causes the switch to load only the factory
default configuration therefore bypassing the load of the configuration file (i.e.
config.cfg). The contents of the configuration file “config.cfg” isn’t changed until you
overwrite it using a save config command after the switch resets. The
factorydefaults flag clears itself after use so the next switch reset will load the
config.cfg.
2. Wait about 5 minutes and login after the switch reboots. Save the factory default
configuration.
VSP-8404:1>enable
VSP-8404:1#save config
© 2022 Extreme Networks, Inc. All rights reserved
9
Campus Fabric Deploy Lab Guide
3. Check the factory default configuration. This is not for automatic on-boarding, but
as a traditional switch with all ports in VLAN 1.
VSP-8404:1#show vlan member
Class Name Student Guide
4. Configure the prompt to match your system name as specified in the Appendix.
VSP-8404:1#config t
VSP-8404:1(config)#snmp-server name X-VSP1 (Where X is your
lab/student number)
5. Enable the basic management utilities on the VSP8K. These protocols are being
enable for our lab environment while a production network will only include those
that are necessary.
X-VSP1:1(config)#boot config flags ftpd
X-VSP1:1(config)#boot config flags telnetd
X-VSP1:1(config)#boot config flags tftpd
X-VSP1:1(config)#boot config flags sshd
X-VSP1:1(config)#web-server enable
X-VSP1:1(config)#no web-server secure-only
X-VSP1:1(config)#show boot config flags
6. Remove all the ports from VLAN 1. This is a common best practice.
X-VSP1:1(config)#sho vlan members
X-VSP1:1(config)#vlan members remove 1 1/1-1/24
X-VSP1:1(config)#sho vlan members
7. Create a management VLAN and assign the IP address.
X-VSP1:1(config)#vlan create x01 name InBandMgmt type portmstprstp 0
X-VSP1:1(config)#inter vlan x01
X-VSP1:1(config-if)#ip address 10.x.1.1/24
X-VSP1:1(config-if)#exit
X-VSP1:1(config)#mgmt vlan x01
X-VSP1:1(config-if)#ip address 10.x.1.1/24
X-VSP1:1(config-if)#enable
X-VSP1:1(config-if)#exit
© 2022 Extreme Networks, Inc. All rights reserved
10
Campus Fabric Deploy Lab Guide
8. Create an out-of-band management (oob mgmt) interface and enable DHCP client
on the port. The switch will obtain an IP address that should match the value
specified in the Appendix.
X-VSP1:1(config)#
mgmt oob
Class Name Student
Guide
X-VSP1:1(mgmt:oob)#enable
X-VSP1:1(mgmt:oob)#exit
X-VSP1:1(config)#mgmt dhcp-client oob
X-VSP1:1(config)#sho mgmt ip
9. Save the config and examine its contents, then exit.
X-VSP1:1(config)#save config
X-VSP1:1(config)#more config.cfg
X-VSP1:1(config)#exit
Section D: Configuring the 5520
You will now reset the 5520 (VSP2) to the factory defaults configuration and perform
the basic setup to make the switch manageable within the lab.
1. From PC-A, connect to the 5520 using the Console port. See the Appendix.
2. Login to the switch:
Username: rwa
Password: rwa
3. Enter Global Configuration Mode:
5520-24T-VOSS:1>enable
5520-24T-VOSS:1#configure terminal
4. Show the primary configuration file name and then display it.
5520-24T-VOSS:1(config)#sho boot config choice
5520-24T-VOSS:1(config)#more /intflash/config.cfg
Note: Use the “spacebar” to advance by page and press “Enter” to advance by line.
Press “q” to quit.
© 2022 Extreme Networks, Inc. All rights reserved
11
Campus Fabric Deploy Lab Guide
5. Reset the device to use the factory defaults by setting the boot flag.
X5520-24T-VOSS:1(config)#boot config flag factorydefaults
5520-24T-VOSS:1(config)#save config
Class Name Student Guide
5520-24T-VOSS:1(config)#reset –y
6. Wait about 4 minutes and login after the switch reboots. Save the factory default
configuration.
5520-24T-VOSS:1>enable
5520-24T-VOSS:1#config t
5520-24T-VOSS:1(config)#save config
7. Configure the prompt to match your system name as specified in the Appendix.
5520-24T-VOSS:1(config)#snmp-server name X-VSP2 (Where X is
your lab and student number)
8. Enable the basic utilities on the 5520.
X-VSP2:1(config)#boot config flags ftpd
X-VSP2:1(config)#boot config flags telnetd
X-VSP2:1(config)#boot config flags tftpd
X-VSP1:1(config)#boot config flags sshd
X-VSP2:1(config)#web-server enable
X-VSP2:1(config)#no web-server secure-only
X-VSP2:1(config)#show boot config flags
9. Remove all the ports from VLAN 1.
X-VSP2:1(config)#sho vlan members
X-VSP2:1(config)#vlan members remove 1 1/1-1/24
X-VSP2:1(config)#sho vlan members
© 2022 Extreme Networks, Inc. All rights reserved
12
Campus Fabric Deploy Lab Guide
10. Create a management VLAN and add the port member, assign the IP address and
enable the port.
X-VSP2:1(config)#vlan create x01 name InBandMgmt type port-
Class Name Student
Guide
mstprstp
0
X-VSP2:1(config)#vlan mem add x01 1/7
X-VSP2:1(config)#inter vlan x01
X-VSP2:1(config-if)#ip address 10.x.1.2/24
X-VSP2:1(config)#mgmt vlan x01
X-VSP2:1(config-if)#ip address 10.x.1.2/24
X-VSP2:1(config-if)#enable
X-VSP2:1(config-if)#interface gig 1/7
X-VSP2:1(config-if)#no shut
X-VSP2:1(config-if)#show interface gig state
X-VSP2:1(config-if)#exit
11. Create an out-of-band management (oob mgmt) interface and enable DHCP client
on the port. The switch will obtain an IP address that should match the value
specified in the Appendix.
X-VSP2:1(config)# mgmt oob
X-VSP2:1(mgmt:oob)#enable
X-VSP2:1(mgmt:oob)#exit
X-VSP2:1(config)#mgmt dhcp-client oob
X-VSP2:1(config)#sho mgmt ip
12. Save the config and examine the contents, then exit.
X-VSP2:1(config)#save config
X-VSP2:1(config)#more config.cfg
X-VSP2:1(config)#exit
© 2022 Extreme Networks, Inc. All rights reserved
13
Campus Fabric Deploy Lab Guide
Section E: ERS CLI Overview and Initial Setup
During this section, you’ll set the ERS (ERS1) to its factory defaults and perform the
initial setup and ensure that the IP Address is set, spbm is enabled and the VLANs are
Class Name
Student Guide
configured with proper port membership.
1. From the PC-A desktop, use Putty to access to the console of the ERS (BOSS)
switch. Refer to the Appendix. Once you are connected, enter “Ctrl-Y”.
Note: Ctrl-Y is used to wake-up and gain access to the console port of a BOSS switch.
2. The Boss switch does not require that you enter a username or password. Enter
Privileged Exec Mode and then Global configuration mode.
5928GTS-PWR+> enable
3. Display the VLAN information and record the VLANs that are currently listed. You
will use this information later for comparing before and after the switch “reset to
partial-defaults”.
5928GTS-PWR+(config)#show vlan
4. Display the IS-IS status. (There is not a problem if IS-IS is not enabled. You will
be resetting the switch to partial-defaults soon and then comparing the settings
before and after the restart.)
5928GTS-PWR+(config)#show isis
5. Verify the SPBM status. It should be enabled. If not, it will need to be enabled and
the switch will have to be rebooted.
5928GTS-PWR+(config)#show spbm
SPBM Global: Disabled
SPBM Ethertype: 0x8100
Also show the reserved port information using the following command.
5928GTS-PWR+#show spbm reserved-port
SPBM Current Reserved Port: None
SPBM Next Boot Reserved Port: None
Note: A loopback port must be configured to enable IP Multicast over Fabric Connect.
That’s what the next command does.
a. Only execute the following command if necessary to set the reserved port to
stack. Enter the following command and reboot using partial-defaults if
asked.
5928GTS-PWR+(config)#spbm reserved-port stack
© 2022 Extreme Networks, Inc. All rights reserved
14
Campus Fabric Deploy Lab Guide
This operation will disable stacking and requires a reboot
to configure loopback ports.
Are you sure?
Class Name Student Guide
(y/n) ? Y
6. Reboot the switch using partial-defaults by executing the following command.
5928GTS-PWR+(config)#boot partial-default
Reboot the unit(s) (y/n) ? Y
7. After the switch boots, Enter Ctrl-Y.
Note: When using the boot partial-default command, the IP address and
license file remain unchanged by the operation. Also, SPBM mode is enabled.
8. Set the switches IP address
5928GTS-PWR+#enable
5928GTS-PWR+#config t
5928GTS-PWR+(config)#show ip
5928GTS-PWR+(config)#ip address 10.x.1.3 255.255.255.0
5928GTS-PWR+(config)#show ip
Note: An ERS in-band Default Gateway may be set using ip default-gateway
10.x.1.1 only when the OOB management port is not obtaining an IP address and
gateway utilizing DHCP. In our case the Default Gateway is being assigned by DHCP
along with the OOB mgmt IP address.
9. Because we are manually configuring the switch, ensure all the ports have been
disabled.
5928GTS-PWR+(config)#sho interfaces all
5928GTS-PWR+(config)#inter ether all
5928GTS-PWR+(config-if)#shut
5928GTS-PWR+(config-if)#exit
10. After setting the switch to partial defaults, ensure that Spanning Tree mode is
set for Multiple Spanning Tree Protocol (MSTP). Set the spanning-tree mode using
the spanning-tree mode mst command if necessary.
5928GTS-PWR+(config)#sho spanning-tree mode
11. Configure the prompt to match your system name as shown in the Appendix.
5928GTS-PWR+(config)#snmp-server name X-ERS1 (Where X is
your Student Number)
© 2022 Extreme Networks, Inc. All rights reserved
15
Campus Fabric Deploy Lab Guide
12. Change the VLAN Configcontrol mode to automatic.
X-ERS1(config)#show vlan configcontrol
X-ERS1(config)#vlan configcontrol automatic
Class Name Student Guide
Note: VLAN Configuration Control (VCC) determines how switch manipulates port VLAN
assignments and PVID value assignments when ports are placed into VLANs. You may
change VCC values at any time during configuration to make it act as you want at the
time. The default VCC setting is “strict”. Here are the four options:
Strict -- This option prevents the addition of an untagged port to a VLAN if it is already
a member of another VLAN. To add an untagged port to a new VLAN, the switch
administrator must remove the port from all other VLANs of which it is a member
before adding it to the new VLAN. The PVID of the port is changed to the new VID to
which it was added.
Automatic -- This option adds an untagged port to a new VLAN and automatically
removes it from any previous VLAN membership. The PVID of the port is automatically
changed to the VID of the VLAN it joins. Because the port is first added to the new
VLAN and then removed from any previous membership, the Spanning Tree Group
participation of the port will not be disabled as long as the VLANs involved are in the
same Spanning Tree Group.
AutoPVID -- When an untagged port is added to a new VLAN, the port is added to the
new VLAN and the PVID assigned to the new VID without removing the port from any
previous VLAN memberships. When using this option, an untagged port can have
membership in multiple VLANs.
Flexible -- This option functions in a similar manner to disabling AutoPVID
functionality. When this option is used, an untagged port can belong to an unlimited
number of VLANs. But new additions of an untagged port to a new VLAN does not
change the PVID of that port.
© 2022 Extreme Networks, Inc. All rights reserved
16
Campus Fabric Deploy Lab Guide
13. Change the switch port VLAN membership. These commands take all ports out of
VLAN 1 and places them in a new VLAN 2.
Note: Best practices dictates moving all NNI ports out of VLAN 1. This is in agreement
with many
security
experts who also recommend removing all ports from VLAN 1.
Class Name
Student
Guide
X-ERS1(config)#show vlan
X-ERS1(config)#vlan members remove 1 all
a. Create VLAN 2 and add all ports.
X-ERS1(config)#vlan create 2 type port cist
X-ERS1(config)#vlan mem add 2 all
14. Create the Management VLAN x01 and add port 7 to it.
X-ERS1(config)#vlan create x01 type port cist
X-ERS1(config)#vlan member add x01 7
X-ERS1(config)#vlan mgmt x01
Note: The Management VLAN will provide “in-band” access for switch. Initially only the
local device (PC-A or PC-B) will have access via port 7. Later on, as the fabric is
configured, In-Band Management will extend throughout the fabric.
15. Enable Port 7
X-ERS1(config)#interface ethernet 7
X-ERS1(config-if)#no shut
X-ERS1(config-if)#exit
16. Check the VLAN and port results.
X-ERS1(config)#show vlan
X-ERS1(config)#show interface
17. Save the config and exit.
X-ERS1(config)#save config
X-ERS1(config)#exit
X-ERS1#exit
© 2022 Extreme Networks, Inc. All rights reserved
17
Campus Fabric Deploy Lab Guide
Section F: EXOS Initial Configuration
You will now reset the EXOS switch (EXOS1) to the factory defaults and configure an
In-Band Management VLAN.
Class Name Student Guide
1. Press Enter on the EXOS console. When prompted, logon to the switch. Enter a
few commands to observe the switch configuration. Then set the EXOS1 switch to
the factory defaults.
Username: admin
Password: (none) just press Enter
X-EXOS1.1 # show vlan
X-EXOS1.2 # show ports config no-refresh
X-EXOS1.3 # unconfig switch
2. After reboot, press Enter on the EXOS console. When prompted, logon to the
switch. The startup script will be initiated as part of the initial login following
factory default. It will prompt you for answers to questions about the basic
configuration. Accept the defaults for each question, except one: ensure that “All
the ports are disabled”.
All ports are enabled by default. In some secure applications, it
may be more desirable for the ports to be turned off. Would you
like unconfigured ports to be turned off by default? [y/N/q]: Yes
X450G2-24p-G4.1 # show ports config no-refresh
X450G2-24p-G4.2 # disable ports 1-24 (if necessary)
3. Set the switch prompt X-EXOS1 (X is your student number).
X450G2-24p-G4.3 # configure snmp sysName X-EXOS1
4. Look at the default VLAN configuration and management protocols settings. Save
the configuration.
X-EXOS1.4 # show vlan
X-EXOS1.5 # show management
X-EXOS1.6 # save config
© 2022 Extreme Networks, Inc. All rights reserved
18
Campus Fabric Deploy Lab Guide
Section G: Out-Of-Band Network
Class Name
Student diagram
Guide shows the Out-Of-Band (OOB) network used in this lab
The following
environment. DHCP provides the IP addresses for switches VSP8K, 5520, ERS1 and
EXOS1. Refer to the Appendix for each device’s OOB IP address.
1. There are two network adapters on PC-A. One of them is for In-Band use and the
other for OOB network. From your PC-A, open up a command prompt and verify
your OOB management IP address.
C:\Users\Studentx> ipconfig
2. Each of the switch’s OOB Mgmt IP address can be found by executing the
following commands. You may also refer to the Appendix for each device’s OOB IP
address.
X-VSP1:1#sho mgmt ip
X-VSP2:1#sho mgmt ip
X-ERS1# show IP
X-EXOS1.x# show vlan
3. From PC-A verify connectivity to each of your switches. Ping each of your switches
in the OOB network.
C:\Users\Studentx> ping x.x.x.x
© 2022 Extreme Networks, Inc. All rights reserved
19
Campus Fabric Deploy Lab Guide
Section H: Lab 1 Configuration Summary
The following commands make up the configuration accomplished in this lab.
VSP8K
Class Name
Student Guide
enable
configure terminal
boot config flag factorydefaults
save config
reset –y
*Switch Power-on Sequence
enable
configure terminal
snmp-server name X-VSP1
boot config flags ftpd
boot config flags telnetd
boot config flags tftpd
boot config flags sshd
web-server enable
no web-server secure-only
vlan members remove 1 1/1-1/24
vlan create x01 name InBandMgmt type port-mstprstp 0
inter vlan x01
ip address 10.x.1.1/24
exit
mgmt vlan x01
ip address 10.x.1.1/24
enable
exit
mgmt oob
enable
exit
mgmt dhcp-client oob
save config
© 2022 Extreme Networks, Inc. All rights reserved
20
Campus Fabric Deploy Lab Guide
5520
enable
configure terminal
boot config
Class Name Student
Guide flag factorydefaults
save config
reset –y
*Switch Power-on Sequence
enable
configure terminal
snmp-server name X-VSP2
boot config flags ftpd
boot config flags telnetd
boot config flags tftpd
boot config flags sshd
web-server enable
no web-server secure-only
vlan members remove 1 1/1-1/24
vlan create x01 name InBandMgmt type port-mstprstp 0
vlan mem add x01 1/7
inter vlan x01
ip address 10.x.1.2/24
exit
mgmt vlan x01
ip address 10.x.1.2/24
enable
exit
interface gig 1/7
no shut
exit
mgmt oob
enable
exit
mgmt dhcp-client oob
save config
© 2022 Extreme Networks, Inc. All rights reserved
21
Campus Fabric Deploy Lab Guide
ERS 5900
enable
config t
spbm reserved-port
stack
Class Name Student
Guide
y
boot partial-default
*Switch Power-on Sequence
enable
conf t
ip address 10.x.1.3 255.255.255.0
inter ether all
shut
exit
snmp-server name X-ERS1
vlan configcontrol automatic
vlan members remove 1 all
vlan create 2 type port cist
vlan mem add 2 all
vlan create x01 name InBandMgmt type port cist
vlan member add x01 7
vlan mgmt x01
save config
exit
exit
EXOS
unconf switch
*Switch Power-on Sequence
disable ports all
configure snmp sysName X-EXOS1
save config
y
End of Lab
© 2022 Extreme Networks, Inc. All rights reserved
22
Campus Fabric Deploy Lab Guide
Lab 2: Fabric Infrastructure
Lab Overview:
Class Name Student Guide
During this lab, you’ll configure the fabric infrastructure consisting of the SPBM
Instance= 1, Area=49.0000, BVLANs=4051 (primary) and 4052. The diagram shows
the three SPBM switches.
Resources/Tools:
•
Refer to the Appendix.
Objectives:
When you finish this lab, you will be able to:
•
•
•
•
Use the SPBM script to provision a switch as an SPBM node
Configure a VOSS VSP as an SPBM node
Configure a BOSS ERS as an SPBM node
Verify SPBM Configuration
Note: The lab guide uses yellow highlighted text to identify configuration values that
need to be modified based on the switch you’re configuring. The x represents your
student number from 1 through 12. The double xx represents cases where two digits
are required, 01, 02, etc. through 12. Please refer to the Appendix that accompanies
this guide for the specific values.
© 2022 Extreme Networks, Inc. All rights reserved
23
Campus Fabric Deploy Lab Guide
Section A: Execute SPBM Script on VOSS
Extreme Networks provides an spbm script as an easy way to configure the fabric
parameters. In this section, you will execute the script on X-VSP1.
Class Name Student Guide
1. From PC-A, connect to the X-VSP1 using the Console port and login to the switch.
Enter configuration mode.
Username: rwa
Password: rwa
X-VSP1:1>enable
X-VSP1:1#configure terminal
2. Locate the X-VSP1 fabric parameter values in the Appendix. When you run the
spbm script it will prompt you for a response to nearly 25 questions. Some of the
default values will be acceptable. Enter the correct values for your X-VSP1. If an
incorrect value is entered, cancel the script by pressing “ctrl c” and start the script
again. xx (01, 02, 03 …12) is used to identify your student number.
X-VSP1:1(config)#run spbm
SPB Ethertype <0x8100,0x88a8> [0x8100]:
SPBM instance <1-100> [1]:
SPB primary BVLAN <2-4059> [4051]:
SPB secondary BVLAN <2-4059> [4052]:
ISIS system id <xxxx.xxxx.xxxx> [646a.52ef.6c84]: 020b.0xx1.0000
SPB nickname <x.xx.xx> [f.6c.84]: b.xx.01
SPB Manual Area <xx.xxxx.xxxx...xxxx> [49.0000]:
ISIS System Name [X-VSP1]: X-VSP1
Enable SPBM multicast (y/n) [n]: y
Enable IP shortcuts (y/n) [n]: y
Loopback interface ID <1-256> [1]:
Loopback interface IP and subnet <a.b.c.d/x>: 10.x.0.1/32
Configure SPBM SMLT? (y/n) [n]: y
Peer system id <xxxx.xxxx.xxxx>: 020b.0xx2.0000
SMLT virtual BMAC
<0x00:0x00:0x00:0x00:0x00:0x00>[]: 02:0b:0x:x1:00:01
Virtual-IST VLAN ID <2-4059> [4053]:
Virtual-IST VLAN I-SID <0-16777215>: x4053
© 2022 Extreme Networks, Inc. All rights reserved
24
Campus Fabric Deploy Lab Guide
Virtual-IST VLAN IP and subnet <a.b.c.d/x>: 10.x.53.1/30
Virtual-IST VLAN peer IP <a.b.c.d>: 10.x.53.2
ISIS port interfaces <a/b,c/d>[]: 1/1,1/3
Class Name Student Guide
ISIS MLT interface <MLT ID LIST> []:
Enable CFM SPBM (y/n) [n]: y
Enter CFM SPBM MEPID <1-8191> [1]: x1
Enter CFM SPBM level <0-7> [4]:
****CONFIGURATION IN PROGRESS****
After you answer the final question, the script will execute the commands and display
the progress on the console.
Note: At this time ignore the following console notification since we haven’t configured
VSP2.
GlobalRouter MLT INFO System up and waiting for IST vlan to up.
The IST control channel failed to come up within 90 seconds;
unlocking SMLT ports
3. The values set by the script may be checked using the following commands.
Because this VSP is the only switch configured at this point, no adjacencies have
formed.
X-VSP1:1#show spbm
X-VSP1:1#show vlan basic
X-VSP1:1#show vlan member
X-VSP1:1#show ip interface
X-VSP1:1#show isis
X-VSP1:1#show isis manual-area
X-VSP1:1#show isis interface
X-VSP1:1#show isis adjacency
X-VSP1:1#show isis lsdb
X-VSP1:1#show virtual-ist
X-VSP1:1#show cfm
© 2022 Extreme Networks, Inc. All rights reserved
25
Campus Fabric Deploy Lab Guide
Section B: VOSS Fabric Configuration
Now you’ll proceed with configuring SPBM and IS-IS on the second VSP switch (VSP2).
Class Name
Student
Guide overview
VOSS
procedure
1. Log in to the VSP2 and enter global configuration mode to enable SPBM globally:
X-VSP2:1>enable
X-VSP2:1#conf t
X-VSP2:1(config)#spbm
2. Enter IS-IS Router Configuration Mode to create an instance of SPBM specifying
the backbone VLANs, nickname, system-id, and area. (xx is your student number.)
X-VSP2:1(config)#router isis
X-VSP2:1(config-isis)#spbm 1
X-VSP2:1(config-isis)#spbm 1 b-vid 4051,4052 primary 4051
X-VSP2:1(config-isis)#spbm 1 nick-name b.xx.02
X-VSP2:1(config-isis)#system-id 020b.0xx2.0000
X-VSP2:1(config-isis)#manual-area 49.0000
X-VSP2:1(config-isis)#sho isis
X-VSP2:1(config-isis)#exit
Note: IS-IS has not yet been enabled so it will show as disabled.
© 2022 Extreme Networks, Inc. All rights reserved
26
Campus Fabric Deploy Lab Guide
3. Create the SPBM backbone VLANs:
X-VSP2:1(config)#vlan create 4051 type spbm-bvlan
X-VSP2:1(config)#vlan create 4052 type spbm-bvlan
Class Name Student Guide
4. Enter interface configuration mode, specifying the ports linking to the SPBM
network. Disable spanning tree, configure IS-IS and then enable the interfaces.
X-VSP2:1(config)#interface Gigabitethernet 1/1,1/3
X-VSP2:1(config-if)#no spanning-tree mstp force-port-state
enable
X-VSP2:1(config-if)#auto-nni
X-VSP2:1(config-if)#no shut
X-VSP2:1(config-if)#exit
5. Use the following commands to configure a circuitless IP address and specify the
same address as the IS-IS IP source address.
X-VSP2:1(config)#interface loopback 1
X-VSP2:1(config-if)#ip address 10.x.0.2/32
X-VSP2:1(config-if)#exit
X-VSP2:1(config)#router isis
X-VSP2:1(config-isis)#ip-source-address 10.x.0.2
X-VSP2:1(config-isis)#exit
6. The last step is to enable the IS-IS router.
X-VSP2:1(config)#router isis enable
X-VSP2:1(config)#save config
X-VSP2:1(config)#exit
Note: The IS-IS router will need to be disabled using “no router isis enable” if
any changes are necessary to these IS-IS/SPBM parameters.
© 2022 Extreme Networks, Inc. All rights reserved
27
Campus Fabric Deploy Lab Guide
Section C: Verify SPBM Configuration on VOSS
When the IS-IS router is properly configured and enabled, adjacencies will form with
neighbor switches. Use the following commands to validate that the VSPs are properly
Class Name
Student Guide
configured.
1. Display IS-IS SPBM
VSP2#1:1#sho isis spbm
=============================================================================================================
ISIS SPBM Info
=============================================================================================================
SPBM
B-VID
INSTANCE
PRIMARY
NICK
LSDB
VLAN
NAME
TRAP
IP
IPV6
MULTICAST
SPB-PIM-GW
STP-MULTI
HOMING
------------------------------------------------------------------------------------------------------------1
4051-4052
4051
b.xx.02
disable
disable
disable
disable
disable
disable
=============================================================================================================
ISIS SPBM SMLT Info
=============================================================================================================
SPBM
SMLT-SPLIT-BEB
SMLT-VIRTUAL-BMAC
SMLT-PEER-SYSTEM-ID
INSTANCE
------------------------------------------------------------------------------------------------------------1
primary
00:00:00:00:00:00
-------------------------------------------------------------------------------Total Num of SPBM instances: 1
--------------------------------------------------------------------------------
2. Display IS-IS interfaces
VSP2#sho isis inter
===============================================================================================
ISIS Interfaces
===============================================================================================
IFIDX
TYPE
LEVEL
OP-STATE
ADM-STATE
ADJ
UP-ADJ
SPBM-L1-METRIC
----------------------------------------------------------------------------------------------Port1/1
pt-pt
Level 1
UP
UP
1
1
10
Port1/3
pt-pt
Level 1
DOWN
UP
0
0
10
-------------------------------------------------------------------------------2 out of 2 Total Num of ISIS interfaces
© 2022 Extreme Networks, Inc. All rights reserved
28
Campus Fabric Deploy Lab Guide
Section D: BOSS Fabric Configuration
In this section you will be configuring the fabric infrastructure on the ERS Layer 2 Edge
Device.
Class Name Student Guide
BOSS Procedures
1. The ERS has already been reset to the default configuration and SPBM is currently
enabled.
X-ERS1>enable
X-ERS1#config t
X-ERS1(config)#sho spanning-tree mode
X-ERS1(config)#sho spbm
X-ERS1(config)#spbm
Note: Unlike with the VOSS switches, the VLANs for the BVIDs need to be created
before the SPB configuration.
2. Create the SPBM backbone VLANs:
X-ERS1(config)#vlan create 4051 type spbm-bvlan
X-ERS1(config)#vlan create 4052 type spbm-bvlan
3. Perform the IS-IS SPBM configuration on the BOSS switch using the specific
parameters for your group as specified in the Appendix.
© 2022 Extreme Networks, Inc. All rights reserved
29
Campus Fabric Deploy Lab Guide
X-ERS1(config)#router isis
X-ERS1(config-isis)#spbm 1
X-ERS1(config-isis)#spbm 1 b-vid 4051,4052 primary 4051
Class Name Student Guide
X-ERS1(config-isis)#spbm 1 nick-name e.xx.01
X-ERS1(config-isis)#system-id 020e.0xx1.0000
X-ERS1(config-isis)#manual-area 49.0000
4. Check the VLAN configuration and enable tagging on the NNI ports. If needed,
remove the ports from the default VLAN (VLAN ID = 1) and VLAN 2:
X-ERS1(config)#sho vlan
X-ERS1(config)#vlan port 1,3 tagging tagall
X-ERS1(config)#vlan member remove 2 1,3
5. Configure IS-IS on the ERS NNI ports.
X-ERS1(config)#interface ethernet 1,3
X-ERS1(config-if)#spanning-tree mstp learning disable
X-ERS1(config-if)#isis
X-ERS1(config-if)#isis spbm 1
X-ERS1(config-if)#isis en
X-ERS1(config-if)#no shut
X-ERS1(config-if)#exit
X-ERS1(config)#router isis enable
X-ERS1(config)#exit
X-ERS1#save config
© 2022 Extreme Networks, Inc. All rights reserved
30
Campus Fabric Deploy Lab Guide
Section E: Verify SPBM Configuration on the ERS
Now you will verify SPB and IS-IS configurations on the ERS.
1. Student
Verify whether
Class Name
GuideSPBM is enabled:
X-ERS1>enable
X-ERS1#show spbm
2. Verify the IS-IS configuration parameters:
X-ERS1#show isis
X-ERS1#show isis system-id
X-ERS1#show isis net
X-ERS1#show isis manual-area
X-ERS1#show isis interface
X-ERS1#show isis lsdb
X-ERS1#show isis adjacencies
X-ERS1#show isis statistics
X-ERS1#show isis int-counters
3. Additional commands to run and test at your convenience throughout the training:
X-ERS1#show isis spbm unicast-fib
X-ERS1#show isis spbm unicast-fib vlan 4051 (or 4052)
X-ERS1#show isis spbm unicast-tree 4051 (or 4052)
X-ERS1#show isis spbm multicast-fib
X-ERS1#show isis spbm ip-unicast-fib
X-ERS1#show isis spbm ?
4. Check that the backbone VLANs have the right type (bvlan) assigned to them:
X-ERS1#show vlan
© 2022 Extreme Networks, Inc. All rights reserved
31
Campus Fabric Deploy Lab Guide
Section F: Lab 2 Configuration Summary
The following commands make up the configuration accomplished in this lab.
VSP1Student Guide
Class Name
enable
conf t
spbm
interface GigabitEthernet 1/1,1/3
encapsulation dot1q
exit
router isis
spbm 1
spbm 1 nick-name b.xx.01
spbm 1 b-vid 4051-4052 primary 4051
spbm 1 multicast enable
spbm 1 ip enable
spbm 1 smlt-virtual-bmac 02:0b:0x:x1:00:01
spbm 1 smlt-peer-system-id 020b.0xx2.0000
exit
vlan create 4051 type spbm-bvlan
vlan create 4052 type spbm-bvlan
vlan create 4053 type port-mstprstp 1
vlan i-sid 4053 x4053
interface vlan 4053
ip address 10.x.53.1/30
exit
virtual-ist peer-ip 10.x.53.2 vlan 4053
interface GigabitEthernet 1/1,1/3
default-vlan-id 0
no shutdown
isis
isis spbm 1
isis enable
no spanning-tree mstp msti 62 force-port-state enable
exit
interface loopback 1
ip address 1 10.x.0.1/32
exit
router isis
sys-name "X-VSP1"
ip-source-address 10.x.0.1
is-type l1
system-id 020b.0xx1.0000
manual-area 49.0000
exit
router isis enable
© 2022 Extreme Networks, Inc. All rights reserved
32
Campus Fabric Deploy Lab Guide
save conf
exit
Class Name
VSP2Student Guide
enable
conf t
spbm
router isis
spbm 1
spbm 1 b-vid 4051,4052 primary 4051
spbm 1 nick-name b.xx.02
system-id 020b.0xx2.0000
manual-area 49.0000
exit
vlan create 4051 type spbm-bvlan
vlan create 4052 type spbm-bvlan
interface Gigabitethernet 1/1,1/3
no spanning-tree mstp force-port-state enable
y
isis
isis spbm 1
isis enable
no shut
exit
interface loopback 1
ip address 10.x.0.2/32
exit
router isis
ip-source-address 10.x.0.2
exit
router isis enable
save conf
exit
© 2022 Extreme Networks, Inc. All rights reserved
33
Campus Fabric Deploy Lab Guide
ERS1
enable
config t
spbm
Class Name Student
Guide
vlan create 4051 type spbm-bvlan
vlan create 4052 type spbm-bvlan
router isis
spbm 1
spbm 1 b-vid 4051,4052 primary 4051
spbm 1 nick-name e.xx.01
system-id 020e.0xx1.0000
manual-area 49.0000
vlan port 1,2,3 tagging tagall
vlan member remove 1 1,3
vlan member remove 2 1,3
interface ethernet 1,3
spanning-tree mstp learning disable
isis
isis spbm 1
isis enable
no shut
exit
router isis enable
save conf
exit
End of Lab
© 2022 Extreme Networks, Inc. All rights reserved
34
Campus Fabric Deploy Lab Guide
Lab 3: Fabric Management
Lab Overview:
Class Name Student Guide
Configuring an SPB node for switch management involves configuring Connectivity Fault
Manager (CFM). Also beneficial for management is creating a dedicated In-Band
network for SSH and SNMP access to the switches. In this lab you’ll perform these
actions.
Resources/Tools:
•
Refer to the Appendix.
Objectives:
When you finish this lab, you will be able to:
•
•
•
•
•
•
Configure CFM on the fabric nodes
Test the Layer 2 CFM functionality: l2 ping, l2 traceroute
Provision an In-Band Management VLAN and I-SID
Configure IP Shortcuts for management
Create a Route-Map for the redistribution policy
Explore the web interface management tool Enterprise Device Manager
Note: The lab guide uses yellow highlighted text to identify configuration values that
need to be modified based on the switch you’re configuring. The x represents your
student number from 1 through 12. The double xx represents cases where two digits
are required, 01, 02, etc. through 12. Please refer to the Appendix that accompanies
this guide for the specific values.
© 2022 Extreme Networks, Inc. All rights reserved
35
Campus Fabric Deploy Lab Guide
Section A: Connectivity Fault Manager
In this section you will configure CFM on all the ERS and VSP switches with the
following values:
Class Name Student Guide
•
•
•
Maintenance domain: spbm
Maintenance associations 4051 and 4052
Use level 4 for CFM SPBM
Note: A global CFM Maintenance End Point ID must be assigned while CFM is disabled
or prior to enabling it. Please see Appendix for your MEPID.
1. Login to X-VSP1 and verify the CFM SPBM settings setup by the script. (x is your
student number)
X-VSP1:1>enable
X-VSP1:1#conf t
# X-VSP1:1(config)#cfm spbm mepid x1 (script completed)
# X-VSP1:1(config)#cfm spbm enable
(script completed)
X-VSP1:1(config)#show cfm maintenance-endpoint
==============================================================================
Maintenance Endpoint Config
===============================================================================
DOMAIN
ASSOCIATION
MEP
NAME
NAME
ID
ADMIN
------------------------------------------------------------------------------spbm
4051
81
enable
spbm
4052
81
enable
Total number of MEP entries: 2.
© 2022 Extreme Networks, Inc. All rights reserved
36
Campus Fabric Deploy Lab Guide
===============================================================================
Maintenance Endpoint Service
===============================================================================
DOMAIN_NAME
ASSN_NAME
MEP_ID TYPE
SERVICE_DESCRIPTION
spbm
4051
81
nodal
Vlan 4051, Level 4
spbm
4052
81
nodal
Vlan 4052, Level 4
Class Name Student
Guide
-------------------------------------------------------------------------------
Total number of MEP entries: 2.
2. On VSP2, perform the same operation to configure the CFM MEPID.
X-VSP2:1>enable
X-VSP2:1#conf t
X-VSP2:1(config)#cfm spbm mepid x2
X-VSP2:1(config)#cfm spbm enable
X-VSP2:1(config)#show cfm maintenance-association
X-VSP2:1(config)#show cfm maintenance-endpoint
X-VSP2:1(config)#show cfm spbm
3. Now perform the configuration on the ERS.
Note: The CFM level is by default set to level 4.
X-ERS1:1#config t
X-ERS1:1(config)#cfm spbm level 4
X-ERS1:1(config)#cfm spbm mepid x3
X-ERS1:1(config)#cfm spbm enable
X-ERS1:1(config)#show cfm spbm
4. On VSP1, perform CFM Testing. Use these commands to find routernode names
and mac addresses of your switches. Be aware that you cannot ping your own
switch.
X-VSP1:1#sho isis spbm unicast-tree 4051
X-VSP1:1#sho isis spbm unicast-fib vlan 4051
5. Use “l2 ping” to verify connectivity using the destination mac address of another
one of your switches.
X-VSP1:1#l2 ping vlan 4051 mac 02:0b:0x:x2:00:00
(The MAC Address (Destination Address) for your switch is obtained from the display
output from the above commands)
© 2022 Extreme Networks, Inc. All rights reserved
37
Campus Fabric Deploy Lab Guide
Please wait for l2ping to complete or press any key to abort
----00:ee:04:03:03:00
1 packets
transmitted,
Class Name Student
Guide
round-trip (us)
L2 PING Statistics---1 packets received,
min/max/ave/stdv =
0(64) bytes of data
0.00% packet loss
2283/2283/2283.00/ 0.00
Try the command again replacing the Mac address with the Host-Name. Refer to the
results of the previous steps for the Host-Name.
6. Use “l2 ping” to verify connectivity using the destination router node name of
another one of your switches.
X-VSP1#l2 ping vlan 4051 routernodename X-VSP2
7. Check out the traceroute command for both backbone VLANs:
X-VSP1:1#l2 traceroute vlan 4051 mac 02:0b:0x:x2:00:00 priority 4
X-VSP1:1#l2 traceroute vlan 4052 mac 02:0b:0x:x2:00:00 priority 4
© 2022 Extreme Networks, Inc. All rights reserved
38
Campus Fabric Deploy Lab Guide
Section B: Configure I-SID for Management
Now you will add an I-SID to the Management VLANs on each of the switches to extend
the Layer 2 network between switches.
Class Name Student Guide
1. Login to each of the switches (VSP1, VSP2, and ERS1) and add the management
VLAN x01 to I-SID 10xx01. (xx is your student number.)
Note: There is no difference in the configuration commands between BOSS and VOSS
devices for mapping a VLAN to a I-SID.
enable
conf t
vlan i-sid x01 10xx01
exit
2. Validate the configuration settings.
X-VSP2:1#show vlan member
X-VSP2:1#show vlan i-sid
X-VSP2:1#show ip interface
X-ERS1#show vlan
3. Each switch should be able to ping other switches within the same group across ISID 10xx01. It may require you to repeat the command in order to receive a
response.
X-VSP2:1#ping 10.x.1.1
10.x.1.1 is alive
10.x.1.2 is alive
10.x.1.3 is alive
© 2022 Extreme Networks, Inc. All rights reserved
39
Campus Fabric Deploy Lab Guide
4. The ip arp cache on each switch will now be populated with each switches
management mac address.
X-ERS1#show arp
Class Name Student
Guide mac-address-table
X-ERS1#show
X-VSP2:1#show ip arp
X-VSP2:1#show vlan mac-address-entry
5. From PC-A and/or PC-B test access to your In-Band Management for the three
switches. Use the IP Address assigned to VLAN x01 on each switch. All of the
switches are within the same IP Subnet providing access from either PC-A or PC-B
once the I-SID 10xx01 is provisioned.
a. Use Ping to test connectivity from PC-A or PC-B
b. Telnet to each switch
6. Use a Web browser to access Enterprise Device Manager on one of the VSPs.
Enter the IP address as the URL and enter the credentials as shown.
Username: admin
Password: password
Note: EDM is a fully functional device management tool for those who prefer a GUI.
7. Explore EDM’s interface identifying key network services already provisioned.
© 2022 Extreme Networks, Inc. All rights reserved
40
Campus Fabric Deploy Lab Guide
Section C: Configure IP-Shortcuts for Management
Frequently, a fabric deployment consists of multiple networks for in-band management.
Using IP-Shortcuts and the GRT along with their loopback addresses is a possible
Class Name
Student Guide
mechanism to accomplish this goal.
VSP1
1. For VSP1: Login and enter Global Configuration Mode.
Note: IP-Shortcuts has been enabled on X-VSP1 as part of the execution of the spbm
script (spbm 1 ip enable). But that’s all, no routes have been redistributed.
2. Before we redistribute the local routes, we will setup a policy for the networks we
do not want to redistribute: vIST and any “other” routes (the value 10.150.150.0
will be used as an example though it is not an address configured in the lab).
X-VSP1:1(config)#ip prefix-list "vist" 10.x.53.0/30
X-VSP1:1(config)#ip prefix-list "other" 10.150.150.0/24
X-VSP1:1(config)#route-map "suppress-vist-other" 1
X-VSP1:1(route-map)#no permit
X-VSP1:1(route-map)#enable
X-VSP1:1(route-map)#match network "vist"
X-VSP1:1(route-map)#exit
X-VSP1:1(config)#route-map "suppress-vist-other" 2
X-VSP1:1(route-map)#no permit
X-VSP1:1(route-map)#enable
X-VSP1:1(route-map)#match network "other"
X-VSP1:1(route-map)#exit
© 2022 Extreme Networks, Inc. All rights reserved
41
Campus Fabric Deploy Lab Guide
X-VSP1:1(config)#route-map "suppress-vist-other" 3
X-VSP1:1(route-map)#permit
X-VSP1:1(route-map)#enable
Class Name Student Guide
X-VSP1:1(route-map)#exit
3. Redistribute the local IP subnets.
X-VSP1:1(config)#router isis
X-VSP1:1(config-isis)#spbm 1 ip enable
X-VSP1:1(config-isis)#redistribute direct
X-VSP1:1(config-isis)#redistribute direct metric 1
X-VSP1:1(config-isis)#redistribute direct route-map
suppress-vist-other
X-VSP1:1(config-isis)#redistribute direct enable
X-VSP1:1(config-isis)#exit
4. Redistribute Direct Routes through IS-IS to the rest of the network. This activates
the redistribution of direct routes as part of the Global Routing Table (GRT).
X-VSP1:1(config)#isis apply redistribute direct
X-VSP1:1(config)#exit
X-VSP1:1#save config
VSP2
5. For VSP2: Login and enter Global Configuration Mode.
6. Before we redistribute the local routes, we will setup a policy for the networks we
do not want to redistribute: vIST and any “other” routes (the value 10.150.150.0
will be used as an example though not an address configured in the lab).
X-VSP2:1(config)#ip prefix-list "vist" 10.x.53.0/30
X-VSP2:1(config)#ip prefix-list "other" 10.150.150.0/24
X-VSP2:1(config)#route-map "suppress-vist-other" 1
X-VSP2:1(route-map)#no permit
X-VSP2:1(route-map)#enable
X-VSP2:1(route-map)#match network "vist"
X-VSP2:1(route-map)#exit
© 2022 Extreme Networks, Inc. All rights reserved
42
Campus Fabric Deploy Lab Guide
X-VSP2:1(config)#route-map "suppress-vist-other" 2
X-VSP2:1(route-map)#no permit
X-VSP2:1(route-map)#enable
Class Name Student Guide
X-VSP2:1(route-map)#match network "other"
X-VSP2:1(route-map)#exit
X-VSP2:1(config)#route-map "suppress-vist-other" 3
X-VSP2:1(route-map)#permit
X-VSP2:1(route-map)#enable
X-VSP2:1(route-map)#exit
7. Redistribute the local IP subnets.
X-VSP2:1(config)#router isis
X-VSP2:1(config-isis)#spbm 1 ip enable
X-VSP2:1(config-isis)#redistribute direct
X-VSP2:1(config-isis)#redistribute direct metric 1
X-VSP2:1(config-isis)#redistribute direct route-map
suppress-vist-other
X-VSP2:1(config-isis)#redistribute direct enable
X-VSP2:1(config-isis)#exit
8. Redistribute Direct Routes through IS-IS to the rest of the network. This activates
the redistribution of direct routes as part of the Global Routing Table (GRT).
X-VSP2:1(config)#isis apply redistribute direct
X-VSP2:1(config)#exit
X-VSP2:1#save config
© 2022 Extreme Networks, Inc. All rights reserved
43
Campus Fabric Deploy Lab Guide
9. Use the following commands on both VSP1 and VSP2 to validate the IP Shortcuts
configuration.
X-VSPx:1(config)#exit
Class Name Student
Guide ip route
X-VSPx:1#show
X-VSPx:1#show ip isis redistribute
X-VSPx:1#show isis spbm
X-VSPx:1#show isis lsdb tlv 135
X-VSPx:1#show isis lsdb tlv 135 detail
X-VSPx:1#show autotopology nmm-table
© 2022 Extreme Networks, Inc. All rights reserved
44
Campus Fabric Deploy Lab Guide
Section D: Lab 3 Configuration Summary
The following commands make up the configuration accomplished in this lab.
VSP1Student Guide
Class Name
enable
conf t
cfm spbm mepid x1
cfm spbm enable
vlan i-sid x01 10xx01
ip prefix-list "vist" 10.x.53.0/30
ip prefix-list "other" 10.150.150.0/24
route-map "suppress-vist-other" 1
no permit
enable
match network "vist"
exit
route-map "suppress-vist-other" 2
no permit
enable
match network "other"
exit
route-map "suppress-vist-other" 3
permit
enable
exit
router isis
spbm 1 ip enable
redistribute direct
redistribute direct metric 1
redistribute direct route-map suppress-vist-other
redistribute direct enable
exit
isis apply redistribute direct
exit
save config
© 2022 Extreme Networks, Inc. All rights reserved
45
Campus Fabric Deploy Lab Guide
VSP2
enable
conf t
cfm spbm
mepid x2
Class Name Student
Guide
cfm spbm enable
vlan i-sid x01 10xx01
ip prefix-list "vist" 10.x.53.0/30
ip prefix-list "other" 10.150.150.0/24
route-map "suppress-vist-other" 1
no permit
enable
match network "vist"
exit
route-map "suppress-vist-other" 2
no permit
enable
match network "other"
exit
route-map "suppress-vist-other" 3
permit
enable
exit
router isis
spbm 1 ip enable
redistribute direct
redistribute direct metric 1
redistribute direct route-map suppress-vist-other
redistribute direct enable
exit
isis apply redistribute direct
exit
save config
ERS1
enable
conf t
cfm spbm level 4
cfm spbm mepid x3
cfm spbm enable
vlan i-sid x01 10xx01
End of Lab
© 2022 Extreme Networks, Inc. All rights reserved
46
Campus Fabric Deploy Lab Guide
Lab 4: Configure Layer 2 VSNs
Lab Overview:
Class Name Student Guide
Layer 2 VSNs are the most common services for Fabric Connect because they make it
easy to provision networks using a couple of simple commands on the BEB.
Resources/Tools:
•
Refer to the Appendix.
Objectives:
When you finish this lab, you will be able to:
▪
▪
▪
Configure a Layer 2 VSN utilizing C-UNI ports
Examine and Verify the Layer 2 VSN Configuration
Configure the L2VSN for IP Multicast
Note: The lab guide uses yellow highlighted text to identify configuration values that
need to be modified based on the switch you’re configuring. The x represents your
student number from 1 through 12. The double xx represents cases where two digits
are required, 01, 02, etc. through 12. Please refer to the Appendix that accompanies
this guide for the specific values.
© 2022 Extreme Networks, Inc. All rights reserved
47
Campus Fabric Deploy Lab Guide
Section A: L2VSN ERS Configuration
Here are the BOSS procedures for configuring customer VLANs on a BEB.
1. Student
Configure Guide
the Loop-back ports. Currently on the ERS, no C-VLANs or UNI ports
Class Name
have been provisioned. For the lab, certain ports are designated as loop-back ports
simply because they are connected to each other on the same switch - creating a
loop. These commands turn on Spanning Tree for these ports. The loopback cable
activates each of the port’s links and also activates the VLANs the ports are a
member of.
X-ERS1>enable
X-ERS1#show interface
X-ERS1#conf t
X-ERS1(config)#vlan port 19,20 tagging tagall
X-ERS1(config)#interface ethernet 19,20
X-ERS1(config-if)#no shut
X-ERS1(config-if)#exit
X-ERS1(config)#show spanning-tree mstp port role
2. Create the CVLAN with the UNI ports as member ports and map to the I-SID.
X-ERS1(config)#vlan create x20 type port cist
X-ERS1(config)#vlan members add x20 19,20
X-ERS1(config)#vlan i-sid x20 20xx20
3. Turn on multicast for this L2VSN.
X-ERS1(config)#router isis
X-ERS1(config-isis)#spbm 1 multicast enable
X-ERS1(config)#exit
X-ERS1(config)#interface vlan x20
X-ERS1(config-if)#ip igmp snooping
X-ERS1(config-if)#ip igmp snoop-querier-addr 10.x.20.3
X-ERS1(config-if)#ip igmp snooping send-query
X-ERS1(config-if)#exit
X-ERS1(config)#exit
X-ERS1#save config
© 2022 Extreme Networks, Inc. All rights reserved
48
Campus Fabric Deploy Lab Guide
Section B: L2VSN VSP Configuration
Here are the VOSS procedures for configuring customer VLANs on a BEB.
1. Student
Enable ports
1/19, 1/20 on VSP2. Spanning Tree is turned on for these ports and a
Class Name
Guide
loopback cable is connected to activate each of the port’s link.
X-VSP2:1(config)#interface GigabitEthernet 1/19,1/20
X-VSP2:1(config-if)#no shut
X-VSP2:1(config-if)#exit
X-VSP2:1(config)#show spanning-tree mstp port role
2. Create the CVLAN with the UNI ports as member ports and map to an I-SID.
X-VSP2:1(config)#vlan create x20 type port-mstprstp 0
X-VSP2:1(config)#vlan members add x20 1/19-1/20
X-VSP2:1(config)#vlan i-sid x20 20xx20
3. Turn on multicast for this L2VSN.
X-VSP2:1(config)#router isis
X-VSP2:1(config-isis)#spbm 1 multicast enable
X-VSP2:1(config)#interface vlan x20
X-VSP2:1(config-if)#ip igmp snooping
X-VSP2:1(config-if)#ip igmp snoop-querier-addr 10.x.20.2
X-VSP2:1(config-if)#exit
X-VSP2:1(config)#exit
X-VSP2:1#save config
© 2022 Extreme Networks, Inc. All rights reserved
49
Campus Fabric Deploy Lab Guide
Section C: Verify L2 VSNs
For this section, you’ll observe how the L2VSN is being represented in the fabric.
Class Name
Guide
For Student
BOSS ERS1
1. Verify the VLAN configuration
X-ERS1#show vlan
X-ERS1#show vlan i-sid
X-ERS1#show mac-address-table
2. Verify the C-VLAN configuration data.
X-ERS1#show i-sid 20xx20
3. Display isis spbm I-SID information.
X-ERS1#show isis spbm i-sid all
X-ERS1#show isis spbm i-sid all id 20xx20
X-ERS1#show isis spbm i-sid all nick-name b.xx.02
X-ERS1#show isis spbm i-sid all vlan 4051
X-ERS1#show isis spbm i-sid all vlan 4052
For VOSS VSP2
4. Verify the VLAN configuration
X-VSP2:1#show vlan member
X-VSP2:1#show vlan i-sid
X-VSP2:1#show vlan mac-address-entry
5. Verify the C-VLAN configuration data.
X-VSP2:1#show i-sid 20xx20
6. Display I-SID information as seen by IS-IS.
X-VSP2:1#show isis spbm i-sid all
X-VSP2:1#show isis spbm i-sid all id 20xx20
X-VSP2:1#show isis spbm i-sid all nick-name e.xx.01
X-VSP2:1#show isis spbm i-sid all vlan 4051
X-VSP2:1#show isis spbm i-sid all vlan 4052
© 2022 Extreme Networks, Inc. All rights reserved
50
Campus Fabric Deploy Lab Guide
Section D: Lab 4 Configuration Summary
The following commands make up the configuration accomplished in this lab.
VSP2Student Guide
Class Name
enable
config t
interface GigabitEthernet 1/19,1/20
no shut
exit
vlan create x20 type port-mstprstp 0
vlan members add x20 1/19-1/20
vlan i-sid x20 20xx20
router isis
spbm 1 multicast enable
interface vlan x20
ip igmp snooping
ip igmp snoop-querier-addr 10.x.20.2
exit
exit
save config
ERS1
enable
conf t
vlan port 19,20 tagging tagall
interface ethernet 19,20
no shut
exit
vlan create x20 type port cist
vlan members add x20 19,20
vlan i-sid x20 20xx20
router isis
spbm 1 multicast enable
exit
interface vlan x20
ip igmp snooping
ip igmp snoop-querier-addr 10.x.20.3
ip igmp snooping send-query
exit
exit
save config
End of Lab
© 2022 Extreme Networks, Inc. All rights reserved
51
Campus Fabric Deploy Lab Guide
Lab 5: Configure Layer 3 VSN
Lab Overview:
Class Name Student Guide
For this lab, a Layer 3 VSN IPVPN will redistribute routes between VRF2 configured on
the VSPs. The VLAN xx50 is also extended to the ERS1 via the L2VSN.
As a disclaimer, please realize that this topology is for lab testing and designed for your
learning experience. There are more efficient ways to design this network.
Resources/Tools:
•
Refer to the Appendix.
Objectives:
When you finish this lab, you will be able to:
•
•
•
Create a VRF and L3VSN IPVPN
Redistribute VRF routes via a L3VSN
Verify the L3VSN operation
Note: The lab guide uses yellow highlighted text to identify configuration values that
need to be modified based on the switch you’re configuring. The x represents your
student number from 1 through 12. The double xx represents cases where two digits
are required, 01, 02, etc. through 12. Please refer to the Appendix that accompanies
this guide for the specific values.
© 2022 Extreme Networks, Inc. All rights reserved
52
Campus Fabric Deploy Lab Guide
Section A: Configure Layer 3 VSN on VSP2
At this time, you ‘ll configure VSP2 to support a Layer 3 VSN. This also involves creating
a VRF, creating a VLAN, adding port members, and redistributing routes.
Class Name Student Guide
1. Log in to the VSP2 and enter global configuration mode:
2. In order to configure Layer 3 VSNs, IP must be enabled on the IS-IS router. Check
that now, even though this step was performed in the previous Lab. If necessary,
set spbm 1 IP enable on the IS-IS router.
X-VSP2:1(config)#show isis spbm
X-VSP2:1(config)#router isis
X-VSP2:1(config-isis)#spbm 1 ip enable
X-VSP2:1(config-isis)#exit
3. Create VRF2. A Layer 3 VSN is configured to establish an IPVPN for a specific VRF
instance. In this case the administrative name is vrf-purple with an ID 2.
X-VSP2:1(config)#ip vrf vrf-purple vrfid 2
4. Create a VLAN that will be associated with the VRF and add the ports.
X-VSP2:1(config)#vlan create x40 type port-mstprstp 0
X-VSP2:1(config)#show vlan member
X-VSP2:1(config)#vlan members add x40 1/19-1/20
5. Assign the VLAN to the VRF and assign an IP address to the VLAN. This becomes
an IP Interface in vrf-purple.
X-VSP2:1(config)#interface vlan x40
X-VSP2:1(config-if)#vrf vrf-purple
X-VSP2:1(config-if)#ip address 10.x.40.2/24
X-VSP2:1(config-if)#exit
6. Create an IPVPN routing instance for this VRF (vrf-purple) and map it to the L3VSN
I-SID and enable it. Verify the ipvpn.
X-VSP2:1(config)#router vrf vrf-purple
X-VSP2:1(router-vrf)#ipvpn
X-VSP2:1(router-vrf)#i-sid 30xx02
X-VSP2:1(router-vrf)#ipvpn enable
X-VSP1:1(router-vrf)#show ip ipvpn
© 2022 Extreme Networks, Inc. All rights reserved
53
Campus Fabric Deploy Lab Guide
7. Enable route redistribution of direct routes to this VRF (vrf-purple) and set the
metric to 1.
X-VSP2:1(router-vrf)#isis redistribute direct
Class Name Student
Guide
X-VSP2:1(router-vrf)#isis
redistribute direct metric 1
X-VSP2:1(router-vrf)#isis redistribute direct enable
8. Enable equal cost multipath on the VRF so that both paths will be used.
X-VSP2:1(router-vrf)#ip ecmp
X-VSP2:1(router-vrf)#exit
Note: Redistribution is only activated when the apply command is issued. So, perform
that operation now.
9. Apply redistribution for the VRF to activate the function.
X-VSP2:1(config)#isis apply redistribute direct vrf vrfpurple
X-VSP2:1(config)#exit
X-VSP2:1#save config
Section B: Configure Layer 3 VSN on VSP1
The configuration on VSP1 is a bit different than what was performed on VSP2. Here
you will create a VRF and associate it to an I-SID for route redistribution in the same
way as VSP2. But here you’ll create a VLAN that will have no port members, only a
mapping to a L2VSN which will also include the ERS1.
1. Log in to the VSP1 and enter global configuration mode:
2. In order to configure Layer 3 VSNs, IP must be enabled on the IS-IS router. Check
that now. If necessary, set spbm 1 IP enable on the IS-IS router.
X-VSP1:1(config)#show isis spbm
X-VSP1:1(config)#router isis
X-VSP1:1(config-isis)#spbm 1 ip enable
X-VSP1:1(config-isis)#exit
3. Create vrf-purple VRF2. A Layer 3 VSN is configured to establish an IPVPN for a
specific VRF instance. In this case the administrative name is vrf-purple with an ID
2.
X-VSP1:1(config)#ip vrf vrf-purple vrfid 2
© 2022 Extreme Networks, Inc. All rights reserved
54
Campus Fabric Deploy Lab Guide
4. Create a VLAN that will be associated with the VRF. No port members will be
added only mapping to an I-SID for L2VSN.
X-VSP1:1(config)#vlan create x50 type port-mstprstp 0
Class Name Student
Guide
X-VSP1:1(config)#show
vlan member
X-VSP1:1(config)#vlan i-sid x50 20xx50
X-VSP1:1(config)#show vlan i-sid
5. Assign the VLAN to the VRF and assign a L3 VSN IP address.
X-VSP1:1(config)#interface vlan x50
X-VSP1:1(config-if)#vrf vrf-purple
X-VSP1:1(config-if)#ip address 10.x.50.1/24
X-VSP1:1(config-if)#exit
6. Create an IPVPN routing instance for this VRF (vrf-purple) and map it to the L3VSN
I-SID and enable it. Verify the ipvpn.
X-VSP1:1(config)#router vrf vrf-purple
X-VSP1:1(router-vrf)#ipvpn
X-VSP1:1(router-vrf)#i-sid 30xx02
X-VSP1:1(router-vrf)#ipvpn enable
X-VSP1:1(router-vrf)#show ip ipvpn
7. Enable route redistribution of direct routes to this VRF (vrf-purple) and set the
metric to 1.
X-VSP1:1(router-vrf)#isis redistribute direct
X-VSP1:1(router-vrf)#isis redistribute direct metric 1
X-VSP1:1(router-vrf)#isis redistribute direct enable
8. Enable equal cost multipath on the VRF so that both paths will be used.
X-VSP1:1(router-vrf)#ip ecmp
X-VSP1:1(router-vrf)#exit
9. Apply redistribution for the VRF to activate the function.
X-VSP1:1(config)#isis apply redistribute direct vrf vrfpurple
X-VSP1:1(config)#exit
X-VSP1:1#save config
© 2022 Extreme Networks, Inc. All rights reserved
55
Campus Fabric Deploy Lab Guide
Section C: Configure Layer 2 VSN on ERS1
The ERS1, utilized here as a Layer 2 device, is connected into the topology by a L2VSN.
The subnet 10.x.50.0/24 is available for devices connected to the ERS1 and will use the
Class Name
Student Guide
VSP1 10.x.50.1 (VRF2 x50 IP interface) as the gateway.
1. Log in to ERS1 and enter global configuration mode:
X-ERS1>en
X-ERS1#conf t
2. Create a C-VLAN, add a few UNI ports and map it to an I-SID. Port 1/7 will be
moved from the x01 vlan to x50.
X-ERS1(config)#vlan create x50 type port cist
X-ERS1(config)#vlan members remove x01 7
X-ERS1(config)#vlan members add x50 7,19-20
X-ERS1(config)#vlan i-sid x50 20xx50
X-ERS1(config)#exit
Section D: Verify L3VSN
Refer to the overview diagram at the start of the lab to validate various network
locations and parameters.
1. Check the VRF routing table to validate the network advertisements are being
redistributed through the IPVPN (I-SID 30xx02). Use these commands on both
VSP1 and VSP2.
X-VSP1:1#show ip interface vrf vrf-purple
X-VSP1:1#show ip route vrf vrf-purple
X-VSP1:1#show ip ipvpn
X-VSP2:1#show ip interface vrf vrf-purple
X-VSP2:1#show ip route vrf vrf-purple
X-VSP2:1#show ip ipvpn
How many entries in the vrf-purple routing table?
Why are there duplicate entries?
2. Check the IS-IS advertisements. Use this command on both VSP1 and VSP2.
X-VSP2:1#show isis lsdb tlv 184 detail
© 2022 Extreme Networks, Inc. All rights reserved
56
Campus Fabric Deploy Lab Guide
3. Ping a VRF interface on the remote switch. Use this command on both VSP1 and
VSP2.
X-VSP2:1#ping <dest_ip> vrf vrf-purple source <your_local
VRF_ip-address>
Class Name Student
Guide
4. Verify the L2VSN on ERS1. Verify the I-SID VLAN mapping. Verify the Mac Address
Tables on both ERS and VSP1, that they are both learning addresses in the context
of VLAN x50.
X-ERS1#show vlan
X-ERS1#show vlan i-sid
X-ERS1#show mac-address-table
X-ERS1#show isis spbm i-sid all nick-name b.xx.01
X-VSP1:1#show vlan mac-address-entry
X-VSP1:1#show isis spbm i-sid all nick-name e.xx.01
5. Modify the IP address on PC-B to reflect the new network 10.x.50.61/24. Ping
from PC-B to the VPS2 x40 IP interface 10.x.40.2. The network should be
established between the two subnets.
© 2022 Extreme Networks, Inc. All rights reserved
57
Campus Fabric Deploy Lab Guide
Section E: Lab 5 Configuration Summary
The following commands make up the configuration accomplished in this lab.
VSP2Student Guide
Class Name
enable
conf t
ip vrf vrf-purple vrfid 2
vlan create x40 type port-mstprstp 0
vlan members add x40 1/19-1/20
interface vlan x40
vrf vrf-purple
ip address 10.x.40.2/24
exit
router vrf vrf-purple
ipvpn
i-sid 30xx02
ipvpn enable
isis redistribute direct
isis redistribute direct metric 1
isis redistribute direct enable
ip ecmp
exit
isis apply redistribute direct vrf vrf-purple
exit
save config
© 2022 Extreme Networks, Inc. All rights reserved
58
Campus Fabric Deploy Lab Guide
VSP1
enable
conf t
ip vrf Guide
vrf-purple vrfid 2
Class Name Student
vlan create x50 type port-mstprstp 0
vlan i-sid x50 20xx50
interface vlan x50
vrf vrf-purple
ip address 10.x.50.1/24
exit
router vrf vrf-purple
ipvpn
i-sid 30xx02
ipvpn enable
isis redistribute direct
isis redistribute direct metric 1
isis redistribute direct enable
ip ecmp
exit
isis apply redistribute direct vrf vrf-purple
exit
save config
ERS1
enable
conf t
vlan create x50 type port cist
vlan members add x50 7,19-20
vlan i-sid x50 20xx50
exit
save config
End of Lab
© 2022 Extreme Networks, Inc. All rights reserved
59
Campus Fabric Deploy Lab Guide
Lab 6: vIST Core Switch pair (SMLT)
Lab Overview:
Class Name Student Guide
Redundancy at the edge of the fabric is provided by creating a vIST Core Switch pair
also referred to in legacy terms as a Switch Cluster. The Switch pair has redundancy at
layer 1 utilizing multiple links and at Layer 2 with redundant C-VLANs. This pair of
switches maintain the integrity of the configuration by communicating across the virtual
Inter-Switch Trunk. This lab details the configuration steps for vIST, SMLT and RSMLT.
Resources/Tools:
•
Refer to the Appendix.
Objectives:
When you finish this lab, you will be able to:
•
•
•
•
•
•
Configure a vIST Core Switch pair
Configure SMLT ports and C-VLANs
Configure a Fabric Attach Server and EXOS switch client
Demonstrate VLAN creation using Fabric Attach
Add the loop protection mechanisms SLPP and SLPP-Guard
Incorporate Layer 3 redundancy using RSMLT
Note: The lab guide uses yellow highlighted text to identify configuration values that
need to be modified based on the switch you’re configuring. The x represents your
student number from 1 through 12. The double xx represents cases where two digits
are required, 01, 02, etc. through 12. Please refer to the Appendix that accompanies
this guide for the specific values.
© 2022 Extreme Networks, Inc. All rights reserved
60
Campus Fabric Deploy Lab Guide
Section A: Configure the vIST
The vIST Core Switch pair will be VSP1 and VSP2. Only VSP2 will require vIST
configuration because the spbm script has been run on VSP1 in a previous lab. Initially,
Class Name
Student Guide
for the vIST to be established, there is no need to configure the C-VLANs and SMLT UNI
ports.
Note: IS-IS Router must be disabled to setup a vIST.
1. On VSP2, disable IS-IS Router (SPBM) in order to configure vIST.
X-VSP2:1#conf t
X-VSP2:1(config)#no router isis enable
2. Configure the SMLT Virtual BMAC and Peer System ID.
X-VSP2:1(config)#router isis
X-VSP2:1(config-isis)#spbm 1 smlt-peer-system-id
020b.0xx1.0000
X-VSP2:1(config-isis)#spbm 1 smlt-virtual-bmac
02:0b:0x:x1:00:01
X-VSP2:1(config-isis)#exit
Note: The smlt-virtual-bmac is a unique value that represents a single pair of switches
to the rest of the fabric nodes. Use a different value for each vIST Core Switch pair.
3. Create the VLAN and I-SID used for the vIST. This vIST I-SID should be unique
and not be used for any other purpose other than establishing the vIST for this
switch pair. In contrast, the VLAN ID 4053 may be used as the vIST VLAN
between other switch pairs to provide numbering consistency.
X-VSP2:1(config)#vlan create 4053 type port-mstprstp 0
X-VSP2:1(config)#vlan i-sid 4053 x4053
4. Assign the local IP address to the vIST VLAN and the peer’s IP address. It’s
recommended to use a /30 bit mask. This address is not used for routing nor is it
advertised/redistributed.
X-VSP2:1(config)#interface vlan 4053
X-VSP2:1(config-if)#ip address 10.x.53.2/30
X-VSP2:1(config-if)#exit
X-VSP2:1(config)#virtual-ist peer-ip 10.x.53.1 vlan 4053
5. Enable the IS-IS Router.
X-VSP2:1(config)#router isis enable
© 2022 Extreme Networks, Inc. All rights reserved
61
Campus Fabric Deploy Lab Guide
X-VSP2:1(config)#exit
6. Verify the vIST. The IST Status will be “up”; IST State will be “up”. If not, check
the configuration on the VSP1. The smlt-virtual-bmac must be the same on both
Class Name Student
switches. Guide
X-VSP2:1#show virtual-ist
X-VSP2:1#show isis spbm
Section B: SMLT Configuration
Split Multi-Link Trunking (SMLT) provides redundancy to the edge of the SPBM fabric
network. The SMLT ports are on the Core Switch pair and Fabric Attach is also enabled
on these ports. The LAG (sharing) is going to be automatically configured on the EXOS
edge switch using Fabric Attach.
1. Verify that the UNI ports 1/5 and 1/4 on VSP1 and VSP2 are disabled and removed
from all VLANs.
X-VSP2:1(config)#show interface gig state 1/4
X-VSP2:1(config)#show interface gig vlan 1/4
X-VSP1:1(config)#show interface gig state 1/5
X-VSP1:1(config)#show interface gig vlan 1/5
© 2022 Extreme Networks, Inc. All rights reserved
62
Campus Fabric Deploy Lab Guide
2. On both switches, create MLT x (student number) and assign the edge UNI port.
Turn on 802.1Q tagging.
X-VSP_:1(config)#mlt x
Class Name Student
Guide
X-VSP_:1(config)#mlt
x name SMLTx
X-VSP_:1(config)#mlt x mem 1/4 (VSP1 uses 1/5 and VSP2 uses 1/4)
X-VSP_:1(config)#mlt x encapsulation dot1q
3. On both switches, while in the MLT interface mode, convert it to an SMLT. Turn on
Fabric Attach with no authentication. This is also where you set the management
VLAN and I-SID for FA.
X-VSP_:1(config)#interface mlt x
X-VSP_:1(config-mlt)#smlt
X-VSP_:1(config-mlt)#fa enable
X-VSP_:1(config-mlt)#no fa message-authentication
X-VSP_:1(config-mlt)#fa management i-sid 10xx01 c-vid x01
X-VSP_:1(config-mlt)#exit
4. On both switches, display the MLT status using the following commands.
X-VSP_:1(config)#show smlt mlt
X-VSP_:1(config)#show mlt x
Note: The current status of the MLT is “Normal”. That is because the SMLT ports are
administratively disabled. The next section includes the steps to enable these ports and
thus complete the configuration.
© 2022 Extreme Networks, Inc. All rights reserved
63
Campus Fabric Deploy Lab Guide
Section C: EXOS edge configuration with Fabric Attach
This section provides automatic configuration of the EXOS edge using Fabric Attach.
Specifically, the management VLAN will be automatically mapped to the I-SID. You will
Class Name
Student Guide
step through the configuration so that you can examine the automation. Under normal
conditions, bringing up the ports in a particular order is unnecessary.
CAUTION: When using SMLT, all the C-VLANs need to have an I-SID associated with
it. Simply create the C-VLAN on both switches and associate an I-SID. In our case,
VLAN x01 and I-SID 10xx01 have already been configured on the vIST Core Switch
pair.
1. Press Enter on the EXOS console. When prompted, logon to the switch. After
observing the current configuration, you’ll enable ports 4 and 5.
Previously in Lab1, you set the switch prompt X-EXOS1 (x is your student number). All
ports are disabled which ensures LLDP packets have not yet started the automatic
configuration.
Username: admin
Password: (none) just hit Enter
X-EXOS1.1 # show vlan
X-EXOS1.2 # show port config no-refresh
X-EXOS1.3 # enable ports 4,5
2. On both VSP1 and VSP2, the SMLT port are still disabled. Enable the SMLT ports
now.
X-VSP1:1(config)#inter gig 1/5
X-VSP1:1(config-if)#no shut
X-VSP1:1(config-if)#exit
© 2022 Extreme Networks, Inc. All rights reserved
64
Campus Fabric Deploy Lab Guide
X-VSP2:1(config)#inter gig 1/4
X-VSP2:1(config-if)#no shut
X-VSP2:1(config-if)#exit
Class Name Student Guide
Fabric Attach automation will occur now!
Watch the VSP1 and VSP2 consoles for notification that the MLT is up as the EXOS links
become active. Also notice “FA INFO Fabric Attach Element Discovered”.
3. On the EXOS switch, examine the automation of fabric attach. Look at the VLAN
and sharing configuration on the EXOS switch.
X-EXOS1.4 # show ports vlan
X-EXOS1.5 # show vlan
Notice that ports 4 and 5 have the management VLAN automatically assigned.
X-EXOS1.6 # show sharing
Load Sharing Monitor
Config
Current Agg
Master
Master
Min
Ld Share
Ld Share
Control Active Algorithm Flags Group
Agg Link
Link Up
Mbr State Transi
=============================================================================
4
4
Static
1
L3
Ad
4
Y
A
1
L3
d
5
Y
A
1
=============================================================================
Notice that the LAG has been “Dynamically created shared port” with flag “d”.
X-EXOS1.7 # show fabric attach element
Notice that the two ports of the LAG have been assigned with mgmt VLAN x01. And
recognize the System Id on both ports is identical; the SMLT-VIRTUAL-BMAC.
4. Manually assign a name and an IP address to management VLAN x01. When the
administrator assigns a name to a dynamic VLAN, it becomes configurable. Using
DHCP to assign the IP address is an option in a production network.
X-EXOS1.8 # config vlan x01 name InBandMgmt
X-EXOS1.9 # disable dhcp vlan InbandMgmt
X-EXOS1.10 # config vlan InBandMgmt ipaddress 10.x.1.4/24
X-EXOS1.11 # save config
5. From the EXOS switch, verify IP connectivity of the InBandMgmt VLAN.
X-EXOS1.12 # ping 10.x.1.1
X-EXOS1.13 # ping 10.x.1.2
X-EXOS1.14 # ping 10.x.1.3
© 2022 Extreme Networks, Inc. All rights reserved
65
Campus Fabric Deploy Lab Guide
Section D: EXOS VLAN Creation Using Fabric Attach
This section provides automatic configuration of an EXOS VLAN using Fabric Attach
(FA). A VLAN and I-SID configuration performed on the EXOS will be propagated to the
Class Name
Student Guide
vIST Core Switch pair.
1. Create a new VLAN “faData” on EXOS1 and assign an I-SID. Observe that the FA
ports have been automatically configured.
X-EXOS1.14 # create vlan faData tag x06
X-EXOS1.15 # config vlan faData add port 7
X-EXOS1.16 # config vlan x06 add isid 20xx06
X-EXOS1.17 # show fabric attach assignment
X-EXOS1.18 # show port vlan
2. On one of the VSPs, observe the automation of Fabric Attach. Also notice the
learned MAC address of the EXOS switch on the SMLT interface.
X-VSP1:1#show i-sid
X-VSP1:1#show port vlan
X-VSP1:1#show vlan member
X-VSP1:1#show fa assignment
X-VSP1:1#show fa elements
X-VSP1:1#show vlan mac-address-entry
© 2022 Extreme Networks, Inc. All rights reserved
66
Campus Fabric Deploy Lab Guide
Section E: Configure SLPP and SLPP-Guard
SLPP is enabled on SMLT UNI ports to help detect and prevent loops. The packet-rxthreshold will be set differently on each VSP switch using a multiplier of 10 (i.e. 5, 50)
Class Name Student Guide
SLPP-Guard is used on the other UNI ports to ensure that cables that are moved don’t
inadvertently cause loops.
Note: Do not enable SLPP or SLPP-Guard on SPB NNI Ports.
VSP1
1. On VSP1, enable SLPP and set the packet receive threshold.
X-VSP1:1(config)#slpp enable
X-VSP1:1(config)#interface gig 1/5
X-VSP1:1(config-if)#slpp packet-rx packet-rx-threshold 5
X-VSP1:1(config-if)#exit
2. Enable SLPP on the InBandMgmt VLAN that is applied to the SMLT ports.
X-VSP1:1(config)#slpp vid x01
3. Display the SLPP configuration
X-VSP1:1(config)#show slpp
VSP2
4. On VSP2, enable SLPP and set the packet receive threshold.
X-VSP2:1(config)#slpp enable
X-VSP2:1(config)#interface gig 1/4
X-VSP2:1(config-if)#slpp packet-rx packet-rx-threshold 50
X-VSP2:1(config-if)#exit
5. Enable SLPP on the InBandMgmt VLAN used for the SMLT ports.
X-VSP2:1(config)#slpp vid x01
6. Display the SLPP configuration
X-VSP2:1(config)#show slpp
© 2022 Extreme Networks, Inc. All rights reserved
67
Campus Fabric Deploy Lab Guide
ERS1
7. Turn on SLPP-Guard on the ERS. Enter interface configuration mode to configure
SLPP Guard on switch ports:
Class Name Student
Guide
X-ERS1(config)#interface
ethernet 4-28
X-ERS1(config-if)#slpp-guard enable
X-ERS1(config-if)#exit
X-ERS1(config)#show slpp-guard
Section F: Configure RSMLT
To add RSMLT (Layer 3 redundancy) to the SMLT, IP routers will be required. In a
previous lab VRF2 has already been created. That VRF will be used along with the
supporting IP Interfaces.
1. On both of the VSPs, determine which I-SIDs and port VLAN assignments are
configured.
X-VSP1:1#show i-sid
X-VSP1:1#show port vlan
Even though FA has been used to generate I-SID 20xx06, we’ll need to add VLAN x06
specifically to create routed interfaces in VRF2.
© 2022 Extreme Networks, Inc. All rights reserved
68
Campus Fabric Deploy Lab Guide
2. On both switches, create the C-VLAN and map it to the I-SID. Add the VLAN to vrfpurple and add an IP address.
X-VSP1:1(config)#vlan create x06 type port-mstprstp 0
Class Name Student
Guide
X-VSP1:1(config)#vlan
i-sid x06 20xx06
X-VSP1:1(config)#inter vlan x06
X-VSP1:1(config-if)#vrf vrf-purple
X-VSP1:1(config-if)#ip address 10.x.6.1/24
X-VSP1:1(config-if)#exit
X-VSP2:1(config)#vlan create x06 type port-mstprstp 0
X-VSP2:1(config)#vlan i-sid x06 20xx06
X-VSP2:1(config)#inter vlan x06
X-VSP2:1(config-if)#vrf vrf-purple
X-VSP2:1(config-if)#ip address 10.x.6.2/24
X-VSP2:1(config-if)#exit
3. On both switches, create a second C-VLAN and map it to the I-SID. Add the VLAN
to vrf-purple and add an IP address. The IP address is going to be the same as the
In-band mgmt. network so that PC-A can be added to this VLAN for testing.
X-VSP1:1(config)#vlan create x04 type port-mstprstp 0
X-VSP1:1(config)#vlan i-sid x04 20xx04
X-VSP1:1(config)#vlan mem add x04 1/7
X-VSP1:1(config)#inter vlan x04
X-VSP1:1(config-if)#vrf vrf-purple
X-VSP1:1(config-if)#ip address 10.x.1.1/24
X-VSP1:1(config-if)#exit
X-VSP2:1(config)#vlan create x04 type port-mstprstp 0
X-VSP2:1(config)#vlan i-sid x04 20xx04
X-VSP2:1(config)#vlan mem add x04 1/7
X-VSP2:1(config)#inter vlan x04
X-VSP2:1(config-if)#vrf vrf-purple
X-VSP2:1(config-if)#ip address 10.x.1.2/24
X-VSP2:1(config-if)#exit
© 2022 Extreme Networks, Inc. All rights reserved
69
Campus Fabric Deploy Lab Guide
4. On both switches, enable RSMLT on both VLANs with edge support.
X-VSP1:1(config)#ip rsmlt edge-support
X-VSP1:1(config)#inter vlan x06
Class Name Student Guide
X-VSP1:1(config-if)#ip rsmlt
X-VSP1:1(config-if)#ip rsmlt holdup-timer 9999
X-VSP1:1(config)#save conf
X-VSP1:1(config)#exit
X-VSP2:1(config)#ip rsmlt edge-support
X-VSP2:1(config)#inter vlan x06
X-VSP2:1(config-if)#ip rsmlt
X-VSP2:1(config-if)#ip rsmlt holdup-timer 9999
X-VSP2:1(config-if)#exit
X-VSP2:1(config)#save config
X-VSP2:1(config)#exit
5. On both VSP switches, verify RSMLT.
X-VSPx:1#show ip rsmlt vrf vrf-purple
X-VSPx:1#show ip rsmlt local vrf vrf-purple
X-VSPx:1#show ip rsmlt peer vrf vrf-purple
X-VSPx:1#show ip rsmlt edge
6. Verify connectivity from PC-A to PC-B. Ensure that PC-B has the correct IP address
and is connected to the EXOS switch. Refer to the Appendix to migrate the
connection. PC-A (10.x.1.51) PC-B (10.x.6.61)
7. From both PC-A and PC-B, ping the gateway and each other.
PC-A to gateway
C:\Users\Studentx> ping 10.x.1.1
PC-A to PC-B
C:\Users\Studentx> ping 10.x.6.61
PC-B to gateway
C:\Users\training> ping 10.x.6.1
PC-B to PB-A
C:\Users\training> ping 10.x.1.51
© 2022 Extreme Networks, Inc. All rights reserved
70
Campus Fabric Deploy Lab Guide
Section G: Lab 6 Configuration Summary
The following commands make up the configuration accomplished in this lab.
VSP2Student Guide
Class Name
no router isis enable
y
router isis
spbm 1 smlt-peer-system-id 020b.0xx1.0000
spbm 1 smlt-virtual-bmac 02:0b:0x:x1:00:01
exit
vlan create 4053 type port-mstprstp 0
vlan i-sid 4053 x4053
interface vlan 4053
ip address 10.x.53.2/30
exit
virtual-ist peer-ip 10.x.53.1 vlan 4053
router isis enable
exit
VSP1
mlt x
mlt x name SMLTx
mlt x mem 1/5
mlt x encapsulation dot1q
interface mlt x
smlt
fa enable
no fa message-authentication
fa management i-sid 10xx01 c-vid x01
exit
slpp enable
inter gig 1/5
no shut
slpp packet-rx packet-rx-threshold 5
exit
slpp vid x01
© 2022 Extreme Networks, Inc. All rights reserved
71
Campus Fabric Deploy Lab Guide
VSP2
mlt x
mlt x name SMLTx
mlt x mem
1/4
Class Name Student
Guide
mlt x encapsulation dot1q
interface mlt x
smlt
fa enable
no fa message-authentication
fa management i-sid 10xx01 c-vid x01
exit
slpp enable
inter gig 1/4
no shut
slpp packet-rx packet-rx-threshold 50
exit
slpp vid x01
ERS1
interface ethernet 4-28
slpp-guard enable
exit
EXOS
enable ports 4,5
config vlan x01 name InBandMgmt
disable dhcp vlan InbandMgmt
config vlan InBandMgmt ipaddress 10.x.1.4/24
create vlan faData tag x06
config vlan faData add port 7
config vlan x06 add isid 20xx06
save config
© 2022 Extreme Networks, Inc. All rights reserved
72
Campus Fabric Deploy Lab Guide
VSP1
vlan create x06 type port-mstprstp 0
vlan i-sid x06 20xx06
inter vlan
Class Name Student
Guidex06
vrf vrf-purple
ip address 10.x.6.1/24
exit
vlan create x04 type port-mstprstp 0
vlan i-sid x04 20xx04
inter vlan x04
vrf vrf-purple
ip address 10.x.1.1/24
exit
VSP2
vlan create x06 type port-mstprstp 0
vlan i-sid x06 20xx06
inter vlan x06
vrf vrf-purple
ip address 10.x.6.2/24
exit
vlan create x04 type port-mstprstp 0
vlan i-sid x04 20xx04
vlan mem add x04 1/7
inter vlan x04
vrf vrf-purple
ip address 10.x.1.2/24
exit
© 2022 Extreme Networks, Inc. All rights reserved
73
Campus Fabric Deploy Lab Guide
VSP1
ip rsmlt edge-support
inter vlan x06
ip rsmlt
Class Name Student
Guide
ip rsmlt holdup-timer 9999
exit
save conf
VSP2
ip rsmlt edge-support
inter vlan x06
ip rsmlt
ip rsmlt holdup-timer 9999
exit
exit
save conf
End of Lab
© 2022 Extreme Networks, Inc. All rights reserved
74
Campus Fabric Deploy Lab Guide
Class Name Student Guide
© 2022 Extreme Networks, Inc. All rights reserved
75
Download