Network Devices

advertisement
IST 228\Ch4\Cisco IOS
What we will be able to do?
1
IST 228\Ch4\Cisco IOS
Fast Track Introduction
Router Con0 is now available
Press RETURN to get started.
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface e0
Router(config-if)#ip address 191.20.10.1 255.255.255.0
Router(config-if)#no shutdown
%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed state to up
%LINK-3-UPDOWN: Interface Ethernet0, changed state to up
Router(config-if)#^Z
%SYS-5-CONFIG_I: Configured from console by console
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface s0
Router(config-if)#ip address 192.30.10.5 255.255.255.0
Router(config-if)#no shutdown
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up
%LINK-3-UPDOWN: Interface Serial0, changed state to up
Router(config-if)#^Z
%SYS-5-CONFIG_I: Configured from console by console
Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route, o - ODR
Gateway of last resort is not set
C
191.20.10.0 is directly connected, Ethernet0
C
192.30.10.0 is directly connected, Serial0
Router#
2
IST 228\Ch4\Cisco IOS
Cisco Router User Interface
• Cisco Internetwork Operating System
(IOS)
– Provides a command-line interface (CLI),
which allows network operators to check the
status of the router and network
administrators to manage and configure the
router
– The software that interprets the command is
called the command executive (or EXEC)
3
IST 228\Ch4\Cisco IOS
Overview Of Router Modes
4
IST 228\Ch4\Cisco IOS
5
Editing and Help Features
• Type in (?) at any prompt to list all the
commends available form that prompt.
Router>?
Exec commands:
access-enable
--More--.
Create a temporary Access-List entry
• Type in (?) after a command to find the next
command in the string.
Router>ping ?
WORD
Ping destination address or hostname
apollo
Apollo echo
appletalk Appletalk echo
.
.
• To find commands that starts with certain letter,
use the letter and question mark (?).
Router>c?
clear clock configure connect copy
IST 228\Ch4\Cisco IOS
6
• Command History
– Up arrow
– Down arrow
– show history
– show terminal
last command entered
previous command entered
last 10 command
terminal configurations
• Enhanced Editing Commands
IST 228\Ch4\Cisco IOS
Setting Passwords
• There are five passwords that can be set on a
Cisco router:
7
IST 228\Ch4\Cisco IOS
8
• Enable Password
Router(config)#enable password easy
Router(config)#enable secret easy
• Auxiliary Password
Router>enable
Router#configure terminal
Enter configuration commands, one per line.
Router(config)#line aux ?
<0-0> First Line number
Router(config)#line aux 0
Router(config-line)#login
Router(config-line)#password easy
• Console Password
Router(config)#line console ?
<0-0> First Line number
Router(config)#line console 0
Router(config-line)#login
Router(config-line)#password easy
• Telnet Password
End with CNTL/Z.
IST 228\Ch4\Cisco IOS
9
• Telnet Password
Router>enable
Router#configure terminal
Enter configuration commands, one per line.
Router(config)#line ?
<0-6>
First Line number
aux
Auxiliary line
console Primary terminal line
vty
Virtual terminal
Router(config)#line
% Incomplete command.
Router(config)#line vty ?
<0-197> First Line number
Router(config)#line vty 0 4
Router(config-line)#login
Router(config-line)#password easy
Router(config-line)#
• Encrypting Your Password
Router#show running-config
Router#configure terminal
Router(config)#service password-encryption
Router(config)#no service password-encryption
Router(config)#^Z
End with CNTL/Z.
IST 228\Ch4\Cisco IOS
Banners
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#banner ?
LINE
c banner-text c, where 'c' is a delimiting character
exec
Set EXEC process creation banner
incoming Set incoming terminal line banner
login
Set login banner
motd
Set Message of the Day banner
Router(config)#banner motd #
Enter TEXT message. End with the character '#'.
Get away from my router!
#
Router(config)#^Z
%SYS-5-CONFIG_I: Configured from console by console
Router#exit
Router Con0 is now available
Press RETURN to get started.
Get away from my router.
• Exec Banner
• Incoming Banner
• Login Banner
10
IST 228\Ch4\Cisco IOS
Interfaces
• Ethernet, serial, console, and auxiliary
interfaces, the router can have other types
of interfaces, including:
– Token Ring
– Basic Rate Interface (BRI)
– Asynchronous Transfer Mode (ATM)
– Fiber Distributed Data Interface (FDDI)
– Channel Interface Processor (CIP) for System
Network Architecture (SNA)
– High-Speed Serial Interface (HSSI)
11
IST 228\Ch4\Cisco IOS
12
IST 228\Ch4\Cisco IOS
13
Bringing Up an Interface and
Configuring an IP Address
Router>enable
Router#configure terminal
Enter configuration commands, one per line.
CNTL/Z.
Router(config)#interface serial ?
<0-1> Serial interface number
End with
Router(config)#interface serial 0
Router(config-if)#ip address 172.16.10.2 255.255.255.0
Router(config-if)#no shutdown
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0,
changed state to up
%LINK-3-UPDOWN: Interface Serial0, changed state to up
Router(config-if)#^Z
Router#
IST 228\Ch4\Cisco IOS
Host Names and Descriptions
•
•
•
•
•
•
•
•
•
•
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname nopass
nopass(config)#interface e0
nopass(config-if)#description irondoor
nopass(config-if)#^Z
%SYS-5-CONFIG_I: Configured from console by console
nopass#
nopass#
14
IST 228\Ch4\Cisco IOS
Viewing and Saving Configuration
nopass#copy running-config startup-config
Destination filename [startup-config]?
nopass#show running-config
nopass# ping ?
nopass#show interface s0
nopass#show ip interface
15
IST 228\Ch4\Cisco IOS
Cisco Router User Interface
• A router can be accessed in several different
ways
– Each of these methods involves access through on
of three lines
• Network administrators typically access the
router directly through the console port
(also known as the console) located on the
back of the router
16
IST 228\Ch4\Cisco IOS
Cisco Router User Interface
• The console port connects directly to a PC
through an RJ-45 to RJ-45 rollover cable
with an RJ-45 to DB-9 or RJ-45 to DB-25
connector included with the router
– Whether you select the DB-9 or DB-25 connector will
depend on the type of port on the back of the router
• The second line used to access the router is
through the auxiliary port (AUX)
– The AUX is also located on the back of the router
17
IST 228\Ch4\Cisco IOS
Cisco Router User Interface
18
IST 228\Ch4\Cisco IOS
Cisco Router User Interface
• In addition to the AUX and console ports, five
virtual terminals (VTY) can be used to
configure the router
• Accessing the router through the VTY lines is
the same as telnetting to the router
• The router can also obtain configuration
information from a Trivial File Transfer
Protocol (TFTP) server
19
IST 228\Ch4\Cisco IOS
Cisco Router User Interface
20
IST 228\Ch4\Cisco IOS
Connecting via Terminal Programs
• When configuring the router through the
console or AUX ports, you must first make
the physical connection
• Then you can access the router through a
terminal program
• There are many different terminal
programs that you can use
21
IST 228\Ch4\Cisco IOS
Switch User Interface
• There are two types of operating systems
in use on Cisco switches:
– IOS-based
• Used by Cisco 1900, 2820, and 2900 switches
• Catalyst 1900 IOS-based operating system is the
switch model that appears on the CCNA exam
– Set-based
• Employed by Cisco 1984G, 2926, 4000, 5000, and
6000 series switches
22
IST 228\Ch4\Cisco IOS
Router Components:
Flash Memory
• Erasable, programmable, read-only
memory (EPROM)
• Not typically modified during normal
operations
• Can be upgraded or erased when
necessary
• Content of flash memory is maintained
even when the router is rebooted
23
IST 228\Ch4\Cisco IOS
Router Components:
Flash Memory
24
IST 228\Ch4\Cisco IOS
Router Components:
NVRAM
• Nonvolatile random access memory
(NVRAM)
– Special type of RAM
– Not cleared when the router is rebooted
– Startup configuration for the router is stored in
NVRAM by default
– Stores all the user-defined configuration
information for the router
25
IST 228\Ch4\Cisco IOS
Router Components:
RAM/DRAM
• Random access memory (RAM)
– Also known as dynamic random access
memory (DRAM)
– A volatile hardware component
• Information is not maintained in the event of a
router reboot
– Similar to how RAM operates in a PC
26
Download