Advanced steps with SimpleGeo

advertisement
Advanced steps with SimpleGeo
Chris Theis
Overview
Different visualization modes
Geometry sections
Visualization of biasing
Volume & mass calculation
Replicas
Measures, Precision & geometry sharing
Visualization
Biasing
Volume & mass calculation
Different visualization modes
Typical problem – visualizing the “inside” of objects while preserving the full appearance
of the surrounding structure
Solution:
1.) Define the material (e.g. concrete) transparent  but this would render all concrete
structures transparent 
2.) Use “X-ray” or “Edge ray” properties
3
Visualization
Biasing
Volume & mass calculation
Different visualization modes
1. Select the body you would like to make transparent
2. In the “Viz attributes” section on the right of your screen choose
either “X-ray mode” or “Edge-Ray mode”
X-ray
Edge-ray
* The gradient background can be enabled via the menu “View  Settings…”
** Always enable “Gouraud shading” for high quality plots (“View  Shading…”)
Visualization
Biasing
Volume & mass calculation
Different visualization modes
Sketched contours (shaded)
Sketched contours (non-shaded)
“Hand drawn” contours
Visualization
Biasing
Volume & mass calculation
Different visualization modes
“Hand drawn” contours are user configurable via the menu “View  Settings” dialog
Frequency & amplitude = level of jittering
Edge overrun => 0 = no over-drawn edges
frequency = 0.05
amplitude =0.0004
edge overrun => 0.1
frequency = 0.005
amplitude =0.0004
edge overrun => 0.3
* Decreasing the frequency and the amplitude + enabling of anti-aliasing (“view” menu) yields
thicker, chalk-like lines.
Visualization
Biasing
Volume & mass calculation
Different visualization modes – interactive shadows
Enabling shadows via the “View”  Shadows menu enhances the depth of an image
No shadows
Hard shadows
Soft shadows will be only available in SG
versions > 4.2
They can be configured via the “View” 
“Settings” dialog.
Soft shadows
More samples = nicer penumbra but longer
calculation times (more powerful GFX card)
Visualization
Biasing
Volume & mass calculation
Different visualization modes – CAD template
AutoCAD 2D DXF files can be loaded as templates to be super-imposed with the 3D geometry
 allows for comparing the CSG model to a technical drawing. (SG version > 4.2!)
1.) Select “CAD 2D template”  “Load” file
2.) Select projection (XY, YZ, etc.), unit and scaling factor in the dialog that pops up
3.) Configure the display of the drawing in terms
of position, rotation, axis dependent scaling,
line styles
Hint: The CAD template can be moved interactively
by selecting the menu “CAD 2D template” 
“Move CAD template”.
It will be moved in the current work plane and
by pressing Shift it can be moved perpendicularly
Visualization
Biasing
Volume & mass calculation
Different visualization modes – CAD template
Visualization
Biasing
Volume & mass calculation
Different visualization modes – rendering into images
SG versions > 4.2 support interactive rendering of geometries & also DaVis3D results into images.
Visualization
Biasing
Volume & mass calculation
Different visualization modes – voxel geometries
DaVis3D can be used to display cuts through voxel geometries. Since the end of 2010 it
is possible to directly load FLUKA binary voxel geometry files.
The colors are user configurable (see manual).
Visualization
Biasing
Volume & mass calculation
Visualization of importance biasing
Geometric importance biasing settings can be visualized
by coloring their contours according to their importance.
 Allows for checking for erroneous discontinuities
1.) Select “View  Shading  Render importance”
2.) Set the importance range, number of colors as well as the color scheme.
Visualization
Biasing
Geometry sections
Volume & mass calculation
For better understanding we would like to “cut out” a part of the geometry or create a full section
with a plane.
13
Visualization
Biasing
Geometry sections
Volume & mass calculation

Create a body which will be used as a section body (cookie cutter)
and place it at the correct position.

Select this body and choose from the menu “Edit  Create
section of whole geometry”. This will modify the whole geometry
in order to subtract the respective body! The file extension is
changed to “.sec.dat” to avoid mistaking this geometry, which is
intended for visualization only, with an ordinary one that can be
exported for simulations.
14
Visualization
Biasing
Geometry sections
Volume & mass calculation
Note: The parameters of the section body (size, position) can be changed even after it has
been subtracted. All changes will be propagated immediately to the rest of the geometry.
It is also possible to remove the section body from some regions in order to exclude them
from being sliced.
15
Visualization
Biasing
Volume & mass calculation
Biasing
Task: Splitting of one body/region into several sub-regions for importance biasing
1.) Select the body/region
2.) From the (context) menu choose
“Biasing wizard  Splitting wizard”
3.) Set the number of sub-regions, the dimension in
splitting direction (=distance of the splitting planes) &
splitting direction
4.) Press okay  full region description will be created automatically
Visualization
Biasing
Biasing
Task: Creation of concentric, encapsulated structures
1.) Select the body (only box, cylinder or sphere!)
2.) From the (context) menu choose
“Biasing wizard  Concentric regions”
3.) Set the geometry modification parameters
Optionally the importances can be applied as well
e.g.: entering 1.4 would apply 1.4 to the first region, 1.4^2
to the second, 1.4^3 to the third etc….
4.) Press okay  full region description will be created automatically
Volume & mass calculation
Visualization
Biasing
Volume & mass calculation
Volume & mass calculation
What is the volume & the mass of this object?
Select the object & from the context menu
(right click) choose “Volume & mass calculation”
Replicas
Replicas
To create a complex geometry which contains several cloned replicas
of one prototype as a full geometry instead of a virtual lattice copy one
can use SimpleGeo’s replica function.
1.) Create a prototype, e.g., of a magnet
2.) Do NOT include any surrounding regions
with the exception of a box which
contains your whole prototype. This facilitates
the integration in the final geometry.
3.) Save this prototype to a file.
4.) Open the final geometry and choose “File  Merge”. Select the file containing the prototype.
5.) In the following dialog answer “Yes” to
keep the prototype grouped.
Replicas
Replicas
6.) In the CSG tree you will find the prototype as a group named “Root”. You can change this
name according to your preference.
7.) Select the grouped prototype and modify its position parameters to place it correctly.
8.) Subtract the container box of the prototype from its surrounding volume (etc. the
surrounding air)
9.) Create a replica of the grouped prototype (Ctrl + C)  a fully independent clone will be
created with independent body primitives. Move this replica to its final position by
changing its position parameters. Repeat step 8 and continue as often as you would like.
ATTENTION:
The new regions/bodies will carry unique names based on the original names + suffix. Some codes like FLUKA have a
limit of 8-10 characters for names!! Thus, one might have to manually adapt these names if they become too long. For
codes like PHITS this does not pose a problem as SimpleGeo’s exporter automatically converts names to numbers.
NOTE:
Please read also the “Create replicas” section in the manual for further information.
Replicas
Replicas
Measures 2D/3D
Precision
Replicas
Measures 2D/3D
Precision
Measures (2D/3D)
What are the dimensions of
this object?
You can measure dimensions/distances
in 2D or in 3D but you need to pay attention
to the following constraints:
2D:
- Distances/measures can be defined freely without any dependence on the geometry
- Results are only meaningful if the measures are placed in parallel and not in perspective view.
 the view should be aligned to the axis-system of the geometry (use F1, F2, F3 keys, etc…)
3D:
- Distances can be measured independently of the perspective
- as the screen/mouse are 2D devices the third coordinate for the start/end of the measure has
to be obtained from a list of known points  bound to geometry vertices
Replicas
Measures 2D/3D
Precision
Measures (2D)
1.) Press F10 or select
. This will
automatically change into the
parallel projection mode.
2.) Choose the most suitable perspective
(F1, F2, F3 etc…)
3.) Click once on your geometry to define
the starting point. While moving the
mouse the actual distance w.r.t. start
will be shown next to the cursor.
4.) Click again to define the end point.
5.) Press Esc to remove all measures
from the screen.
Try also
to automatically obtain horizontal & vertical measures.
The number of displayed digits can be configured via the menu “View  Settings”.
Replicas
Measures 2D/3D
Measures 3D
1.) Click on
2.) All vertices will be marked with green
points. The size of the points can be
changed via “View  Settings” in the
field “Snap/Debugpoint size”.
3.) Click on the first vertex to define the
starting point.
4.) Click on another vertex to define
the end point.
Precision
Replicas
Measures 2D/3D
Precision
Precision
• Internally SG uses full double precision for calculations. However, by default only 2 digits,
which equals for example 1/100 cm for FLUKA, will be used in the property view.
• You can enter more digits but they will be rounded to 2 in the view for display but not
internally for geometry creation!
• The FLUKA, PHITS & MCNP(X) export filters usually use 2 digits with some exception like
arbitrary planes which require higher accuracy.
• It is possible to increase the number of digits that are displayed as well as exported.
Via the menu “View  Settings” you can open a dialog and request a larger number
in the field “Number of property digits”.
Note: A larger number of digits does not always reflect higher accuracy! We are dealing with
binary floating point arithmetic!!
Currently only the export modules for FLUKA & PHITS support a configurable number of
digits.
Mail/Copy/Paste
Sharing geometries/images

Mailing of geometries or images is supported directly from within
SimpleGeo. Just select “File  Send” and “Geometry” or “Image”.
This will send either the full geometry (incl. the material database) or
the currently rendered image to a mail recipient.

Images can be transferred directly from SimpleGeo to other applications
like Word etc. For this purpose two options are available:


Copy the full image to the clipboard (Ctrl + Alt + P or via the “Edit” menu)
Copy region of the image to the clipboard (Ctrl + Alt + R or via the “Edit” menu)
In this case the user can define the copied region by dragging a rectangle over the
screen.
Thank you for your attention
Website: www.cern.ch/theis/simplegeo
Author: Christian.Theis {at} cern . ch
27
Download
Related flashcards

Literature

26 cards

Literary genres

22 cards

Medieval literature

42 cards

Typographical symbols

20 cards

Cinematography

19 cards

Create Flashcards