Uploaded by Delito Antonio Assane

02-BCMSN-VLANs

advertisement
BCMSN LAB 2
VLAN and VTP Configuration
Lab 2: VLAN and VTP Configuration
Objective
Configure VLANs, and assign switchports to VLANs.
Lab Topology
For this lab, your network design will include two pods of devices. You will be responsible for configuring the
devices in both pods. The devices on the left side of the topology are in Pod 1. The devices on the right side of the
topology are in Pod 2. P1PC1 and P2PC2 are PC workstations. P1ASW1 and P2ASW2 are access-layer switches.
P1DSW1 and P2DSW2 are distribution-layer switches. The access and distribution layers are two of the three layers in the Cisco three-layer hierarchical network model, which also includes the core layer.
The Topology diagram below represents the NetMap in the Simulator. To access each of the devices from within
the Simulator, select the device name from the appropriate menu bar in the Simulator. For example, to access
P1ASW1, click the eSwitches button and select P1ASW1 from the drop-down menu.
128
Boson NetSim for CCNP Lab Manual
BCMSN LAB 2
VLAN and VTP Configuration
Command Summary
Command
vlan vlan_id
name vlan_name
show vlan
shutdown
no shutdown
switchport access vlan vlan_id
switchport mode access
switchport trunk allowed vlan remove vlan_list
vlan database
show interfaces interface_id switchport
ping ip_address
Description
creates a VLAN
names a VLAN
displays VLAN information
disables an interface
enables an interface
assigns the default VLAN for a port
assigns an access port
removes VLANs from a trunk port
enters VLAN database configuration mode
shows the switchport configuration
sends an ICMP echo request to the specified address
Lab Tasks
1. On each ASW, create a VLAN with the number 99.
2. On each ASW, assign the port that connects the PC router to VLAN 99.
3. On each ASW, verify that this interface belongs to VLAN 99. Use the show interfaces interface_id
switchport command.
4. Attempt to ping P1ASW1’s IP address 172.16.1.10 from P1PC1. This should fail. Why?
__________________________________________________________
5. On each ASW, disable the VLAN 1 interface.
6. On each ASW, create a VLAN 99 interface and assign this interface an IP address of 172.16.99.10 /16.
7. Enable the VLAN 99 interface.
8. Why was it necessary to disable the VLAN 1 interface?
________________________________________________________________
9. Attempt to ping the ASW VLAN 99 IP address from the PC routers. This should succeed this time because the ASWs and the PC routers all have IP addresses associated with VLAN 99.
10. From P1PC1, attempt to ping P2PC2. This should fail. Why?
________________________________________________________________
11. On each ASW, configure each of the ports that connects to the DSWs to belong to VLAN 99. Use the
interface range command to accomplish this task.
12. On each DSW, configure each of the ports that connects to the ASWs to belong to VLAN 99. Use the interface range command to accomplish this task. Notice that you neglected to create VLAN 99 on the
DSWs and that the switches created it for you.
13. On each DSW, configure each of the ports that connects to the other DSW to belong to VLAN 99. Use the
interface range command to accomplish this task.
14. From P1PC1, attempt to ping P2PC2. This should be successful now.
15. What should you do to allow the PC routers to successfully ping the DSWs?
______________________________________________________________________
Boson NetSim for CCNP Lab Manual
129
BCMSN LAB 2
VLAN and VTP Configuration
16. Configure a VLAN 99 interface on each DSW. Use the IP address 172.16.99.100 /16.
17. Enable the VLAN 99 interface. Remember to disable the VLAN 1 interface.
18. Attempt to ping the DSW VLAN 99 IP address from the PC routers. This should succeed because the DSWs
and the PC routers all have IP addresses associated with VLAN 99.
Lab Solutions
1. P1ASW1(config)#vlan 99 name VLAN99
2. P1ASW1(config)#int fa0/5
P1ASW1(config-if)#switchport access vlan 99
3. P1ASW1#show interfaces FastEthernet 0/5 switchport
Name: Fa0/5
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 99 (VLAN0099)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Voice VLAN: none (Inactive)
Appliance trust: none
4. ping 172.16.1.10
The ping fails because the ASW does not have an interface in VLAN 99.
5. P1ASW1(config)#interface vlan 1
P1ASW1(config-if)#shutdown
6. P1ASW1(config)#interface vlan99
P1ASW1(config-if)#ip address 172.16.99.10 255.255.0.0
130
Boson NetSim for CCNP Lab Manual
BCMSN LAB 2
VLAN and VTP Configuration
7. P1ASW1(config)#interface vlan99
P1ASW1(config-if)#no shut
8. It was necessary to shut down the VLAN 1 interface because the IP address overlaps with the IP address
for VLAN 99.
9. C:>ping 172.16.99.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.99.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
10. The ping fails because the interfaces between the ASWs and the DSWs do not belong to VLAN 99 and
they are not trunks.
11. P1ASW1(config)#interface range fastethernet 0/1 - 4
P1ASW1(config-if-range)#switchport access vlan 99
12. P1DSW1(config)#interface range fastethernet 0/1 - 4
P1DSW1(config-if-range)#switchport access vlan 99
%Access VLAN does not exist. Creating vlan 99
13. P1DSW1(config)#interface range fastethernet 0/11 - 12
P1DSW1(config-if-range)#switchport access vlan 99
14. The ping should succeed.
15. Create a VLAN 99 interface, and assign it an IP address.
16. P1DSW1(config)#interface vlan 99
P1DSW1(config-if)#ip address 172.16.99.100 255.255.0.0
17. P1DSW1(config)#interface vlan 99
P1DSW1(config-if)#no shut
18. C:>ping 172.16.99.100
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.99.100, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
Boson NetSim for CCNP Lab Manual
131
BCMSN LAB 2
VLAN and VTP Configuration
Sample Configuration Scripts
P1PC1
version 12.1
!
hostname C:
!
enable password cisco
!
ip subnet-zero
!
interface Ethernet0
ip address 172.16.1.1 255.255.0.0
!
ip http server
!
line con 0
password cisco
login
line aux 0
line vty 0 4
password cisco
login
!
end
132
Boson NetSim for CCNP Lab Manual
BCMSN LAB 2
VLAN and VTP Configuration
Sample Configuration Scripts
P1ASW1
version 12.1
no service pad
!
hostname P1ASW1
!
enable password cisco
!
ip subnet-zero
!
interface FastEthernet0/1
description P1ASW1 to P1DSW1
switchport access vlan 99
switchport mode access
no ip address
duplex full
speed 100
!
interface FastEthernet0/2
description P1ASW1 to P1DSW1
switchport access vlan 99
switchport mode access
no ip address
duplex full
speed 100
!
interface FastEthernet0/3
description P1ASW1 to P2DSW2
switchport access vlan 99
switchport mode access
no ip address
duplex full
speed 100
!
interface FastEthernet0/4
description P1ASW1 to P2DSW2
switchport access vlan 99
switchport mode access
no ip address
duplex full
speed 100
!
interface FastEthernet0/5
description student P1PC1 on P1ASW1
switchport access vlan 99
switchport mode access
no ip address
speed 10
!
interface FastEthernet0/6
Boson NetSim for CCNP Lab Manual
P1ASW1 (Continued)
switchport mode access
no ip address
!
interface FastEthernet0/7
switchport mode access
no ip address
!
interface FastEthernet0/8
switchport mode access
no ip address
!
interface FastEthernet0/9
switchport mode access
no ip address
!
interface FastEthernet0/10
switchport mode access
no ip address
!
interface FastEthernet0/11
switchport mode access
no ip address
!
interface FastEthernet0/12
switchport mode access
no ip address
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan99
ip address 172.16.99.10 255.255.0.0
no ip route-cache
!
ip http server
!
!
line con 0
password cisco
login
line vty 0 4
password cisco
login
line vty 5 15
login
!
end
133
BCMSN LAB 2
VLAN and VTP Configuration
Sample Configuration Scripts
P1DSW1
version 12.1
!
hostname P1DSW1
!
!
ip subnet-zero
!
interface FastEthernet0/1
description P1DSW1 to P1ASW1
switchport access vlan 99
no ip address
duplex full
speed 100
!
interface FastEthernet0/2
description P1DSW1 to P1ASW1
switchport access vlan 99
no ip address
duplex full
speed 100
!
interface FastEthernet0/3
switchport access vlan 99
no ip address
duplex full
speed 100
!
interface FastEthernet0/4
switchport access vlan 99
no ip address
duplex full
speed 100
!
interface FastEthernet0/5
no ip address
!
interface FastEthernet0/6
no ip address
!
interface FastEthernet0/7
no ip address
!
interface FastEthernet0/8
no ip address
!
interface FastEthernet0/9
no ip address
!
134
P1DSW1 (Continued)
interface FastEthernet0/10
no ip address
!
interface FastEthernet0/11
no ip address
!
interface FastEthernet0/12
no ip address
!
interface Vlan1
ip address 172.16.1.100 255.255.0.0
shutdown
!
interface Vlan99
ip address 172.16.99.100 255.255.0.0
!
ip classless
ip http server
line con 0
password cisco
login
line vty 0 4
password cisco
login
line vty 5 15
login
!
end
Boson NetSim for CCNP Lab Manual
Download