脚本调用菜单命令
app.executeMenuCommand('xxx')
File
menu
menu command
New
new
New from Template
newFromTemplate
Open
open
Browse in Bridge
Adobe Bridge Browse
Close
close
Save
save
Save As
saveas
Save a Copy
saveacopy
Save as Template
saveastemplate
Save for Web & Devices
Adobe AI Save For Web
Save Selected Slices
Adobe AI Save Selected Slices
Revert
revert
Place
AI Place
Export
export
Export Selection
exportSelection
Export/Export For Screens
exportForScreens
Scripts>Other Script
aibrowsefor_script
Document Setup
document
Document Color Mode>CMYK Color doc-color-cmyk
Document Color Mode>RGB Color
doc-color-rgb
File Info
File Info
Print
Print
Exit
quit
Edit
menu
menu command
Undo
undo
Redo
redo
Cut
cut
Copy
copy
Paste
paste
Paste in Front
pasteFront
Paste in Back
pasteBack
Paste in Place
pasteInPlace
Paste on All Artboards
pasteInAllArtboard
Clear
clear
Find & Replace
Find and Replace
Find Next
Find Next
Check Spelling
Check Spelling
Define Pattern
Define Pattern Menu Item
Edit Colors>Recolor Artwork
Recolor Art Dialog
Edit Colors>Adjust Color Balance
Adjust3
Edit Colors>Blend Front to Back
Colors3
Edit Colors>Blend Horizontally
Colors4
Edit Colors>Blend Vertically
Colors5
Edit Colors>Convert to CMYK
Colors8
Edit Colors>Convert to Grayscale
Colors7
Edit Colors>Convert to RGB
Colors9
Edit Colors>Invert Colors
Colors6
Edit Colors>Overprint Black
Overprint2
Edit Colors>Saturate
Saturate3
Edit Original
EditOriginal Menu Item
Transparency Flattener Presets
Transparency Presets
Tracing Presets
TracingPresets
Print Presets
Print Presets
Adobe PDF Presets
PDF Presets
SWF Presets
SWFPresets
Perspective Grid Presets
PerspectiveGridPresets
Color Settings
color
Assign Profile
assignprofile
Keyboard Shortcuts
KBSC Menu Item
Preferences>General
preference
Preferences>Selection & Anchor Display selectPref
Preferences>Type
keyboardPref
Preferences>Units
unitundoPref
Preferences>Guides & Grid
guidegridPref
Preferences>Smart Guides
snapPref
Preferences>Slices
slicePref
Preferences>Hyphenation
hyphenPref
Preferences>Plug-ins & Scratch Disks
pluginPref
Preferences>User Interface
UIPref
Preferences>File Handling & Clipboard
FileClipboardPref
Preferences>Appearance of Black
BlackPref
Object
menu
menu command
Transform>Transform Again
transformagain
Transform>Move
transformmove
Transform>Rotate
transformrotate
Transform>Reflect
transformreflect
Transform>Scale
transformscale
Transform>Shear
transformshear
Transform Each
Transform v23
Transform>Reset Bounding Box
AI Reset Bounding Box
Arrange>Bring to Front
sendToFront
Arrange>Bring Forward
sendForward
Arrange>Send Backward
sendBackward
Arrange>Send to Back
sendToBack
Arrange>Send to Current Layer
Selection Hat 2
Group
group
Ungroup
ungroup
Lock>Selection
lock
Lock>All Artwork Above
Selection Hat 5
Lock>Other Layers
Selection Hat 7
Unlock All
unlockAll
Hide>Selection
hide
Hide>All Artwork Above
Selection Hat 4
Hide>Other Layers
Selection Hat 6
Show All
showAll
Expand
Expand3
Expand Appearance
expandStyle
Flatten Transparency
Flatten Transparency
Rasterize
Rasterize 8 menu item
Create Gradient Mesh
make mesh
Create Object Mosaic
AI Object Mosaic Plug-in4
Create Trim Marks
TrimMark v25
Slice>Make
AISlice Make Slice
Slice>Release
AISlice Release Slice
Slice>Create from Guides
AISlice Create from Guides
Slice>Create from Selection
AISlice Create from Selection
Slice>Duplicate Slice
AISlice Duplicate
Slice>Combine Slices
AISlice Combine
Slice>Divide Slices
AISlice Divide
Slice>Delete All
AISlice Delete All Slices
Slice>Slice Options
AISlice Slice Options
Slice>Clip to Artboard
AISlice Clip to Artboard
Path>Join
join
Path>Average
average
Path>Outline Stroke
OffsetPath v22
Path>Offset Path
OffsetPath v23
Path>Simplify
simplify menu item
Path>Add Anchor Points
Add Anchor Points2
Path>Remove Anchor Points
Remove Anchor Points menu
Path>Divide Objects Below
Knife Tool2
Path>Split Into Grid
Rows and Columns….
Path>Clean Up
cleanup menu item
Blend>Make
Path Blend Make
Blend>Release
Path Blend Release
Blend>Expand
Path Blend Expand
Blend>Blend Options
Path Blend Options
Blend>Replace Spine
Path Blend Replace Spine
Blend>Reverse Spine
Path Blend Reverse Spine
Blend>Reverse Front to Back
Path Blend Reverse Stack
Envelope Distort>Make with Warp
Make Warp
Envelope Distort>Make with Mesh
Create Envelope Grid
Envelope Distort>Make with Top Object
Make Envelope
Envelope Distort>Release
Release Envelope
Envelope Distort>Envelope Options
Envelope Options
Envelope Distort>Expand
Expand Envelope
Envelope Distort>Edit Contents
Edit Envelope Contents
Perspective>Attach to Active Plane
Attach to Active Plane
Perspective>Release with Perspective
Release with Perspective
Perspective>Move Plane to Match Object Show Object Grid Plane
Perspective>Edit Text
Edit Original Object
Live Paint>Make
Make Planet X
Live Paint>Merge
Marge Planet X
Live Paint>Release
Release Planet X
Live Paint>Gap Options
Planet X Options
Live Paint>Expand
Expand Planet X
Text Wrap>Make
Make Text Wrap
Text Wrap>Release
Release Text Wrap
Text Wrap>Text Wrap Options
Text Wrap Options…
Clipping Mask>Make
makeMask
Clipping Mask>Release
releaseMask
Clipping Mask>Edit Contents
editMask
Compound Path>Make
compoundPath
Compound Path>Release
noCompoundPath
Artboards>Convert to Artboards
setCropMarks
Artboards>Rearrange
ReArrange Artboards
Artboards>Fit to Artwork Bounds
Fit Artboard to artwork bounds
Artboards>Fit to Selected Art
Fit Artboard to selected Art
Graph>Type
setGraphStyle
Graph>Data
editGraphData
Graph>Design
graphDesigns
Graph>Column
setBarDesign
Graph>Marker
setIconDesign
Align>Horizontal Align Left
Horizontal Align Left
Align>Horizontal Align Center
Horizontal Align Center
Align>Horizontal Align Right
Horizontal Align Right
Align>Vertical Align Top
Vertical Align Top
Align>Vertical Align Center
Vertical Align Center
Align>Vertical Align Bottom
Vertical Align Bottom
Type
menu
menu command
Glyphs
alternate glyph palette plugin
Area Type Options
area-type-options
Type on a Path>Rainbow
Rainbow
Type on a Path>3D Ribbon
3D ribbon
Type on a Path>Skew
Skew
Type on a Path>Stair Step
Stair Step
Type on a Path>Gravity
Gravity
Type on a Path>Type on a path
Options
typeOnPathOptions
Type on a Path>Update Legacy Type updateLegacyTOP
on a Path
Threaded Text>Create
threadTextCreate
Threaded Text>Release Selection
releaseThreadedTextSelection
Threaded Text>Remove Threading
removeThreading
Composite Fonts
Adobe internal composite font plugin
Kinsoku Shori Settings
Adobe Kinsoku Settings
Mojikumi Settings
Adobe MojiKumi Settings
Fit Headline
fitHeadline
Create Outlines
outline
Find Font
Adobe Illustrator Find Font Menu Item
Change Case>UPPERCASE
UpperCase Change Case Item
Change Case>lowercase
LowerCase Change Case Item
Change Case>Title Case
Title Case Change Case Item
Change Case>Sentence case
Sentence case Change Case Item
Smart Punctuation
Adobe Illustrator Smart Punctuation
Menu Item
Optical Margin Alignment
Adobe Optical Alignment Item
Show Hidden Characters
showHiddenChar
Type Orientation>Horizontal
type-horizontal
Type Orientation>Vertical
type-vertical
Select
menu
menu command
All
selectall
All on Active Artboard
selectallinartboard
Deselect
deselectall
Reselect
Find Reselect menu item
Inverse
Inverse menu item
Next Object Above
Selection Hat 8
Next Object Below
Selection Hat 9
Same>Appearance
Find Appearance menu item
Same>Appearance Attribute
Find Appearance Attributes menu item
Same>Blending Mode
Find Blending Mode menu item
Same>Fill & Stroke
Find Fill & Stroke menu item
Same>Fill Color
Find Fill Color menu item
Same>Opacity
Find Opacity menu item
Same>Stroke Color
Find Stroke Color menu item
Same>Stroke Weight
Find Stroke Weight menu item
Same>Graphic Style
Find Style menu item
Same>Symbol Instance
Find Symbol Instance menu item
Same>Link Block Series
Find Link Block Series menu item
Object>All on Same Layers
Selection Hat 3
Object>Direction Handles
Selection Hat 1
Object>Not Aligned to Pixel Grid Selection Hat 12
Object>Bristle Brush Strokes
Bristle Brush Strokes menu item
Object>Brush Strokes
Brush Strokes menu item
Object>Clipping Masks
Clipping Masks menu item
Object>Stray Points
Stray Points menu item
Object>Text Objects
Text Objects menu item
Object>Flash Dynamic Text
Dynamic Text
Object>Flash Input Text
Input Text
Save Selection
Selection Hat 10
Edit Selection
Selection Hat 11
Effect
menu
menu command
Apply Last Effect
Adobe Apply Last Effect
Last Effect
Adobe Last Effect
Document Raster Effects Settings
Live Rasterize Effect Setting
3D>Extrude & Bevel
Live 3DExtrude
3D>Revolve
Live 3DRevolve
3D>Rotate
Live 3DRotate
Convert to Shape>Rectangle
Live Rectangle
Convert to Shape>Rounded Rectangle Live Rounded Rectangle
Convert to Shape>Ellipse
Live Ellipse
Crop Marks
Live Trim Marks
Distort & Transform>Free Distort
Live Free Distort
Distort & Transform>Pucker & Bloat Live Pucker & Bloat
Distort & Transform>Roughen
Live Roughen
Distort & Transform>Transform
Live Transform
Distort & Transform>Tweak
Live Scribble and Tweak
Distort & Transform>Twist
Live Twist
Distort & Transform>Zig Zag
Live Zig Zag
Path>Offset Path
Live Offset Path
Path>Outline Object
Live Outline Object
Path>Outline Stroke
Live Outline Stroke
Pathfinder>Add
Live Pathfinder Add
Pathfinder>Intersect
Live Pathfinder Intersect
Pathfinder>Exclude
Live Pathfinder Exclude
Pathfinder>Subtract
Live Pathfinder Subtract
Pathfinder>Minus Back
Live Pathfinder Minus Back
Pathfinder>Divide
Live Pathfinder Divide
Pathfinder>Trim
Live Pathfinder Trim
Pathfinder>Merge
Live Pathfinder Merge
Pathfinder>Crop
Live Pathfinder Crop
Pathfinder>Outline
Live Pathfinder Outline
Pathfinder>Hard Mix
Live Pathfinder Hard Mix
Pathfinder>Soft Mix
Live Pathfinder Soft Mix
Pathfinder>Trap
Live Pathfinder Trap
Rasterize
Live Rasterize
Stylize>Drop Shadow
Live Adobe Drop Shadow
Stylize>Feather
Live Feather
Stylize>Inner Glow
Live Inner Glow
Stylize>outer Glow
Live Outer Glow
Stylize>Round Corners
Live Adobe Round Corners
Stylize>Scribble
Live Scribble Fill
SVG Filters>Apply SVG Filter
Live SVG Filters
SVG Filters>Import SVG Filter
SVG Filter Import
Warp>Arc
Live Deform Arc
Warp>Arc Lower
Live Deform Arc Lower
Warp>Arc Upper
Live Deform Arc Upper
Warp>Arch
Live Deform Arch
Warp>Bulge
Live Deform Bulge
Warp>Shell Lower
Live Deform Shell Lower
Warp>Shell Upper
Live Deform Shell Upper
Warp>Flag
Live Deform Flag
Warp>Wave
Live Deform Wave
Warp>Fish
Live Deform Fish
Warp>Rise
Live Deform Rise
Warp>Fisheye
Live Deform Fisheye
Warp>Inflate
Live Deform Inflate
Warp>Squeeze
Live Deform Squeeze
Warp>Twist
Live Deform Twist
Effect Gallery
Live PSAdapterpluginGEfc
Artistic>Colored Pencil
Live PSAdapterpluginClrP
Artistic>Cutout
Live PSAdapterpluginCt
Artistic>Dry Brush
Live PSAdapterpluginDryB
Artistic>Film Grain
Live PSAdapterpluginFlmG
Artistic>Fresco
Live PSAdapterpluginFrsc
Artistic>Neon Glow
Live PSAdapterpluginNGlw
Artistic>Paint Daubs
Live PSAdapterpluginPntD
Artistic>Palette Knife
Live PSAdapterpluginPltK
Artistic>Plastic Wrap
Live PSAdapterpluginPlsW
Artistic>Poster Edges
Live PSAdapterpluginPstE
Artistic>Rough Pastels
Live PSAdapterpluginRghP
Artistic>Smudge Stick
Live PSAdapterpluginSmdS
Artistic>Sponge
Live PSAdapterpluginSpng
Artistic>Underpainting
Live PSAdapterpluginUndr
Artistic>Watercolor
Live PSAdapterpluginWtrc
Blur>Gaussian Blur
Live PSAdapterpluginGblR
Blur>Radial Blur
Live PSAdapterpluginRdlB
Blur>Smart Blur
Live PSAdapterpluginSmrB
Brush Strokes>Accented Edges
Live PSAdapterpluginAccE
Brush Strokes>Angled Strokes
Live PSAdapterpluginAngS
Brush Strokes>Crosshatch
Live PSAdapterpluginCrsh
Brush Strokes>Dark Strokes
Live PSAdapterpluginDrkS
Brush Strokes>Ink Outlines
Live PSAdapterpluginInkO
Brush Strokes>Spatter
Live PSAdapterpluginSpt
Brush Strokes>Sprayed Strokes
Live PSAdapterpluginSprS
Brush Strokes>Sumi-e
Live PSAdapterpluginSmie
Distort>Diffuse Glow
Live PSAdapterpluginDfsG
Distort>Glass
Live PSAdapterpluginGls
Distort>Ocean Ripple
Live PSAdapterpluginOcnR
Pixelate>Color Halftone
Live PSAdapterpluginClrH
Pixelate>Crystallize
Live PSAdapterpluginCrst
Pixelate>Mezzotint
Live PSAdapterpluginMztn
Pixelate>Pointillize
Live PSAdapterpluginPntl
Sharpen>Unsharp Mask
Live PSAdapterpluginUSMk
Sketch>Bas Relief
Live PSAdapterpluginBsRl
Sketch>Chalk & Charcoal
Live PSAdapterpluginChlC
Sketch>Charcoal
Live PSAdapterpluginChrc
Sketch>Chrome
Live PSAdapterpluginChrm
Sketch>Cont← Crayon
Live PSAdapterpluginCntC
Sketch>Graphic Pen
Live PSAdapterpluginGraP
Sketch>Halftone Pattern
Live PSAdapterpluginHlfS
Sketch>Note Paper
Live PSAdapterpluginNtPr
Sketch>Photocopy
Live PSAdapterpluginPhtc
Sketch>Plaster
Live PSAdapterpluginPlst
Sketch>Reticulation
Live PSAdapterpluginRtcl
Sketch>Stamp
Live PSAdapterpluginStmp
Sketch>Torn Edges
Live PSAdapterpluginTrnE
Sketch>Water Paper
Live PSAdapterpluginWtrP
Stylize>Glowing Edges
Live PSAdapterpluginGlwE
Texture>Craquelure
Live PSAdapterpluginCrql
Texture>Grain
Live PSAdapterpluginGrn
Texture>Mosaic Tiles
Live PSAdapterpluginMscT
Texture>Patchwork
Live PSAdapterpluginPtch
Texture>Stained Glass
Live PSAdapterpluginStnG
Texture>Texturizer
Live PSAdapterpluginTxtz
Video>De-Interlace
Live PSAdapterpluginDntr
Video>NTSC Colors
Live PSAdapterpluginNTSC
View
menu
menu command
Preview
preview
Overprint Preview
ink
Pixel Preview
raster
Proof Setup>Document CMYK>
proof-document
Proof Setup>Legacy Macintosh RGB (Gamma
proof-mac-rgb
1.8)
Proof Setup>Internet Standard RGB (sRGB)
proof-win-rgb
Proof Setup>Monitor RGB
proof-monitor-rgb
Proof Setup>Color blindness –
Protanopia-type
proof-colorblindp
Proof Setup>Color blindness –
Deuteranopia-type
proof-colorblindd
Proof Setup>Customize
proof-custom
Proof Colors
proofColors
Zoom In
zoomin
Zoom Out
zoomout
Fit Artboard in Window
fitin
Fit All in Window
fitall
Actual Size
actualsize
Hide Edges
edge
Hide Artboards
artboard
Hide Print Tiling
pagetiling
Show Slices
AISlice Feedback Menu
Lock Slices
AISlice Lock Menu
Show Template
showtemplate
Rulers>Show Rulers
ruler
Rulers>Show Video Rulers
videoruler
Rulers>Change to Global Rulers
rulerCoordinateSystem
Hide Bounding Box
AI Bounding Box Toggle
Show Transparency Grid
TransparencyGrid Menu Item
Show Text Threads
textthreads
Hide Gradient Annotator
Gradient Feedback
Show Live Paint Gaps
Show Gaps Planet X
Guides>Hide Guides
showguide
Guides>Lock Guides
lockguide
Guides>Make Guides
makeguide
Guides>Release Guides
releaseguide
Guides>Clear Guides
clearguide
Smart Guides
Snapomatic on-off menu item
Perspective Grid>Show Grid
Show Perspective Grid
Perspective Grid>Show Rulers
Show Ruler
Perspective Grid>Snap to Grid
Snap to Grid
Perspective Grid>Lock Grid
Lock Perspective Grid
Perspective Grid>Lock Station Point
Lock Station Point
Perspective Grid>Define Grid
Define Perspective Grid
Perspective Grid>Save Grid as Preset
Save Perspective Grid as
Preset
Show Grid
showgrid
Snap to Grid
snapgrid
Snap to Point
snappoint
New View
newview
Edit Views
editview
Window
menu
menu command
New Window
newwindow
Arrange>Cascade
cascade
Arrange>Tile
tile
Arrange>Float in Window
floatInWindow
Arrange>Float All in
Windows
floatAllInWindows
Arrange>Consolidate All
Windows
consolidateAllWindows
Workspace>Save Workspace
Adobe Save Workspace
Workspace>New Workspace
Adobe New Workspace
Workspace>Manage Workspaces Adobe Manage Workspace
CSS Menu
CSS Menu Item
Tools
AdobeBuiltInToolbox1
Actions
Adobe Action Palette
Align
AdobeAlignObjects2
Appearance
Style Palette
Artboards
Adobe Artboard Palette
Attributes
internal palettes posing as plug-in menusattributes
Brushes
Adobe BrushManager Menu Item
Color
Adobe Color Palette
Color Guide
Adobe Harmony Palette
Kuler Panel
Adobe Illustrator Kuler Panel
Document Info
DocInfo1
Flattener Preview
Adobe Flattening Preview
Gradient
Adobe Gradient Palette
Graphic Styles
Adobe Style Palette
Info
internal palettes posing as plug-in menusinfo
Layers
AdobeLayerPalette1
Links
Adobe LinkPalette Menu Item
Magic Wand
AI Magic Wand
Navigator
AdobeNavigator
Pathfinder
Adobe PathfinderUI
Separations Preview
Adobe Separation Preview Panel
Stroke
Adobe Stroke Palette
SVG Interactivity
Adobe SVG Interactivity Palette
Swatches
Adobe Swatches Menu Item
Symbols
Adobe Symbol Palette
Transform
AdobeTransformObjects1
Transparency
Adobe Transparency Palette Menu Item
Variables
Adobe Variables Palette Menu Item
Character
internal palettes posing as plug-in menuscharacter
Character Styles
Character Styles
Glyphs
alternate glyph palette plugin 2
OpenType
internal palettes posing as plug-in menusopentype
Paragraph
internal palettes posing as plug-in menusparagraph
Paragraph Styles
Adobe Paragraph Styles Palette
Tabs
internal palettes posing as plug-in menustab
Other Library
Adobe Art Style Plugin Other libraries menu
item
Other Library
Adobe Symbol Palette Plugin Other libraries
menu item
Help
menu
menu command
Illustrator Help
helpcontent
About Illustrator about
System Info
System Info
Other Panel
menu
menu command
New Symbol
Adobe New Symbol Shortcut
Show Color Panel (Secondary) Adobe Color Palette Secondary
Actions Batch
Adobe Actions Batch
Add New Fill
Adobe New Fill Shortcut
Add New Stroke
Adobe New Stroke Shortcut
New Graphic Style
Adobe New Style Shortcut
New Layer
AdobeLayerPalette2
New Layer with Dialog
AdobeLayerPalette3
Update Link
Adobe Update Link Shortcut
Navigator Options
AdobeNavigator2
New Swatch
Adobe New Swatch Shortcut Menu
脚本调用动作命令
app.doScript(name , group)
0
You can add this document to your study collection(s)
Sign in Available only to authorized usersYou can add this document to your saved list
Sign in Available only to authorized users(For complaints, use another form )