Uploaded by Tech-Knowlogy Inc.

OSPFV3 Solution

advertisement
On Router1
Open R1
Router>enable
Router#conf t
Router(config)#no ip domain-lookup
Router(config)#hostname R1
R1(config)#enable secret class
R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#logging synchronous
R1(config-line)#exit
R1(config)#line vty 0 15
R1(config-line)#password cisco
R1(config-line)#exit
R1(config)#banner motd#
Unauthorized Access is Prohibited! #
R1(config) #ipv6 unicast-routing
R1(config)#interface g 0/0
R1(config-if)#ipv6 address 2001:DB8:ACAD:A::1/64
R1(config-if)#ipv6 address FE80::1 link-local
R1(config-if)#no shutdown
R1(config-if)#interface serial 0/0/0
R1(config-if)#clock rate 64000
R1(config-if)#ipv6 address 2001:DB8:ACAD:12::1/64
R1(config-if)#ipv6 add fe80::1 link-local
R1(config-if)#no shut
R1(Config-if) #int s0/0/01
R1(config-if)#ipv6 address 2001:DB8:ACAD:13::1/64
R1(config-if)#ipv6 add fe80::1 link-local
R1(config-if)#no shut
R1(config-if)#exit
R1(config)# exit
R1# wr
On Router2
Open R2
Router>enable
Router#conf t
Router(config)#no ip domain-lookup
Router(config)#hostname R2
R2(config)#enable secret class
R2(config)#line console 0
R2(config-line)#password cisco
R2(config-line)#logging synchronous
R2(config-line)#exit
R2(config)#line vty 0 15
R2(config-line)#password cisco
R2(config-line)#exit
R2(config)#banner motd#
Unauthorized Access is Prohibited! #
R2(config) #ipv6 unicast-routing
R2(config)#interface g 0/0
R2(config-if)#ipv6 address 2001:DB8:ACAD:B::2/64
R2(config-if)#ipv6 address FE80::2 link-local
R2(config-if)#no shutdown
R2(config-if)#interface serial 0/0/0
R2(config-if)#ipv6 address 2001:DB8:ACAD:12::2/64
R2(config-if)#ipv6 add fe80::2 link-local
R2(config-if)#no shut
R1(config-if)#exit
R2(config)#interface serial 0/0/1
R2(config-if)#ipv6 address 2001:DB8:ACAD:23::2/64
R2(config-if)#ipv6 add fe80::2 link-local
R2(config-if)#clock rate 64000
R2(config-if)#no shut
R2(config-if)#exit
R2(config)# exit
R2# wr
On Router3
Open R3
Router>enable
Router#conf t
Router(config)#no ip domain-lookup
Router(config)#hostname R3
R3(config)#enable secret class
R3(config)#line console 0
R3(config-line)#password cisco
R3(config-line)#logging synchronous
R3(config-line)#exit
R3(config)#line vty 0 15
R3(config-line)#password cisco
R3(config-line)#exit
R3(config)#banner motd#
Unauthorized Access is Prohibited! #
R3(config) #ipv6 unicast-routing
R3(config)#interface g 0/0
R3(config-if)#ipv6 address 2001:DB8:ACAD:C::3/64
R3(config-if)#ipv6 address FE80::3 link-local
R3(config-if)#no shutdown
R3(config-if)#interface serial 0/0/0
R3(config-if)#ipv6 address 2001:DB8:ACAD:13::3/64
R3(config-if)#ipv6 add fe80::3 link-local
R3(config-if)#Clock rate 64000
R3(config-if)#no shut
R1(config-if)#exit
R3(config)#interface serial 0/0/1
R3(config-if)#ipv6 address 2001:DB8:ACAD:23::3/64
R3(config-if)#ipv6 add fe80::3 link-local
R3(config-if)#no shut
R3(config-if)#exit
R3(config)# exit
R3# wr
Configure router id on all 3 routers
R1(config)# ipv6 router ospf 1
Assign the OSPFv3 router ID 1.1.1.1 to the R1.
R1(config-rtr)# router-id 1.1.1.1
Exit
R2(config)# ipv6 router ospf 1
Assign the OSPFv3 router ID 2.2.2.2 to the R2
R2(config-rtr)# router-id 2.2.2.2
exit
On R3
R3(config)# ipv6 router ospf 1
Assign the OSPFv3 router ID 3.3.3.3 to the R3
R3(config-rtr)# router-id 3.3.3.3
Exit
CONFIGURING OSPF V3 On all routers
Configure OSPFv6 on R1.
With IPv6, it is common to have multiple IPv6 addresses configured on an interface. The network
statement
has been eliminated in OSPFv3. OSPFv3 routing is enabled at the interface level instead.
a. Issue the ipv6 ospf 1 area 0 command for each interface on R1 that is to participate in OSPFv3 routing.
R1(config)# interface g0/0
R1(config-if)# ipv6 ospf 1 area 0
R1(config-if)# interface s0/0/0
R1(config-if)# ipv6 ospf 1 area 0
R1(config-if)# interface s0/0/1
R1(config-if)# ipv6 ospf 1 area 0
Note: The process ID must match the process ID you used in Step1a.
Configure OSPFv6 onR2.
With IPv6, it is common to have multiple IPv6 addresses configured on an interface. The network
statement
has been eliminated in OSPFv3. OSPFv3 routing is enabled at the interface level instead.
a. Issue the ipv6 ospf 1 area 0 command for each interface on R1 that is to participate in OSPFv3 routing.
R2(config)# interface g0/0
R2(config-if)# ipv6 ospf 1 area 0
R2(config-if)# interface s0/0/0
R2(config-if)# ipv6 ospf 1 area 0
R2(config-if)# interface s0/0/1
R2(config-if)# ipv6 ospf 1 area 0
Note: The process ID must match the process ID you used in Step1a.
Configure OSPFv6 on R3.
With IPv6, it is common to have multiple IPv6 addresses configured on an interface. The network
statement
has been eliminated in OSPFv3. OSPFv3 routing is enabled at the interface level instead.
a. Issue the ipv6 ospf 1 area 0 command for each interface on R1 that is to participate in OSPFv3 routing.
R3(config)# interface g0/0
R3(config-if)# ipv6 ospf 1 area 0
R3(config-if)# interface s0/0/0
R3(config-if)# ipv6 ospf 1 area 0
R3(config-if)# interface s0/0/1
R3(config-if)# ipv6 ospf 1 area 0
Note: The process ID must match the process ID you used in Step1a.
Check the OSPF 3 protocol on all 3 routers
Verify the IPv6 routing table.
Issue the show ipv6 route command to verify that all networks are appearing in the routing table.
R2# show ipv6 route
R1# show ipv6 route
R3# show ipv6 route
R2# show ipv6 route ospf
R1# show ipv6 route ospf
R3# show ipv6 route ospf
R1# show ipv6 ospf nei
R2# show ipv6 ospf nei
R3# show ipv6 ospf nei
Assign IPv6 addresses to PC A, PC B and PC C
Ping the Pc’s and see if they are pinging each other! SUCCESS!
Download