Uploaded by Abubakar Sadiq Hassan

With the aid of diagram configure three separate routers and use static route to make them communicate

advertisement
With the aid of diagram configure three separate routers and use
static route to make them communicate.
STEP:1- CONFIGURATION ON ROUTER R1:
I am going to assign ip address on interfaces of router R1.
Router>enable
Router#config terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa0/0
Router(config-if)#ip address 1.0.0.1 255.0.0.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int fa0/1
Router(config-if)#ip address 2.0.0.1 255.0.0.0
Router(config-if)#no shut
Now I am going to configure Static Routing on router R1:
Remember in static routing we will tell the routers about there indirectly connected networks.All routers know about their
neighbours but they didn’t have idea about the indirectly connected network.So the pattern of static routing is:
#ip route ip to reach indirectly connected network>
Router>enable
Router#config terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#ip route 3.0.0.0 255.0.0.0 2.0.0.2
Router(config)#ip route 4.0.0.0 255.0.0.0 2.0.0.2
STEP:2- CONFIGURATION ON ROUTER R2:
Similarly like router R1 i am going to configure static routing on Router R2.But before configuring static routing or any routing
protocol we need to assign ip address to router interfaces.SO here first i will assign ip address to each and every interface of
router which is in use.
Router>enable
Router#config terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa0/0
Router(config-if)#ip address 2.0.0.2 255.0.0.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int fa0/1
Router(config-if)#ip address 3.0.0.1 255.0.0.0
Router(config-if)#no shut
Now i am going to configure static routing over
router R2:
Router>enable
Router#config terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#ip route 1.0.0.0 255.0.0.0 2.0.0.1
Router(config)#ip route 4.0.0.0 255.0.0.0 3.0.0.2
STEP:3-CONFIGURATION ON ROUTER R3:
Like above two routers i will assign ip address to each interfaces of third router R3 too.
Router>enable
Router#config terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa0/1
Router(config-if)#ip address 3.0.0.2 255.0.0.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int fa0/0
Router(config-if)#ip address 4.0.0.1 255.0.0.0
Router(config-if)#no shut
Now after assigning ip addresses it’s time to
configure static routing on router R3:
Router>enable
Router#config terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#ip route 2.0.0.0 255.0.0.0 3.0.0.1
Router(config)#ip route 1.0.0.0 255.0.0.0 3.0.0.1
STEP:4- TEST PC0 and PC1 COMMUNICATION USING PING COMMAND.
Now it’s time to test network whether it is communication with devices located in other network or not.
But before pinging we need to see the ip address of our machine using ipconfig.
PC>ipconfig
1. Explain the various modes of a router.
A router is a layer 3 device used to forward packet from one network to another. It forwards the packet
through one of its port on the basis of destination IP address and the entry in the routing table. By using
routing table, it finds an optimised path between the source and destination network.
Let’s discuss about about Cisco router different modes.
Modes of router –
There are mainly 5 modes in router:
User execution mode –
As soon as the interface up message appears and press enter, the router> prompt will pop up. This is
called user execution mode. This mode is limited to some monitoring commands.
Privileged mode –
As we type enable to user mode, we enter into Privileged mode where we can view and change the
configuration of router. Different commands like show running-configuration, show IP interface brief etc
can run on this mode which are used for troubleshooting purpose.
Global configuration mode –
As we type configure terminal to the user mode, we will enter into the global configuration mode.
Commands enter in these modes are called global commands and they affect the running-configuration
of the router. In this mode, different configuration like making local database on router by providing
username and password, can set enable and secret password etc.
Interface configuration mode –
In this mode, only configuration of interfaces are done. Assigning an IP address to an interface, bringing
up the interface are the common tasks done in this mode.
ROMMON mode –
We can enter in this mode when we interrupt boot process of the router. Generally, we enter in this
mode while password recovery process or Backing up of IOS on device like TFTP server. It is like BIOS
mode of a PC.
Entering and exiting in different modes:
Modes
Access method
prompt
Exit method
user execution
mode
Login
router>
use logout command
privilege mode
use enable command in
user mode
router#
use disable command to enter
user mode
global
configuration
mode
use configure terminal
command
router(config)#
use exit command to enter into
privilege mode
Interface mode
use interface command
and specify an interface in
global configuration mode
router(configif)#
use exit command to enter into
global configuration mode or
use end command to enter into
privilege mode.
ROMMON
mode
press ctrl+break key while
boot process or use reload
command in privilege
mode.
ROMMON 1>
use continue command
SWITCHING INTO DIFFERENT ROUTER MODES
Configuration –
The user execution mode:
router>
Entering into privilege mode from user execution mode:
router>enable
router#
Exiting from privilege mode to user execution mode:
router#disable
router>
Entering in global configuration mode from privilege mode:
router#configure terminal
router(config)#
Exiting from global configuration mode to privilege mode:
router(config)#exit
router#
Entering into interface mode from global configuration mode.here we have to
specify the router’s interface.
router(config)#interface fa0/0
router(config-if)#
Exiting from interface mode to global configuration mode.
router(config-if)#exit
router(config)#
Exiting from interface mode to privilege mode.
router(config-if)#end
router#
Entering into ROMMON mode from privilege mode.
router#reload
Download