Slide 1

advertisement
Chapter 8
The Routing Table: A Closer
Look
The Routing Table Structure
Understanding the Routing
Table
 Understanding the structure and lookup process of the routing table
 Help you diagnose any routing table issue
 Regardless of your level of familiarity with the routing
protocol.
 Is the packet is being forwarded as expected? Why or why not?
 Forwarded elsewhere? Discarded?
 For more details: Cisco IP Routing
3
The Routing Table Structure
Router# show ip route
S
R
C
C
S
C
S
172.16.0.0/24 is subnetted, 4 subnets
172.16.4.0 is directly connected, Serial0/0/1
172.16.1.0 [120/1] via 172.16.2.1, 00:00:08, Serial0/0/0
172.16.2.0 is directly connected, Serial0/0/0
172.16.3.0 is directly connected, FastEthernet0/0
10.0.0.0/16 is subnetted, 1 subnets
10.1.0.0 is directly connected, Serial0/0/1
192.168.1.0/24 is directly connected, Serial0/0/1
192.168.100.0/24 is directly connected, Serial0/0/1
 The structure of the routing table might seem obvious.
 Help you verify and troubleshoot routing issues because you will
understand the routing table lookup process.
 You will know exactly what the Cisco IOS software does when it
searches for a route.
4
Topology
 Notice that R3 also has a 172.16.4.0/24 subnet that is disconnected, or
discontiguous, from the 172.16.0.0 network that R1 and R2 share.
 The effects of this discontiguous subnet are examined later in this chapter
when you look at the route lookup process.
5
Topology: Interface Configurations for R1 and R3
R1(config)# interface FastEthernet0/0
R1(config-if)# ip address 172.16.1.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# interface Serial0/0/0
R1(config-if)# ip address 172.16.2.1 255.255.255.0
R1(config-if)# clock rate 64000
R1(config-if)# no shutdown
R3(config)# interface FastEthernet0/0
R3(config-if)# ip address 172.16.4.1 255.255.255.0
R3(config-if)# no shutdown
R3(config-if)# interface Serial0/0/1
R3(config-if)# ip address 192.168.1.2 255.255.255.0
R3(config-if)# no shutdown
6
Sample Routing Table Entries
Router# show ip route
S
R
C
C
S
C
S
172.16.0.0/24 is subnetted, 4 subnets
172.16.4.0 is directly connected, Serial0/0/1
172.16.1.0 [120/1] via 172.16.2.1, 00:00:08, Serial0/0/0
172.16.2.0 is directly connected, Serial0/0/0
172.16.3.0 is directly connected, FastEthernet0/0
10.0.0.0/16 is subnetted, 1 subnets
10.1.0.0 is directly connected, Serial0/0/1
192.168.1.0/24 is directly connected, Serial0/0/1
192.168.100.0/24 is directly connected, Serial0/0/1
 Route entries from the following sources:
 Directly connected networks
 Static routes
 Dynamic routing protocols
 The source of the route does not affect the structure of the
routing table
7
Level 1 Routes
R2# debug ip routing
IP routing debugging is on
R2# conf t
R2(config)# interface serial 0/0/1
R2(config-if)# ip address 192.168.1.1 255.255.255.0
R2(config-if)# clock rate 64000
R2(config-if)# no shutdown
R2(config-if)#
00:11:06: %LINK-3-UPDOWN: Interface Serial0/0/1, changed state to up
R2(config-if)#
RT: add 192.168.1.0/24 via 0.0.0.0, connected metric [0/0]
RT: interface Serial0/0/1 added to routing table
R2(config-if)# end
R2# undebug all
All possible debugging has been turned off
 Serial 0/0/1 interface for R2 is configured with the 192.168.1.1/24 address
 As soon as no shutdown is entered, the output from debug ip routing
shows that this route has been added to the routing table.
8
Level 1 Routes
RT: add 192.168.1.0/24 via 0.0.0.0, connected metric [0/0]
RT: interface Serial0/0/1 added to routing table
R2(config-if)# end
R2# show ip route
<output omitted>
C
192.168.1.0/24 is directly connected, Serial0/0/1
 The routing table is actually a hierarchical structure that is used to
speed up the lookup process when locating routes and forwarding
packets.
 Within this structure, the hierarchy includes several levels.
 For simplicity, we discuss all routes as one of two levels: level 1
or level 2.
9
Level 1 Routes
R2# show ip route
<output omitted>
C
192.168.1.0/24 is directly connected, Serial0/0/1
 A level 1 route is a route with a subnet mask equal to or less than the
classful mask of the network address.
 192.168.1.0/24 is a level 1 network route because the subnet mask is
equal to the network’s classful mask.
 /24 is the classful mask for Class C networks, such as the 192.168.1.0
network.
10
Level 1 Routes
We will be using this chart throughout this chapter.
 A level 1 route can function as any of the following:
 Default route: A default route is a static route with the address 0.0.0.0/0.
 Supernet route: A supernet route is a network address with a mask less than
the classful mask.
 Network route: A network route is a route that has a subnet mask equal to that
of the classful mask.
 A network route can also be a parent route (next).
11
Level 1 Routes
 The level 1 route 192.168.1.0/24 can be further defined as an ultimate
route.
 An ultimate route is a route that includes one or both of the following:
 A next-hop IP address (another path)
 An exit interface
12
Level 1 Routes
 Directly connected network 192.168.1.0/24 is a
 level 1 network route - subnet mask that is the same as its
classful mask.
 ultimate route - contains the exit interface Serial 0/0/1.
13
Parent and Child Routes: Classful Networks
R2(config)# interface fastethernet 0/0
R2(config-if)# ip address 172.16.3.1 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# end
R2# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile,
<text omitted>
Gateway of last resort is not set
Level 1 Parent Route
172.16.0.0/24 is subnetted, 1 subnets
Level 2
C
172.16.3.0 is directly connected, FastEthernet0/0
Child Route
C
192.168.1.0/24 is directly connected, Serial0/0/1
 Another type of level 1 network route, a parent route.
 When the 172.16.3.0 subnet was added to the routing table,
 Another route, 172.16.0.0 also added.
 First entry: no next-hop IP address or exit interface information.
 This route is known as a level 1 parent route.
14
Parent and Child Routes: Classful Networks
R2# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile,
<text omitted>
Gateway of last resort is not set
Level 1 Parent Route
172.16.0.0/24 is subnetted, 1 subnets
Level 2
C
172.16.3.0 is directly connected, FastEthernet0/0
Child Route
C
192.168.1.0/24 is directly connected, Serial0/0/1
 A parent route is a heading:
 Indicates the presence of level 2 routes, also known as child routes.
 A level 1 parent route is automatically created any time a subnet is added
to the routing table.
 A parent route is created whenever a route with a mask greater than the
classful mask is entered into the routing table.
 The subnet 172.16.3.0 is the level 2 child route of the parent route
172.16.0.0.
15
Parent and Child Routes: Classful Networks
Level 1 Parent Route
Level 2
Child Route
 A level 2 route is a route that is a subnet of a classful network
address.
 Like a level 1 route, the source of a level 2 route can be a :
 directly connected network
 static route
 dynamic routing protocol.
16
 Parent route:
 172.16.0.0: The classful network address for our subnet.
 /24: The subnet mask for all the child routes. If the child routes have
variable-length subnet masks (VLSM), the subnet mask will be excluded
from the parent route and included with the individual child routes.
(later).
 is subnetted, 1 subnets: This part of the route specifies that this is a
parent route and in this case has one child route (that is, one subnet).
17
 Child route:
 C: The route code for a directly connected network.
 172.16.3.0: The specific route entry.
 is directly connected: Along with the route code of C, this specifies that
this is a directly connected network with an administrative distance of 0.
 FastEthernet0/0: The exit interface for forwarding packets that match this
specific route entry.
18
 A level 2 child route contains the route source and the network address of
the route.
 Notice that the subnet mask is not included with the subnet, the level 2 child
route.
 The subnet mask for this child route is the /24 mask included in its parent
route, 172.16.0.0.
 Level 2 child routes are also considered ultimate routes because they
contain the next-hop IP address or exit interface.
19
Adding another child route
R2(config)# interface serial 0/0/0
R2(config-if)# ip address 172.16.2.2 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# end
R2# show ip route
172.16.0.0/24 is subnetted, 2 subnets
C
172.16.2.0 is directly connected, Serial0/0/0
C
172.16.3.0 is directly connected, FastEthernet0/0
C
192.168.1.0/24 is directly connected, Serial0/0/1
 The routing table shows two child routes for the same 172.16.0.0/24 parent
route.
 172.16.2.0 and 172.16.3.0 are members both members of the 172.16.0.0/16
classful network.
 Because both child routes have the same subnet mask, the parent
route still maintains the /24 mask but now shows two subnets.
 Later we will see the role of the parent route.
20
Adding another child route
If child routes are
deleted there is
no parent route.
 If there is only a single level 2 child route and that route is removed, the
level 1 parent route is automatically deleted.
 A level 1 parent route exists only when there is at least one level 2 child route.
21
Parent and Child Routes: Classless Networks
 For this discussion, we switch briefly to the RouterX topology.
22
Parent and Child Routes: Classless Networks
RouterX# show ip route
C
C
C
172.16.0.0/16 is
172.16.1.4/30
172.16.1.8/30
172.16.3.0/24
variably subnetted, 3 subnets, 2 masks
is directly connected, Serial0/0/0
is directly connected, Serial0/0/1
is directly connected, FastEthernet0/0
 All three subnets belong to the classful network 172.16.0.0/16 and are
therefore level 2 child routes.
 Notice that the child routes do not share the same subnet mask, as was the
case in the classful example.
 Implementing a network addressing scheme with VLSM.
 Whenever there are two or more child routes with different subnet masks
belonging to the same classful network, the routing table presents a
slightly different view, which states that this parent network is variably
subnetted.
23
Parent and Child Routes: Classless Networks
 The parent route of 172.16.0.0 now contains the classful mask /16.
 In the classful example shown earlier the classful mask was not displayed.
 Parent route states that the child routes are variably subnetted.
 Includes the number of different masks of the child routes (2 masks).
 Each child route now contains the subnet mask for that specific route.
 In the non-VLSM example both child routes shared the same subnet mask, 24
and the parent displayed their common subnet mask.
 Parent route:
 172.16.0.0: The parent route, the classful network address associated
with all child routes
 /16: The classful subnet mask of the parent route
 variably subnetted: States that the child routes are variably subnetted
and that there are multiple masks for this classful network
 3 subnets, 2 masks: Indicates the number of subnets and the number of
different subnet masks for the child routes under this parent route
25
 Child route:
 C: The route code for a directly connected network
 172.16.1.4: The specific route entry
 /30: The subnet mask for this specific route
 is directly connected: Along with the route code of C, specifies that this
is a directly connected network with an administrative distance of 0
 Serial0/0/0: The exit interface for forwarding packets that match this
specific route entry
26
Routing Table Lookup Process
Routing Table Lookup Process
IP Packet
Routing Table
Find “best match”
 When a router receives a packet on one of its interfaces.
 The routing table lookup process compares the destination IP
address of the incoming packet with the entries in the routing table.
 The best match between the packet’s destination IP address and
the route in the routing table is used to determine to which interface
to forward the packet.
28
Steps in the Route Table
Lookup Process
R1(config)# router rip
R1(config-router)# network 172.16.0.0
R2(config)# router rip
R2(config-router)# network 172.16.0.0
R2(config-router)# network 192.168.1.0
R3(config)# router rip
R3(config-router)# network 172.16.0.0
R3(config-router)# network 192.168.1.0
 We have specifically chosen a classful routing protocol with our
discontiguous 172.16.0.0 subnets.
 The reason for this will become evident in a later section.
29
Steps in the Route Table Lookup Process
R1# show ip route
172.16.0.0/24 is subnetted, 3 subnets
C
172.16.1.0 is directly connected, FastEthernet0/0
C
172.16.2.0 is directly connected, Serial0/0/0
R
172.16.3.0 [120/1] via 172.16.2.2, 00:00:25, Serial0/0/0
R
192.168.1.0/24 [120/1] via 172.16.2.2, 00:00:25, Serial0/0/0
R2# show ip route
172.16.0.0/24 is subnetted, 3 subnets
R
172.16.1.0 [120/1] via 172.16.2.1, 00:00:07, Serial0/0/0
C
172.16.2.0 is directly connected, Serial0/0/0
C
172.16.3.0 is directly connected, FastEthernet0/0
C
192.168.1.0/24 is directly connected, Serial0/0/1
R3# show ip route
172.16.0.0/24 is subnetted, 1 subnets
C
172.16.4.0 is directly connected, FastEthernet0/0
C
192.168.1.0/24 is directly connected, Serial0/0/1
 Neither R1 nor R2 has a route to 172.16.4.0.
 Also, R3 does not have routes to subnets 172.16.1.0/24, 172.16.2.0/24, or
172.16.3.0/24.
30
The Route Lookup Process
Routing Table
Step 1.
 The router examines level 1 routes, including network routes and
supernet routes, for the best match with the destination address of
the IP packet
31
The Route Lookup Process
Routing Table
Step 1a.
 If the best match is a level 1 ultimate route—a classful network,
supernet, or default route—this route is used to forward the packet
32
The Route Lookup Process
Routing Table
Step 1b.
 If the best match is a level 1 parent route, proceed to Step 2
33
The Route Lookup Process
Routing Table
Step 2.
 The router examines child routes (the subnet routes) of the parent
route for a best match.
34
The Route Lookup Process
Routing Table
Step 2a.
 If there is a match with a level 2 child route, that subnet is used to
forward the packet.
35
The Route Lookup Process
Routing Table
Step 2b.
 If there is not a match with any of the level 2 child routes, proceed to
Step 3.
36
The Route Lookup Process
Routing Table
Step 3.
 Is the router implementing classful or classless routing behavior.
(later)
 Router(config)# no ip classless
 Router(config)# ip classless
37
The Route Lookup Process
Routing Table
Step 3a.
 If classful routing behavior is in effect, terminate the lookup
process and drop the packet.
 Router(config)# no ip classless
38
The Route Lookup Process
Routing Table
Step 3b.
 If classless routing behavior is in effect, continue searching level 1
supernet routes in the routing table for a match, including the default
route, if there is one.
39
The Route Lookup Process
Routing Table
Step 4.
 If there is now a lesser match with a level 1 supernet or default
routes, the router uses that route to forward the packet.
40
The Route Lookup Process
Routing Table
Step 5.
 If there is not a match with any route in the routing table, the router
drops the packet.
41
Longest Match
 (Digressing from topology)
 For there to be a match between the destination IP address of a packet
and a route in the routing table, a minimum number of leftmost bits
must match between the IP address of the packet and the route in the
routing table.
 The subnet mask of the route in the routing table is used to determine the
minimum number of leftmost bits that must match.
 IP packet only contains the IP address and not the subnet mask.
42
Longest Match
All three routes match but Route 3 has the longest match.
 The best match or longest match is the route in the routing table that has
the greatest number of leftmost matching bits with the destination IP
address of the packet.
 The route with the greatest number of equivalent leftmost bits, or the
longest match, is always the preferred route.
 Subnet mask in routing table specifies the minimum number of leftmost
matching bits – the only bits that are considered.
43
Example: Level 1
Ultimate Route
44
Example: Level 1
Ultimate Route
R1# show ip route
172.16.0.0/24 is subnetted, 3 subnets
C
172.16.1.0 is directly connected, FastEthernet0/0
C
172.16.2.0 is directly connected, Serial0/0/0
R
172.16.3.0 [120/1] via 172.16.2.2, 00:00:25, Serial0/0/0
R
192.168.1.0/24 [120/1] via 172.16.2.2, 00:00:25, Serial0/0/0
 PC1 sends a ping to 192.168.1.2, the serial interface on R3.
45
192.168.1.2
R1# show ip route
172.16.0.0/24 is subnetted, 3 subnets
R
192.168.1.0/24 [120/1] via 172.16.2.2, 00:00:25, Serial0/0/0
 The router first examines level 1 routes for the best match.
46
192.168.1.2
R1# show ip route
172.16.0.0/24 is subnetted, 3 subnets
R
192.168.1.0/24 [120/1] via 172.16.2.2, 00:00:25, Serial0/0/0
 There is a match between the destination IP address 192.168.1.2 and the
level 1 ultimate route of 192.168.1.0/24.
 R1 uses this route and forwards the packet out interface Serial 0/0/0.
47
192.168.1.2
Example: Level 1 Ultimate Route
 Why is there a match with the 192.168.1.0/24 level 1 route and not
with one of the 172.16.0.0 subnets?
 Why is there not a match with any of the 172.16.0.0/24 subnets in
the routing table?
48
192.168.1.2
Example: Level 1 Ultimate Route
 172.16.0.0/24 is a parent route of three subnets or child routes.
 Before a child route is examined for a match, there must be
at least a match between the destination IP address of the
packet and the classful address of the parent route, or
172.16.0.0/16.
 16 bits (/16) must match the route 172.16.0.0/16 – no match!
49
192.168.1.2
Example: Level 1 Ultimate Route
 The route, 192.168.1.0, is a level 1 ultimate route and, therefore, it also
contains the subnet mask, /24.
 Not only does the minimum of 24 bits match, but a total of 30 bits
match.
 Because there is not a longer, more specific match, the packet is forwarded
out the exit interface Serial 0/0/0.
50
192.168.1.2
Example: Level 1
Ultimate Route
No
match
Match
R1# show ip route
172.16.0.0/24 is subnetted, 3 subnets
C
172.16.1.0 is directly connected, FastEthernet0/0
C
172.16.2.0 is directly connected, Serial0/0/0
R
172.16.3.0 [120/1] via 172.16.2.2, 00:00:25, Serial0/0/0
R
192.168.1.0/24 [120/1] via 172.16.2.2, 00:00:25, Serial0/0/0
 R1 forwards the packet out Serial0/0/0.
51
Longest Match:
Level 1 Parent
and Level 2
Child Routes
52
Longest Match: Level 1 Parent and Level 2 Child Routes
172.16.3.10
Match
R1# show ip route
172.16.0.0/24 is subnetted, 3 subnets
C
172.16.1.0 is directly connected, FastEthernet0/0
C
172.16.2.0 is directly connected, Serial0/0/0
R
172.16.3.0 [120/1] via 172.16.2.2, 00:00:25, Serial0/0/0
R
192.168.1.0/24 [120/1] via 172.16.2.2, 00:00:25, Serial0/0/0
 Examine what happens when there is a match with a level 1 parent
route.
 Before any level 2 child routes are examined for a match, there
must be a match between the classful address of the level 1
parent route and the destination IP address of the packet.
53
172.16.3.10
Longest Match: Level
1 Parent and Level 2
Child Routes
 PC1 sends a ping to PC2 at 172.16.3.10.
 R1 receives the packet and forwards it to R2.
54
172.16.3.10
Match
R1# show ip route
172.16.0.0/24 is subnetted, 3 subnets
C
172.16.1.0 is directly connected, FastEthernet0/0
C
172.16.2.0 is directly connected, Serial0/0/0
R
172.16.3.0 [120/1] via 172.16.2.2, 00:00:25, Serial0/0/0
R
192.168.1.0/24 [120/1] via 172.16.2.2, 00:00:25, Serial0/0/0
 The first match that occurs is with the level 1 parent route, 172.16.0.0.
 With non-VLSM subnets, the classful mask of the parent is not
displayed.
 Before any child routes (subnets) are examined for a match, there must be
a match with the classful address of the parent route.
 Because 172.16.0.0 is a Class B address, 16 leftmost bits must match.
 16 bits match the parent route, 172.16.0.0.
55
172.16.3.10
R1# show ip route
172.16.0.0/24 is subnetted, 3 subnets
Examine
child
C
172.16.1.0 is directly connected, FastEthernet0/0
routes C
172.16.2.0 is directly connected, Serial0/0/0
R
172.16.3.0 [120/1] via 172.16.2.2, 00:00:25, Serial0/0/0
R
192.168.1.0/24 [120/1] via 172.16.2.2, 00:00:25, Serial0/0/0
 Because there is a match with the parent route, the level 2 child
routes will be examined for a match.
 The actual subnet mask of /24 is used for the minimum number of
leftmost bits that must match.
56
172.16.3.10
Match
R1# show ip route
172.16.0.0/24 is subnetted, 3 subnets
C
172.16.1.0 is directly connected, FastEthernet0/0
C
172.16.2.0 is directly connected, Serial0/0/0
R
172.16.3.0 [120/1] via 172.16.2.2, 00:00:25, Serial0/0/0
R
192.168.1.0/24 [120/1] via 172.16.2.2, 00:00:25, Serial0/0/0
 The route lookup process searches the child routes for a match.
 In this case, there must be a minimum of 24 bits that match.
 Of the three subnets there is only one route that has 24 bits that
match:
 172.16.3.0
57
172.16.3.10
Match
Parent
No match
child
No match
child
Match
child
 The router checks the last child route for 172.16.3.0/24 and finds a
match.
 The first 24 bits do match.
58
172.16.3.10
Match
Parent
No match
No match
Match
child
R1# show ip route
172.16.0.0/24 is subnetted, 3 subnets
C
172.16.1.0 is directly connected, FastEthernet0/0
C
172.16.2.0 is directly connected, Serial0/0/0
R
172.16.3.0 [120/1] via 172.16.2.2, 00:00:25, Serial0/0/0
R
192.168.1.0/24 [120/1] via 172.16.2.2, 00:00:25, Serial0/0/0
 If this child route did not have an exit interface and
only included a next-hop IP address, the next-hop IP
address would need to be resolved to an exit
interface.
 The lookup process would need to start from the
beginning, this time searching the routing table for the
nexthop IP address.
 What happens if the router does not have a route?
 In this scenario, it discards the packet.
59
Example: Route Lookup Process with VLSM
60
Example: Route Lookup Process with VLSM
172.16.1.5
RouterX# show ip route
Match
Parent
Match
child
C
C
C
172.16.0.0/16 is
172.16.1.4/30
172.16.1.8/30
172.16.3.0/24
variably subnetted, 3 subnets, 2 masks
is directly connected, Serial0/0/0
is directly connected, Serial0/0/1
is directly connected, FastEthernet0/0
 Packet’s destination IP Address: 172.16.1.5
 Using VSLM does not change the lookup process.
 The only difference with VLSM is that child routes display their own specific
subnet masks.
 16 bits match the parent route, 172.16.0.0.
 For there to be a match with the 172.16.1.4 child route, a minimum of 30
leftmost bits must match because the subnet mask is /30
61
Routing Behavior

Classful and Classless Routing Behavior
172.16.4.10
R2# show ip route
Match
Parent
No match
No match
No match
Now
what?
R
C
C
C
S*
172.16.0.0/24 is subnetted, 3 subnets
172.16.1.0 [120/1] via 172.16.2.1, 00:00:00, Serial0/0/0
172.16.2.0 is directly connected, Serial0/0/0
172.16.3.0 is directly connected, FastEthernet0/0
192.168.1.0/24 is directly connected, Serial0/0/1
0.0.0.0/0 is directly connected, Serial0/0/1
 What happens when there is a match between the packet’s destination
IP address and a level 1 parent route, but there is not a match with any
of the level 2 child routes?
 We might assume the routing table lookup process continues looking for
a less-specific match in the routing table.
 However, you will see that this might or might not be the case
depending on the configuration of the router.
63
Classful and Classless Routing Behavior
 Classless and classful routing behaviors are not the same as classless and
classful routing protocols.
 Classful and classless routing protocols affect how the routing table is
populated.
 Classful and classless routing behaviors determine how the routing table
is searched after it is populated.
64
Topology Changes
 Classful routing protocols such as RIPv1 do not support discontiguous
networks.
 Even though our current topology has discontiguous networks, we can
configure static routes to reach those networks.
65
Topology Changes
R2(config)# ip route 0.0.0.0 0.0.0.0 s0/0/1
R2(config)# router rip
R2(config-router)# default-information originate
R2(config-router)# no network 192.168.1.0
R2(config-router)# end
R2# show ip route
R
C
C
C
S*
172.16.0.0/24 is subnetted, 3 subnets
172.16.1.0 [120/1] via 172.16.2.1, 00:00:00, Serial0/0/0
172.16.2.0 is directly connected, Serial0/0/0
172.16.3.0 is directly connected, FastEthernet0/0
192.168.1.0/24 is directly connected, Serial0/0/1
0.0.0.0/0 is directly connected, Serial0/0/1
66
Topology Changes
R3(config)# ip route 172.16.0.0 255.255.0.0 s0/0/1
R3(config)# no router rip
R3(config-router)# end
R3# show ip route
C
S
C
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
172.16.4.0/24 is directly connected, FastEthernet0/0
172.16.0.0/16 is directly connected, Serial0/0/1
192.168.1.0/24 is directly connected, Serial0/0/1
 Notice that the static route for the same network as the parent route is
a child route in the routing table.
 This is because there is a child route for that parent.
 If there wasn’t a 172.16.4.0/24 child route, then this 172.16.0.0/16 static
route would be a level 1 ultimate route.
67
Routing Behavior
Routing Table
Step 3.
 Is the router implementing classful or classless routing behavior.
(later)
 Router(config)# no ip classless
 Router(config)# ip classless
68
Classful Routing Behavior: no ip classless
R2# show ip route
Match
Parent
No match
No match
No match
Now
what?
R
C
C
C
S*
172.16.0.0/24 is subnetted, 3 subnets
172.16.1.0 [120/1] via 172.16.2.1, 00:00:00, Serial0/0/0
172.16.2.0 is directly connected, Serial0/0/0
172.16.3.0 is directly connected, FastEthernet0/0
192.168.1.0/24 is directly connected, Serial0/0/1
0.0.0.0/0 is directly connected, Serial0/0/1
R1(config)# no ip classless
R2(config)# no ip classless
R3(config)# no ip classless
 What happens when there is a match with a parent, but none of the child routes
match?
 Before Cisco IOS Software Release 11.3, no ip classless was the default
behavior for Cisco routers.
 The command no ip classless means that the route lookup process uses
classful routing table lookups by default.
69
Classful Routing Behavior: Search Process
 R2 receives a packet destined for PC3 at 172.16.4.10
70
172.16.4.10
Classful Routing Behavior: no ip classless
R2# show ip route
Match
Parent
No match
No match
No match
Now
what?
R
C
C
C
S*
172.16.0.0/24 is subnetted, 3 subnets
172.16.1.0 [120/1] via 172.16.2.1, 00:00:00, Serial0/0/0
172.16.2.0 is directly connected, Serial0/0/0
172.16.3.0 is directly connected, FastEthernet0/0
192.168.1.0/24 is directly connected, Serial0/0/1
0.0.0.0/0 is directly connected, Serial0/0/1
 The routing process searches the routing table and finds a 16-bit match
with the parent route 172.16.0.0.
 None of the child routes have 24 leftmost bits that match the 24 leftmost bits
of the destination IP address 172.16.4.10.
71
172.16.4.10
Classful Routing Behavior: no ip classless
R2# show ip route
Match
Parent
No match
No match
No match
Now
what?
R
C
C
C
S*
172.16.0.0/24 is subnetted, 3 subnets
172.16.1.0 [120/1] via 172.16.2.1, 00:00:00, Serial0/0/0
172.16.2.0 is directly connected, Serial0/0/0
172.16.3.0 is directly connected, FastEthernet0/0
192.168.1.0/24 is directly connected, Serial0/0/1
0.0.0.0/0 is directly connected, Serial0/0/1
DROP PACKET
 So, what happens next?
 Router R2 drops the
packet.
 Default route is never
checked or used.
72
172.16.4.10
Classful Routing Behavior: no ip classless
 Why does classful routing behavior perform like this?
 The general idea of classful routing behavior comes from the time when all
networks were of a classful nature.
 At the beginning of the Internet’s growth, an organization received a Class
A, Class B, or Class C major network address.
 When an organization had a classful IP major network address, that
organization would also administer all the subnets for that classful address.
 All routers belonging to the organization would know about all the subnets
for the major network.
 If a subnet was not in the routing table, the subnet did not exist
73
172.16.4.10
Classless Routing Behavior: ip classless
 Remember: R2 receives a packet destined for PC3 at 172.16.4.10
74
172.16.4.10
Classless Routing Behavior: ip classless
R2# show ip route
Match
Parent
No match
No match
No match
Now
what?
R
C
C
C
S*
172.16.0.0/24 is subnetted, 3 subnets
172.16.1.0 [120/1] via 172.16.2.1, 00:00:00, Serial0/0/0
172.16.2.0 is directly connected, Serial0/0/0
172.16.3.0 is directly connected, FastEthernet0/0
192.168.1.0/24 is directly connected, Serial0/0/1
0.0.0.0/0 is directly connected, Serial0/0/1
R1(config)# ip classless
R2(config)# ip classless
R3(config)# ip classless
 Cisco IOS 11.3, Cisco changed the default routing behavior from classful to classless.
 ip classless command is configured by default.
 Classless routing behavior means that the routing process no longer assumes that all
subnets for a major classful network can be reached only within the child routes
of the parent.
 Classless routing behavior works well for discontiguous networks and classless
75
interdomain routing (CIDR) supernets.
172.16.4.10
Step 3b.
 If classless routing behavior is
in effect, continue searching level
1 supernet routes in the routing
table for a match, including the
default route, if there is one.
Step 4.
 If there is now a lesser match
with a level 1 supernet or default
routes, the router uses that route
to forward the packet.
76
172.16.4.10
Classless Routing Behavior: ip classless
R2# show ip route
Match
Parent
No match
No match
No match
Now
what?
R
C
C
C
S*
172.16.0.0/24 is subnetted, 3 subnets
172.16.1.0 [120/1] via 172.16.2.1, 00:00:00, Serial0/0/0
172.16.2.0 is directly connected, Serial0/0/0
172.16.3.0 is directly connected, FastEthernet0/0
192.168.1.0/24 is directly connected, Serial0/0/1
0.0.0.0/0 is directly connected, Serial0/0/1
 The 192.168.1.0/24 route does not have 24 leftmost bits that match the
destination IP address.
 /0, which means that zero or no bits need to match.
 A default route will be the lowest-bit match. In classless routing behavior, if
no other route matches, the default route will match.
77
172.16.4.10
Classless Routing Behavior: ip classless
R2# show ip route
Match
Parent
No match
No match
No match
Now
what?
R
C
C
C
S*
172.16.0.0/24 is subnetted, 3 subnets
172.16.1.0 [120/1] via 172.16.2.1, 00:00:00, Serial0/0/0
172.16.2.0 is directly connected, Serial0/0/0
172.16.3.0 is directly connected, FastEthernet0/0
192.168.1.0/24 is directly connected, Serial0/0/1
0.0.0.0/0 is directly connected, Serial0/0/1
Continue searching level 1 supernet routes. The default route is a
match, so I is used to forward the packet.
78
172.16.4.10
Classless Routing Behavior: ip classless
Step 5.
 If there is not a match with any route in the routing table, the router
drops the packet.
79
172.16.4.10
Classful Routing Behavior: no ip classless
Classless Routing Behavior: ip classless
80
Download