31779-QOS - Cisco Support Community

advertisement
Hi Allan,
Thank you for the fast response. Pretty much all calls are affected. Here is what I have in
the LAN and the LLQ policy
Access port
interface FastEthernet1/0/43
switchport access vlan 42
switchport voice vlan 52
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone port
spanning-tree portfast
Trunk port
interface GigabitEthernet1/0/4
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 42,52,72,101,254
switchport mode trunk
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
priority-queue out
mls qos trust cos
auto qos voip trust
Layer 3 Interface
interface GigabitEthernet1/0/47
io switchport
ip address XX.XX.XX.XX 255.255.255.248
ip summary-address eigrp XX XX.XX.XX.0 255.255.240.0 5
speed 1000
duplex full
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2
priority-queue out
mls qos trust cos
auto qos voip trust
LLQ out on Multilink interface into MPLS
class-map match-any gold
description Class 1 traffic, Voip, Video, real-time traffic, exp5
match ip dscp af41 af42 af43 cs5 ef
class-map match-any silver-hi
description Class 2 traffic, majority of traffic, in-profile, exp4
match ip dscp af31
match access-group 110
class-map match-any silver-low
description Class 2 traffic, the bad bad boys, out-of-profile, exp3
match ip dscp af32
match access-group 111
class-map match-any default
description Class 4 traffic, good luck, what ever is left, best effort, exp0
match access-group 112
!
!
policy-map mpls-out
class gold
priority 768
class silver-hi
set ip dscp af31
bandwidth remaining percent 40
class silver-low
set ip dscp af32
bandwidth remaining percent 30
class class-default
fair-queue
set ip dscp default
interface Multilink123
ip address XX.XX.XX.XX 255.255.255.252
ip flow ingress
no peer neighbor-route
ppp chap hostname w0u04597-1706597
ppp multilink
ppp multilink links minimum 1
ppp multilink interleave
ppp multilink group 123
ppp multilink fragment disable
max-reserved-bandwidth 95
service-policy output mpls-out
If you are experiencing voice quality issues, ensure that you have not over provisioned
your CUCM location bandwidth to that of your LLQ in your policy-map. Here is usually
what our 5 min averages are, we aren’t getting close to the 768 specified.
Class-map: gold (match-any)
10748542 packets, 666088992 bytes
5 minute offered rate 20000 bps, drop rate 0 bps
Match: ip dscp af41 (34) af42 (36) af43 (38) cs5 (40) ef (46)
10748541 packets, 666088868 bytes
5 minute rate 20000 bps
Priority: 768 kbps, burst bytes 19200, b/w exceed drops: 0
Are you trusting CallManager/Unity switchports for DSCP?
Here is my CCM port config
no ip address
mls qos trust cos
switchport
switchport access vlan 3
From the CM port it goes out this int to the PIP router
interface GigabitEthernet1/1
description Connection to ENG-3845-01 Gi0/0
no ip address
mls qos trust cos
switchport
switchport access vlan 3
PIP LLQ config
class-map match-any gold
description Class 1 traffic, Voip, Video, real-time traffic, exp5
match ip dscp af41 af42 af43 cs5 ef
match access-group 120
class-map match-any mci_silver_low
class-map match-any silver-sterling
description Class 2 web crawler traffic to India, in-profile, policed traffic, exp3
match access-group 109
class-map match-any silver-hi
description Class 2 traffic, majority of traffic, in-profile, exp4
match ip dscp af31
match access-group 110
class-map match-any silver-low
description Class 2 traffic, the bad bad boys, out-of-profile, exp3
match ip dscp af32
match access-group 111
class-map match-any default
description Class 4 traffic, good luck, what ever is left, best effort, exp0
match access-group 112
!
!
policy-map mpls-out
class gold
priority 4096
set ip dscp ef
class silver-sterling
police 2097000
set ip dscp default
class silver-hi
set ip dscp af31
bandwidth remaining percent 40
class silver-low
set ip dscp af32
bandwidth remaining percent 30
class class-default
fair-queue
set ip dscp default
Any info would be great!
Download